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Chapter 1. CFX-Solver Manager Basics
CFX-Solver Manager is a graphical user interface that allows you to set attributes for your CFD calculation, control
the CFX-Solver interactively, and view information about the emerging solution. As an alternative to using the
CFX-Solver Manager interface, you can also operate CFX-Solver from the command line, which is particularly
useful for batch mode operations (see Chapter 11, Starting the CFX-Solver from the Command Line (p. 109)).

This chapter describes:

• Starting CFX-Solver Manager (p. 1)

• Working with the CFX-Solver Manager Interface (p. 1)

• Customizing CFX-Solver Manager (p. 5)

Starting CFX-Solver Manager
You can start CFX-Solver Manager in different ways:

• Using ANSYS Workbench. For details, see ANSYS CFX in ANSYS Workbench (p. 43) in the ANSYS CFX
Introduction.

• Using the CFX-Launcher. For details, see Using the CFX Launcher (p. 41) in the ANSYS CFX Introduction.

• If CFX-Pre is launched and a simulation is open, you can launch CFX-Solver Manager by writing a solver file.
For details, see Write Solver Input File Command (p. 46) in the ANSYS CFX-Pre User's Guide.

Working with the CFX-Solver Manager Interface
CFX-Solver Manager is an interface that displays a variety of results as outlined below. It is generally used to view
the plotted data during problem solving.

Figure 1.1. CFX-Solver Manager Interface

By default, the convergence history plots appear to the left or the top. The text output window appears to the right
or the bottom. There is an adjustable split between the windows that is oriented either horizontally or vertically,
depending on the aspect ratio of the entire CFX-Solver Manager window (also adjustable).

1

Release 12.0 - © 2009 ANSYS, Inc. All rights reserved.

Contains proprietary and confidential information of ANSYS, Inc. and its subsidiaries and affiliates.



The following parts of the interface are described next:

• Workspace Selector (p. 2)

• Convergence History Plots (p. 2)

• Text Output Window (p. 3)

• Multi-Configuration Run History Page (p. 3)

Workspace Selector
The Workspace selector is a drop-down list that shows the current run name and enables you to switch between
runs.

1. Click the arrow  of the Workspace drop-down list.

2. Select the run you want to view.

Convergence History Plots
Convergence history plots are available on various tabs, with monitors of a certain type under each tab. These are
controlled from the Monitors Menu (p. 107) and configured from the Monitor Properties (p. 93) dialog (which you
access by right-clicking in the plot area).

The main area of convergence history plots shows the plotted value of each variable (typically, an RMS residual)
at each timestep, according to the selected monitor (for example, Momentum and Mass, Heat Transfer, etc.). To
switch between these views, right-click in the convergence history plot and select Switch Residual Mode.

You can edit the plot line variables by selecting Workspace > Workspace Properties from the main menu. For
details, see Workspace Menu (p. 91).

You can click any of the plot lines to view the value at the nearest timestep. The legend that appears below each
history plot shows the variable associated with each plot line.

Printing an Image of the Convergence History
You can print a picture of the convergence history plot:

1. Right-click in the convergence history plot and select Print.

2. Configure the printer as required.

3. Click Print.

Saving a Picture of the Convergence History
You can save a picture of the convergence history plot:

1. Right-click in the convergence history plot and select Save Picture.

The Image File dialog box is displayed.

2. In the Image File dialog box, select a location to which to export the image.

3. Under File name, enter the name for the file.

4. Under File type, select the format to export.

5. Click Save.

Exporting Plot Data
Data from any plot monitor can be exported. The data format for the exported file consists of comma-delimited
entries. This data can be used as the basis for import to another application.

1. Right-click in the convergence history plot.

2. Select Export Plot Data.

The Export dialog box is displayed.

3. Select a location to which to export the data.
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4. Under File name, enter the name for the file.

5. Under File Type, select the format to export.

Files are saved with a .csv extension by default, but this can be modified as required.

6. Click Save.

Note that monitor data can also be exported using the command-line application cfx5mondata.

Exporting Monitor Data from the Command Line
The cfx5mondata application provides a command-line driven mechanism to query or extract monitor data from
the directory in which a solver run is executing, a CFX-Solver Results file, or a monitor file. When extracted,
monitor data are written in a comma-separated format that is similar to the output generated by the Exporting Plot
Data capability.

To obtain a complete list of available command line options for cfx5mondata type the following command into
a UNIX terminal or a suitable Windows command line and press Return or Enter:

cfx5mondata –help

Text Output Window
The text output window lists simulation information and the progress of a solution, including information such as
physical properties, boundary conditions and various other parameters used or calculated in creating the model. All
text is written to the output file automatically. For details, see CFX-Solver Output File (p. 28).

For an ANSYS Multi-field run, an additional text output window is created that shows the text output from the
ANSYS solver. In this case, you can switch between the CFX output file and the ANSYS Out File by using the tabs
at the top of the window. For details on ANSYS Multi-field runs, see Coupling CFX to an External Solver: ANSYS
Multi-field Simulations (p. 295).

The right-click menu provides functionality to find, select and copy text, manage bookmarks as well as manage the
monitor.

Saving the Text to File
The text of the output window can be saved to file (even when a run is in progress):

1. Right-click in the text output window.

2. Select Save As.

3. Select a file location to save the text file.

4. Enter a file name for the text file.

5. Click Save.

Searching for Text
The output window can be searched for specific text:

1. Right-click in the text output window and select Find.

2. In Find, enter words to find.

3. Select or clear the Case Sensitive check box.

4. Click Previous or Next to search up or down from the current location. An icon will appear to the left of the
Find label if the text could not be found in the file when searching in the selected direction from the current
location.

Multi-Configuration Run History Page
A multi-configuration simulation has several workspaces:

• One workspace for each analysis. Each of these workspaces has a convergence history plot and a text output
window that resemble those of a single-analysis simulation.

3
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• One workspace that shows an overview of the multi-configuration simulation. There is a run history page that

lists each simulation step (analysis) and its overall status (  = in progress,  = complete,  = error), and
a text output window that provides the status of each simulation step.

A sample run history page is shown below:

In this case, there are two simulation steps: a steady state analysis and a transient analysis. The steady state analysis
(simulation step 1) is complete, and the transient analysis (simulation step 2) is in progress. Because the transient
analysis is in progress, the overall simulation is marked as being in progress. When the transient analysis completes,
the overall simulation will be marked as being complete.

You can switch to the workspace for a simulation step by right-clicking the simulation step in the run history page
and selecting Open Workspace from the shortcut menu.

The shortcut menu commands on the run history page are:

• Open Workspace

This switches to the workspace view for the selected simulation step.

• Post Process Results

This command is available when running CFX-Solver Manager in standalone mode. It launches CFD-Post with
the results of the selected simulation step.

• Post Process Results and Shutdown

Same as Post Process Results, except CFX-Solver Manager closes after CFD-Post is launched.

• Stop Run

This command stops the CFX-Solver from computing the results for the selected simulation step.

• Display Termination Message

For a simulation step that has completed, this command displays a summary of the termination status.

An alternative way to switch between the various workspaces is to choose a workspace from the Workspace
drop-down list:
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In the drop-down list, the analyses of a multi-configuration simulation are listed below the name of the run, and are
indented to show that they belong to the run. Selecting the name of the run switches to the run history page.

Customizing CFX-Solver Manager
The size and position of most windows in CFX-Solver Manager can be changed to customize the appearance,
function and placement of objects. Toolbars can also be moved as required; just click and drag the left edge of a
toolbar to a new position. (The toolbar orients itself vertically if places along the left or right side of the application.)

Settings such as window sizes, selected plot variables, and other settings specific to the current view can be saved
as a layout file (*.mst). For example, you could select a plot variable and configure the current view. You could
then save the layout and restore it at a later time. For details, see Workspace Menu (p. 91).
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Chapter 2. Working with Solver Manager
This chapter describes procedures for starting specific types of runs using CFX-Solver Manager. The steps to take
depend on whether an initial values file is required or not, and whether the CFX-Solver input file name has already
been passed to the CFX-Solver Manager.

This chapter describes:

• Solver Run Overview (p. 7)

• The Define Run Dialog Box (p. 7)

• Run Output Results (p. 13)

• Parallel Run (p. 14)

• Restarting a Run (p. 16)

• ANSYS Multi-field Run (p. 18)

Solver Run Overview
To run a case, review the settings in the File > Define Run dialog box. The number of settings that you need to
change or specify depends on the case:

• In some cases, you need only to specify the name of a CFX-Solver input file (*.def or *.mdef). For cases
that require initialization from previous results, you also need to specify the name of a results file (*.res or
*.mres).

• You can choose to run in serial or parallel:

• Serial run is the default way of running a CFD case. During a serial run, all computation is done by a single
process running on one processor.

• Parallel run divides computation into more than one process and is done on more than one processor in a
single machine (local parallel processing) or on more than one machine (distributed parallel processing).

• You can configure an ANSYS Multi-field run, which allows the coupling of the CFX-Solver with the ANSYS
Solver in order to execute cases which require two-way fluid-structure interaction.

• For simulations with multiple configurations, you can make global and configuration specific settings. Note
that ANSYS Multi-field runs are not supported for multi-configuration simulations.

When you have finished setting up the case, click Start Run.

Tip
In ANSYS Workbench you have the option of clicking Save Settings to save the settings of the Define
Run dialog box to the Solution cell (some of these settings are visible in the Solution cell's Properties).
By saving the settings in this way, you can configure the run from CFX-Solver Manager, but start the
run from ANSYS Workbench (by updating the Solution cell).

Details of making these changes with the Define Run dialog box are described in the next section.

The Define Run Dialog Box
You access the Define Run dialog box from CFX-Solver Manager by clicking File > Define Run.

The tabs of the Define Run dialog box are described in the following sections:

• Solver Input File Name (p. 8)

• Edit Configuration (p. 8)

• Run Definition Tab (p. 8)

• MultiField Tab (p. 9)

• Partitioner Tab (p. 10)

• Solver Tab (p. 12)
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• Interpolator Tab (p. 12)

Solver Input File Name
Ensure that the name of a CFX-Solver input file (extension .def or .mdef) is specified under Solver Input File.

The name will be set automatically if:

• You have completed the Write Solver Input File dialog box in CFX-Pre.

• You have started CFX-Pre from the command line using the -interactive and -def or -mdef options.
For details, see Starting the CFX-Solver from the Command Line (p. 109).

CFX-Solver input file names must not contain spaces when run with an associated ANSYS input file (.inp).

Note
When specifying or editing the Solver Input File by typing from the keyboard, you must click Reload
run settings from file  to have the changes take effect.

Edit Configuration
If a multi-configuration definition or results file (*.mdef or *.mres, respectively) is selected as the CFX-Solver
Input file, then the settings on the tabs described below can be made on a simulation-wide or per-configuration
basis. This is done by choosing either Global Settings or a specific configuration name for the Edit Configuration
option.

Note
When Global Settings are made these settings are inherited by all configurations. You can then override
any setting for a specific configuration but it is important to note that in this situation the remainder of
the settings for the configuration will not be inherited from Global Settings.

Run Definition Tab
1. Select Initial Values Specification so that you can specify one or more sources of initial values. Note that for

cases with multiple configurations, initial values specifications are not valid for Global Settings. For each
source of initial values (most runs only require one), do the following:

a. Click New  to create an initial values object.

b. Select an initial values object from the list and select either the Results File or Configuration Results
option for Initial Values > Option.

1. If you selected the Results File option, then specify the file name of a file from which initial values
should be used.

2. If you selected the Configuration Results option, then specify the name of the configuration from
which initial values should be used. Note that this option is only available in the context of
multi-configuration simulations. It allows the introduction of dependencies on initial values that will
become available at run time.

c. The Use Mesh From setting determines which mesh is used for the analysis: the one specified in the
Solver Input File option, or the one in the Initial Values. The mesh from the Initial Values File can only
be used in a limited set of circumstances. See Using the Mesh from the Initial Values File (p. 84) in
ANSYS CFX-Solver Modeling Guide for details.

d. Select Continue History From if you want to continue the run history (convergence history, monitor
plots, time and time step counters, etc…) and use the smoothest restart possible from the selected Initial
Values File. The run will continue from the one contained the specified initial values object. Note that
the run history will reset if Continue History From is not selected.

Full details of the settings can be found in Reading the Initial Conditions from a File (p. 81) in ANSYS
CFX-Solver Modeling Guide.
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2. Set Type of Run to Full or Partitioner Only.

• Full runs the partitioner if applicable, and then runs Solver.

• Partitioner Only is used for parallel runs only and does not run Solver. This writes a .par file.

3. Select or clear Double Precision or Executable Selection > Double Precision. This setting will determine
the default (single or double) precision of the partitioner, solver and interpolator executables. For details on
the precision of executables, see Double-Precision Executables (p. 123). The precision of the solver and
interpolator executables can be set individually on the Solver and Interpolator tabs.

4. Configure the Parallel Environment as required.

5. If required, under Run Environment, set the working directory.

6. If required, select Show Advanced Controls to display other tabs.

Additional information is provided in the next section, Parallel Environment, and in Initial Condition Modeling (p.
71) in ANSYS CFX-Solver Modeling Guide.

Parallel Environment
For a distributed parallel setup, specify the number of partitions assigned to each host. If choosing a specified
partition weighting (under Partitioner), click directly on the partition weight number to edit it. There should be one
weight entry per partition.

1. Under Parallel Environment, select a Run Mode.

2. Configure the mode as required.

Run Mode determines whether the run is serial (the default when defining a run in which a problem solved as
one process), or parallel (problem split into partitions).

• Serial run (the default) requires no additional configuration.

• Parallel Run (p. 14)

MultiField Tab
The MultiField tab is used for launching ANSYS Multi-field runs and only appears if the specified CFX-Solver
input file has External Solver Coupling set to ANSYS MultiField or ANSYS Multifield via Prep7.
When this setting is enabled, the CFX-Solver Manager can be used to launch a complete ANSYS Multi-field run,
including processing the multi-field commands (where appropriate) and launching CFX and ANSYS solvers. For
details, see Pre-Processing (p. 295) in the ANSYS CFX-Solver Modeling Guide. A description of the different run
modes and settings can be found in ANSYS Multi-field Run (p. 18).

The following table outlines various settings available on MultiField tab. The settings are marked as required or
optional based on the MFX run mode chosen for the ANSYS Multi-field run.

MFX Run Mode a

Settings for MultiField Tab Process Input
File only

Start CFX

only b
Start ANSYS

only

Start ANSYS
and CFX
(default)

RequiredRequiredRequired
Mechanical application input file
c

Input File

OptionalOptionalProcess ANSYS Input File d

OptionalOptionalOptional
Restart ANSYS Run e

Previous Run DB

RequiredRequired
MultiField Solver Settings f

ANSYS Install Directory
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MFX Run Mode a

Settings for MultiField Tab Process Input
File only

Start CFX

only b
Start ANSYS

only

Start ANSYS
and CFX
(default)

Additional Arguments ANSYS License

Required

MultiField Remote Solver Settings

Host Name

Host Port

aThe default setting for MFX Run Mode is Start ANSYS and CFX that launches the complete MFX run, including starting the ANSYS
Solver. The other modes allow you to start just one or other solver, or to process the multi-field commands only using the specified ANSYS
Input File. The latter option is available only if the specified CFX-Solver input file has External Solver Coupling set to ANSYS MultiField.
bStart CFX only: If the MFX Run Mode setting is Start CFX only, then no further ANSYS settings are required. However, when the
CFX-Solver is started, it needs to know how to communicate with the ANSYS Solver that must have already been started elsewhere (that is, on
another machine), and so Host Name and Host Port must be provided. The host name is the machine on which the ANSYS Solver was started.
The host port number is determined by the ANSYS Solver when it starts, and can be read from the file <jobname>.port in the ANSYS
working directory once the ANSYS Solver has started.
cMechanical Input File: For all MFX run modes other than Start CFX only, the ANSYS input file must be provided. This will be read
from the CFX-Solver input file specified on the Run Definition tab; however, you may choose to change this if the file is now in a different
location, or if you want to use a different input file.
dProcess ANSYS Input File: For the MFX run modes which will start the ANSYS Solver (Start ANSYS and CFX and Start ANSYS
only), it is necessary to select Process ANSYS Input File if the specified ANSYS input file does not already contain the multi-field set-up
(the MF commands required for the run), and if you want the multi-field set-up to be read from the CFX-Solver input file. This option will not
be available if the specified CFX-Solver input file has External Solver Coupling set to ANSYS MultiField via Prep7, as in this case
the CFX-Solver input file will not contain any multi-field set-up. For details, see Processing the ANSYS Input File (p. 21).
eRestart ANSYS Run: If the run is a restart from a previous ANSYS Multi-field run, then you need to select Restart ANSYS Run and supply
the name of the database (*.db or *.rdb) from the previous run. This is not necessary if you are starting the CFX part of the ANSYS Multi-field
run from an existing results file (for example, to provide initial conditions).
fMultiField Solver Settings: If the ANSYS Solver is to be started, you will need to specify the following settings:

• ANSYS Install Directory: On UNIX systems, you may need to manually specify where the ANSYS installation is if it is not in the default
location. In this case, you must provide the path to the v120/ansys directory.

• Additional Arguments: You can use this setting if you want to pass the ANSYS Solver additional arguments. Whatever you specify here
will be added to the command which starts the ANSYS Solver.

• ANSYS License: This setting is available when running CFX-Solver Manager in standalone mode; it used to select which product variable
(license) you want the ANSYS Solver to use. When running in ANSYS Workbench, the ANSYS License setting is not available. In this
case, the license used by the ANSYS solver is selected by ANSYS Workbench. The latter selects licenses according to the settings found
under Tools > Options > Licensing > License Management. For details, see the ANSYS Workbench documentation.

Partitioner Tab
Use the Partitioner tab to configure the mesh partitioning options.

Note
An existing partition file cannot be used if the simulation involves either the Monte Carlo or Discrete
Transfer radiation models.

Partitions may be viewed prior to running CFX-Solver. For details, see CFX Partition File (p. 63).

1. Select the Partitioner tab.

If this is not available, ensure Show Advanced Controls is selected in the Run Definition tab.

2. If required, under Initial Partition File, click Browse  and select the partition file to load.

The *.par file is only required if a model has already been partitioned. The number of partitions in the
partitioning file must be the same as that selected on the Run Definition tab.

Note
A partition file generated in ANSYS CFX 11.0 or earlier versions is not supported in ANSYS CFX
12.0. If such a file is used in ANSYS CFX 12.0, then an error message is generated.
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3. Under Run Priority, select Idle, Low, Standard or High. For a discussion of these priorities, see The
cfx5control Application (p. 129).

4. If required, select the Use Large Problem Partitioner option, which is available on 64-bit platforms only.
This option starts the large problem partitioner which can partition problems up to 2^31-1 elements. This
partitioner uses 64-bit integer and logical variables so it will allocate more memory than the default partitioning
executable. For details, see Large Problem Partitioner Executables (p. 123).

5. Under Partitioning Detail, choose a Partition Type and configure it.

Depending on the selected partition type, various options must be configured. Partition types include:

• Multilevel Graph Partitioning Software - MeTiS (p. 347) in the ANSYS CFX-Solver Modeling Guide.
When first running in parallel, it is recommended that Partition Type be set to MeTiS.

• Recursive Coordinate Bisection (p. 347) in the ANSYS CFX-Solver Modeling Guide

• Optimized Recursive Coordinate Bisection (p. 347) in the ANSYS CFX-Solver Modeling Guide

• Directional Recursive Coordinate Bisection (p. 348) in the ANSYS CFX-Solver Modeling Guide

• User Specified Direction (p. 348) in the ANSYS CFX-Solver Modeling Guide

• Simple Assignment (p. 347) in the ANSYS CFX-Solver Modeling Guide

• Radial (p. 349) in the ANSYS CFX-Solver Modeling Guide

• Circumferential (p. 349) in the ANSYS CFX-Solver Modeling Guide

• Junction Box (p. 349) in the ANSYS CFX-Solver Modeling Guide

6. If required, configure the Partition Weighting as described below.

7. If required, configure the Multidomain Option. You can select from the following options:

• Independent Partitioning: Each domain is partitioned independently into the specified number
of partitions.

• Coupled Partitioning: All domains that are connected together are partitioned together. Note that
solid domains are still partitioned separately from fluid/porous domains. Coupled partitioning often leads
to better scalability, reduced memory requirements, and sometimes better robustness, than independent
partitioning because there are fewer partition boundaries.

For details, see Selection of the partitioning mode for multi-domain cases (p. 359) in ANSYS CFX-Solver
Modeling Guide.

When the coupled partitioning option is activated, you can further choose to set the Multipass Partitioning
option. The Transient Rotor Stator option is relevant only for simulations having transient rotor
stator interfaces. It uses a special multipass algorithm to further optimize the partition boundaries. This
approach generates circumferentially-banded partitions adjacent to each transient rotor stator interface,
which ensures that interface nodes remain in the same partition as the two domains slide relative to each
other. Away from the interface, the partitioning is handled using whichever method is specified for the
Partition Type.

8. If required, under Partitioner Memory, adjust the memory configuration. For details, see Configuring Memory
for the CFX-Solver (p. 13).

Partitioning Weighting
As discussed below, partitions can be weighted in different ways. The default setting is Automatic.

• Uniform

• Specified

• Automatic

Uniform
Assigns equal-sized partitions to each process.
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Specified
Requires Run Definition to be configured with individual partition weights.

Partition Weights is added to the parallel environment. This allows partition weights to be entered. When more
than one partition is assigned to any machine, the number of partition weight entries must equal the number of
partitions. The partition weight entries should be entered as a comma-separated list. For a distributed run like the
following:

Partition Weights# of PartitionsHost

21Sys01

2, 1.52Sys02

11Sys03

Sys01 is therefore a single partition and the weight is 2. Sys02 has two partitions and they are individually
weighted at 2 and 1.5. The final system has a single partition with a weight of 1.

If partition weight factors are used, the ratio of partition weights assigned to each partition controls the partition
size.

Once started, the run progresses through the partitioning, and then into the solution of the CFD problem. Extra
information is stored in the CFX output file for a parallel run. For details, see Partitioning Information (p. 46).

Automatic
Calculates partition sizes based on the Relative Speed entry specified for each machine in the hostinfo.ccl
file.

Machines with a faster relative speed than others are assigned proportionally larger partition sizes. The entry of
relative speed values is usually carried out during the CFX installation process, and accurate entries for relative
speed can significantly optimize parallel performance.

Solver Tab
1. Select the Solver tab.

If this is not available ensure Show Advanced Controls on the Run Definition tab is selected.

2. Under Run Priority, select Idle, Low, Standard or High. For a discussion of these priorities as well as
how you can change them after the execution of the solver has started, see The cfx5control Application (p. 129).

3. If required, from Double Precision Override or Executable Settings > Double Precision Override, select
or clear Double Precision. This setting for the solver will override the corresponding specification, if set, on
the Run Definition tab.

For details, see Double-Precision Executables (p. 123).

4. If required, under Solver Memory, adjust the memory configuration. For details, see Configuring Memory
for the CFX-Solver (p. 13).

5. Under Custom Solver Options, click Browse  and select a custom executable.

This is done when using a custom solver executable. In addition, any command line arguments that must be
supplied to the program can be entered under Solver Arguments.

Interpolator Tab
1. Select the Interpolator tab.

If this is not available ensure Show Advanced Controls in Run Definition tab is selected.

2. Under Run Priority, select Idle, Low, Standard or High. For a discussion of these priorities, see The
cfx5control Application (p. 129).
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3. If required, from Double Precision Override or Executable Settings > Double Precision Override, select
or clear Double Precision. This setting for the interpolator will override the corresponding specification, if
set, on the Run Definition tab.

For details, see Double-Precision Executables (p. 123).

4. If required, under Interpolator Memory, adjust the memory configuration. For details, see Configuring
Memory for the CFX-Solver (p. 13).

Configuring Memory for the CFX-Solver
There may be instances when the CFX-Solver fails due to unsufficient memory. You can determine that the
CFX-Solver failed in this way as well as which of the interpolator, partitioner, or flow solver steps failed by reviewing
the CFX-Solver Output file. In this case you will be required to adjust the memory configuration of the appropriate
CFX-Solver step. The methods available for adjusting memory are:

1. Memory Allocation Factor: Use this method to modify the memory allocation for the CFX-Solver step as a
whole. For example, a value of 1.05 for Memory Allocation Factor increases memory allocation by 5% and
a value of 1.1 increases memory allocation by 10%.

2. Detailed Memory Overrides: Use this method to adjust Real Memory, Integer Memory, Character Memory,
Double Memory and Logical Memory as required.

The number of words of memory can be specified, or a memory multiplier can be used. Use a unit of M for
mega-words, K for kilo-words, or X for a memory multiplier. For example, 2 X doubles the memory allocation
and 15 M means 15 million words of memory. If a value is not specified for a particular type of memory, the
value calculated by the Solver is used. If a value is entered, it overrides the automatic estimate made by the
Solver.

3. Catalogue Size Override: If the solver fails with an *.out file containing the error message ***
INSUFFICIENT CATALOGUE SIZE ***, increase the Catalogue Size Override  setting to a value above
1 until the solver runs. This parameter has the same syntax as the Detailed Memory Overrides above. For
example, you can scale the default size by using a scale factor greater than 1, such as 1.05 X.

For details, see Starting the CFX-Solver from the Command Line (p. 109).

Run Output Results
Once the run definition is complete and the run is started, a new workspace is created and the Workspace drop
down list will contain an entry based on the name of the Solver Input File. For example, using the Solver Input
File named case.def, the workspace entry will be similar to Run case 001. Note that the integer index is
identical to the index used for the text output and result files for the run. For multi-configuration simulations, one
additional workspace is created as each new configuration is executed. The Workspace drop down list will contain
entries based on the names of the configurations

Most workspaces contain a mixture of plot and text output monitors that are updated by the CFX-Solver as the
simulation progresses. By default, appropriate monitors are automatically created in the workspace for the particular
type of simulation you are running. These include:

• • Plot monitors showing the normalized residuals (which should decrease as the solution progresses) for each
equation being solved, plus any user-defined monitor values.

• • A text monitor showing the contents of the CFX-Solver Output file. For details, see CFX-Solver Output
File (p. 28).

No plot monitors are generated for the simulation-level workspace (named according to the Solver Input File)
created for multi-configuration simulations. This workspace includes one text monitor, showing the contents of the
CFX Multi-Configuration Output File. For details, see CFX Multi-Configuration Output File (p. 64).

When the CFX-Solver stops running, a dialog is displayed that indicates whether the run completed normally or
not. Additional information regarding the reasons for terminating the run are presented in the text output window.

After a run has finished:

• Define a new run by following the earlier procedure. For details, see Define Run Command (p. 85)
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• Calculate more timesteps for the original run. For details, see Restarting a Run (p. 16).

• View results in CFD-Post (provided that the CFX-Solver produced a results file and did not fail). For details,
see Overview of CFD-Post (p. 1) in the ANSYS CFD-Post User's Guide.

• Print residual plots in the convergence history plots. For details, see Printing an Image of the Convergence
History (p. 2).

• Add comments to the saved version of the text in the text output window. For details, see Starting the CFX-Solver
from the Command Line (p. 109).

• Export results in a format suitable for post-processors other than CFD-Post. For details, see File Export
Utility (p. 131).

• Quit CFX-Solver Manager by selecting File > Quit. This does not stop the CFX-Solver calculation. Additionally,
CFX-Solver Manager can be reopened at any time. For details, see File Menu (p. 85).

The CFX Tutorials describe how to use the CFX-Solver Manager step-by-step for several different cases. If you
are a new user, you should try at least the first few of these.

Parallel Run
Note
CFX-Solver can be run in parallel only if an appropriate license has been purchased.

Information on a parallel run is explained in more detail:

• Overview (p. 14)

• General Procedure (p. 14)

• Configuring a Parallel Run (p. 14)

Overview
There are several parallel run modes, including PVM (Parallel Virtual Machine) and MPI (Message Passing Interface)
communication libraries. Both are simply libraries which allow the flow solver processes to communicate with each
other. An open-source version of MPI, MPICH, implemented at Argonne National Labs, allows communication
over standard TCP/IP networks, as well as through shared memory. Proprietary, vendor specific versions of MPI
are available on some platforms (32-bit Linux, 64-bit Linux and HP-UX ) and support a wider array of high speed
network devices, as well as Shared Memory communication.

General information on setting up a parallel run and advice on obtaining optimal parallel performance is available.
For details, see Using the Solver in Parallel (p. 345) in the ANSYS CFX-Solver Modeling Guide.

Individual machines may need to be configured to run in parallel.

General Procedure
To run CFX-Solver in parallel, the following procedure must be followed:

1. Partition the mesh into the appropriate number of partitions.

2. Run CFX-Solver on the partitioned problem.

These two jobs can be done either as one composite run, or as two separate jobs.

Configuring a Parallel Run
1. Follow the procedure for a serial run.

For details, see Solver Run Overview (p. 7).

2. Under Run Mode, select a parallel method:

• Local Parallel Setup (p. 15)

• Distributed Parallel Setup (p. 15)
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Local Parallel Setup
Select a local parallel run if running a problem with two or more processors on the local machine.

Any number of partitions between 2 and 512 can be selected. When running the job in the CFX-Solver, the
computation is divided into this number of processes. For details, see Partitioner Tab (p. 10). Solver allows further
changes. For details, see Solver Tab (p. 12).

1. Select one of the local parallel run modes (for example, HP MPI Local Parallel or MPICH Local
Parallel). Which parallel run modes you can select depends on the hardware and operating system on which
you are running.

2. Click Add Partition  or Remove Partition  to increase or decrease the number of partitions.

Partitions may need to be configured based on partition weighting. For details, see discussion in Partitioner
Tab (p. 10).

Distributed Parallel Setup
Select a distributed parallel option to run a problem on two or more computers.

Overview
To configure a distributed parallel run, a file named hostinfo.ccl must exist in the <CFXROOT>/config/ CFX
directory on the master node and be readable by all users of the software. This file is a database containing information
about available nodes and where ANSYS CFX is installed on each of them.

Note
• If running machines as slave nodes, ensure rsh service is installed and working on each of those

machines (many Windows machines do not already have an rsh service installed). If running MPICH2
on Windows, additional steps are required. For details, see the installation documentation.

• MPICH cannot be used with a mixture of UNIX and Windows machines.

• The cfx5parhosts utility operates on the hostinfo.ccl file; in releases prior to Release 12.0, it
operated on the hosts.ccl file. This change was made necessary by a CCL change.

Selecting Parallel Hosts
Simulations can be run on parallel host machines by selecting any available host for parallel processing.

1. Click Insert Host .

The Select Parallel Hosts dialog box is displayed.

2. Select a host from the list of available machines.

3. Click Add.

Ensure the name of current machine is included.

4. Configure each host as required. For details, see Configuring a Host (p. 15).

Configuring a Host
Each parallel host can be configured independently.

1. In Parallel Environment, under Host Name, select the host to configure.

2. Click Add Partition  or Remove Partition  to increase or decrease the number of partitions.

Partitions may need to be configured based on partition weighting. For details, see discussion in Partitioner
Tab (p. 10).
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Restarting a Run
A CFX-Solver run that has stopped may be restarted for the following reasons:

• The CFX-Solver stopped prematurely, at the user’s request, and now needs to continue running.

• More timesteps are needed to extend the duration of a transient analysis, or more iterations are needed to reach
a required level of convergence for a steady state analysis.

Such restarts are particularly useful because they continue the analysis from where it left off, which is often much
more efficient than re-running the analysis from the original CFX-Solver Input file.

The following discussions describe restarting simulations from CFX-Solver Results files using the same or modified
settings:

• Restart Procedure (p. 16)

• Restart Details (p. 16)

Restart Procedure
1. Select File > Define Run.

2. Select, under CFX-Solver Input File, the CFX-Solver Results file of the previous run.

3. Configure the Define Run dialog box as required.

4. Click Start Run.

Tip
You may also select Workspace > Restart Run to restart the analysis presented in the active
workspace. For details, see File Menu (p. 85).

A new workspace that contains the information relevant for that restart, is created for each restart.

Restart Details
Restarting a run should have little effect on the convergence history and no effect on the final results. Additional
information regarding several types of restarts is presented below.

• Runs Using Mesh Adaption (p. 16)

• Runs After Physical Model or Solver Parameter Changes (p. 16)

• Runs after Topology or Mesh Changes (p. 17)

• Multi-Configuration Simulations (p. 17)

Runs Using Mesh Adaption
Restarting a run which uses mesh adaption has no effect on the final results. If the maximum number of adaption
steps has been specified, then CFX-Solver determines how many adaption steps were completed in the initial run
when determining how many adaption steps remain.

Runs After Physical Model or Solver Parameter Changes
You may change CCL settings before continuing from a previously generated CFX-Solver Results file. This is,
however, not handled as a restart. For this case, the previously generated results file is first read into CFX-Pre,
settings are modified, and a new CFX-Solver Input file is written. Note that this file contains the updated CCL, and
the final mesh and mesh adaption parameters from the previous run. A new run is then defined using:

• The newly generated file as the Solver Input File,

• The previously generated results file in an Initial Values definition.
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Tip
On the details view of Initialization in CFX-Pre, set the initial conditions for the variables contained in
the old results file to Automatic. This will ensure that they will be restarted.

Changing the fundamental physics of an analysis, such as the fluids and/or materials involved, is not recommended.
Do not change the reference pressure.

Note
If a run which requires wall scale to be calculated is restarted, and a wall scale-related setting was changed
(for example, a free slip wall changed to a no-slip wall), wall scale will not automatically be recalculated
if its calculation was terminated in a previous run. To force it to be recalculated, set the expert parameter
ignore solve flag on restart to true. For details on expert parameters, see CFX-Solver
Expert Control Parameters (p. 363) in ANSYS CFX-Solver Modeling Guide.

Additional information on initial conditions is available in the Initialization (p. 123) in the ANSYS CFX-Pre User's
Guide. More details about using Initial Values File in the Define Run dialog box in CFX-Solver Manager are
available in Reading the Initial Conditions from a File (p. 81) in ANSYS CFX-Solver Modeling Guide.

Runs after Topology or Mesh Changes
If you make changes such as:

• recreating the mesh with different parameters, mesh controls or inflated boundaries,

• changing the underlying geometry,

• changing the connectivity of the geometry (such as specifying domains or subdomains differently),

• adding a new domain or subdomain. or

• changing the name or location of any boundary condition, including the default boundary condition. Note that
changing the type of boundary condition is not treated as a topology change,

then you can continue the run as described in Runs After Physical Model or Solver Parameter Changes (p. 16).
However, in this case you must set Use Mesh From to Solver Input File.

Note that changing the type of boundary condition is not treated as a topology change.

Multi-Configuration Simulations
Multi-configuration simulations may only be restarted from a multi-configuration results (.mres) file. The simulation
will continue from the final simulation step contained in the specified results file as follows:

• If all active configurations in that simulation step completed successfully, then the new run will begin with the
next simulation step.

• If all active configurations in that simulation step failed to complete successfully, then the new run will attempt
to complete the final simulation step and execute the configurations that are still active. This occurs if the
simulation is stopped prematurely.

Care is required when CCL changes are made before continuing a multi-configuration simulation. This is because
CCL is propagated (that is re-used) from the multi-configuration results (*.mres) and most recently created
configuration results (*.res) files. In particular:

• Global CCL changes (for instance, LIBRARY, SIMULATION CONTROL contents including EXECUTION
CONTROL, etc…) must be applied to the multi-configuration results file.

• Configuration specific CCL changes (such as FLOW contents) must be applied to the most recently generated
configuration results files.

Important
Previously created configuration results (*.res) files are required for accurate CCL propagation (as
noted above) and to resolve configuration dependent initial values, as defined in Run Definition Tab (p.
225) in ANSYS CFX-Pre User's Guide. Paths to these results files are stored and re-used when restarting
multi-configuration simulations, and these paths are relative to the working directory. For example, the
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stored path for the first run of the configuration name Configuration1 corresponding to the
multi-configuration results file named mySim_001.mres is:
mySim_001/configuration1_001.res.

Use of relative paths allows the directories (and files) for a multi-configuration simulation to be transferred
to another working directory (for example, on another file system) to perform a restart. Restarts are not
possible if the required directories (and files) have not been transferred to the desired working directory.

Note
If a restart is performed using a specific configuration’s result file (for example,
configuration1_001.res), then only that configuration will continue execution, but the
multi-configuration simulation will not continue.

ANSYS Multi-field Run
A tutorial is provided to demonstrate an ANSYS Multi-field run. For details, see Chapter 23, Oscillating Plate with
Two-Way Fluid-Structure Interaction.

Note
ANSYS Multi-field runs can only be launched if ANSYS is installed and licensed.

Information on an ANSYS Multi-field run is available in more detail:

• Overview (p. 18)

• General Procedure (p. 18)

• Monitoring a Run in Progress (p. 20)

• Monitoring a Completed Run (p. 20)

• ANSYS Multi-field Residual Plotting (p. 21)

• Processing the ANSYS Input File (p. 21)

• Restart Procedure for ANSYS Multi-field Runs (p. 22)

Overview
An ANSYS Multi-field run allows the coupling of CFX-Solver with ANSYS Solver in order to execute cases that
require two-way fluid-structure interaction. Such cases are described in detail in Using CFX and the Mechanical
Application (p. 76) in the ANSYS CFX Reference Guide and Coupling CFX to an External Solver: ANSYS
Multi-field Simulations (p. 295) in the ANSYS CFX-Solver Modeling Guide.

General Procedure
The steps which take place when a full ANSYS Multi-field run (where MFX Run Mode is set to Start ANSYS
and CFX) is launched from the CFX-Solver Manager are listed below.

1. User supplies CFX-Solver input file and ANSYS input file.

2. If the ANSYS input file does not already contain multi-field settings, then Process ANSYS Input File must
be enabled, and a new "multi-field" file with extension .mf is created in the ANSYS working directory. This
processing step is described more fully in Processing the ANSYS Input File (p. 21).

3. The ANSYS Solver is launched, reading input from the new .mf file if it was created in the previous step, or
from the original ANSYS input file if that file already contained the multi-field settings.

4. CFX-Solver is launched and is already set up to communicate with ANSYS Solver. The full range of parallel
and other solver options (such as double precision) is available for CFX-Solver when run as part of an ANSYS
Multi-field run.

5. The run executes.

Many of these steps can be performed separately if required. The workflow and reasons for doing this are described
in the following sections:
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• Starting ANSYS CFX and ANSYS Separately (p. 19)

• Process ANSYS Input File Only (p. 19)

• Directory Structure (p. 20)

• Starting an ANSYS Multi-field Run from the Command Line (p. 20)

If a run is to be restarted, a different procedure applies. This described in Restart Procedure for ANSYS Multi-field
Runs (p. 22).

Starting ANSYS CFX and ANSYS Separately
The normal procedure for launching an ANSYS Multi-field run from CFX-Solver Manager launches both CFX-Solver
and ANSYS Solver. However, there are certain circumstances when you may want to launch them separately. In
particular, you may want to run the two solvers on different machines. In this case, you can use the CFX-Solver
Manager to start each solver separately. The procedure is as follows:

1. Ensure that the ANSYS input file and CFX-Solver input file for the run are present on the machine on which
you want to run ANSYS Solver. Start CFX-Solver Manager on this machine.

2. Start the ANSYS run with MFX Run Mode set to Start ANSYS only.

3. Ensure that the CFX-Solver input file for the run is present on the machine on which you want to run
CFX-Solver. Start CFX-Solver Manager on this machine.

4. Start the CFX run with MFX Run Mode set to Start CFX only. You will need to supply a host name
and port number which tell CFX-Solver how to communicate with ANSYS solver which is already running.
Host Name is the machine on which the ANSYS Solver was started. Port Number is determined by the
ANSYS Solver when it starts, and can be read from the file <jobname>.port in the ANSYS working
directory once the ANSYS Solver has started. If the CFX-Solver Manager was used to start the ANSYS Solver,
then the port number appears in the CCL under EXECUTION CONTROL/SOLVER STEP
CONTROL/PROCESS COUPLING/Host Port.

Note that this procedure effectively sets up two separate runs as far as the CFX-Solver Manager is concerned; each
can be monitored as a separate run.

If you do not have CFX-Solver Manager installed on the machine where ANSYS Solver is going to run, you can
start the ANSYS Solver from the ANSYS Launcher instead. In this case, the appropriate host name and port number
are displayed in a dialog box from the ANSYS Launcher as the argument -cplg-host <Port Number>@<Host
Name>.

Process ANSYS Input File Only
The processing of an ANSYS input file is a procedure which takes a solid physics setup in the form of an ANSYS
input file and a multi-field setup from a CFX-Solver input file, and combines them into a new ANSYS input file
which contains both the solid physics setup and the multi-field setup. The new ANSYS input file has a name of the
form <jobname>.mf and can be used to start the ANSYS Solver as part of an ANSYS Multi-field run.

Usually the processing takes place as part of launching the ANSYS Solver from the CFX-Solver Manager. However,
you may want to do it as a pre-processing step if, for some reason, you want to modify or check the new ANSYS
input file before use, or if you want to use it outside of the CFX-Solver Manager. This is also a necessary part of
restarting an ANSYS Multi-field run with a change to the solid physics. For details, see Restart Procedure for
ANSYS Multi-field Runs (p. 22). The procedure for a non-restart run is as follows:

1. Ensure that the ANSYS input file and CFX-Solver input file for the run are present and start the CFX-Solver
Manager.

2. Perform the processing by defining a new run, setting MFX Run Mode to Process Input File only.

3. Use the new ANSYS input file <jobname>.mf in the ANSYS working directory as desired.

If you subsequently want to use this file to start the ANSYS Solver, then click the MultiField tab of the Define
Run dialog box, specify the new file as the ANSYS input file and uncheck Process ANSYS Input File.

The processing step is described more fully in Processing the ANSYS Input File (p. 21).
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Directory Structure
For a normal CFX run (not an ANSYS Multi-field run), you must specify a working directory in the Define Run
dialog box. This defaults to the directory from which the CFX-Solver Manager was started.

Once the run is started, a run name is generated. This is the name of the CFX-Solver input file with the extension
removed and a three-digit number added. The number is usually 001 if this is the first time CFX-Solver Manager
is used for this CFX-Solver input file. In general, it is the lowest number that prevents files from previous runs
being overwritten.

Whilst the run is in progress, a CFX working directory with the name <jobname>.dir will exist within the CFX
working directory, which contains the temporary files for CFX-Solver. When the run has finished, you will find
the files <run_name>.res and <run_name>.out in the CFX working directory, and in certain circumstances
(generally when transient results files or backup files are present) a directory <run_name> will also be present.

This directory structure is unchanged for the CFX part of an ANSYS Multi-field run. However, a new directory
<run_name>.ansys is also created in the CFX working directory. This directory is used as the ANSYS working
directory by the ANSYS solver, and all files generated by ANSYS will be placed in this directory, including the
ANSYS results file.

Almost all files produced by ANSYS have a name of the form <jobname>.* (the exception is the ANSYS GST
file, which will always be called ANSYS.gst when a run is started from the CFX-Solver Manager or ANSYS
Launcher). ANSYS Multi-field runs started from the CFX-Solver Manager have a default jobname of ANSYS. So,
for example, the results file will be ANSYS.rst for a case involving structural physics or ANSYS.rth for a case
involving only thermal physics. Note also that all text output generated by the ANSYS solver (that is, standard error
and standard output) is written to the ANSYS.stdout file. These files will be in the directory
<run_name>.ansys. The jobname can be specified explicitly if you start the ANSYS Multi-field run from the
command line. For details, see Starting an ANSYS Multi-field Run from the Command Line (p. 20).

Starting an ANSYS Multi-field Run from the Command Line
An ANSYS Multi-field run can be started from the command line using the cfx5solve command.

Monitoring a Run in Progress
Each ANSYS Multi-field run launched from the CFX-Solver Manager or the cfx5solve command line creates
a temporary CFX working directory with the name <run_name>.dir, even if the MFX Run Mode is set to
Start ANSYS only. For details, see Directory Structure (p. 20). If a run is already in progress when the
CFX-Solver Manager is opened, it can be monitored by selecting this directory as the run directory. The process is
just the same as for ordinary CFX runs:

1. Select File > Monitor Run in Progress.

The Select a Run Directory (.dir) dialog box is displayed.

2. Browse to the directory containing the current run.

3. Select the current run.

4. Click OK.

Monitoring a Completed Run
A completed ANSYS Multi-field run can only be monitored in the CFX-Solver Manager if a CFX results file exists
for the run. This implies that a run with MFX Run Mode set to Start ANSYS only or Process Input
File only cannot be monitored if it has already been completed. If a CFX results file does exist, then a completed
run can be monitored in the same way as an ordinary CFX run, as follows:

1. Select File > Monitor Finished Run.

The Monitor Finished Run dialog box is displayed.

2. Under File type, select the type of files to view. This setting usually corresponds to a CFX results file.

3. Browse to the directory containing the finished run.

4. Select the run to view.

Release 12.0 - © 2009 ANSYS, Inc. All rights reserved.

20 Contains proprietary and confidential information of ANSYS, Inc. and its subsidiaries and affiliates.

Monitoring a Run in Progress



If required, select a different file.

5. Click OK.

ANSYS Multi-field Residual Plotting
The extra residual plots for an ANSYS Multi-field run (ANSYS Interface Loads and ANSYS Field Solver plots)
are described in Residual Plotting for ANSYS Multi-field Runs (p. 72) and Plot Lines Tab (p. 94).

Processing the ANSYS Input File
The processing of an ANSYS input file is a procedure which takes a solid physics setup in the form of an ANSYS
input file and a multi-field setup from a CFX-Solver input file, and combines them into a new ANSYS input file
which contains both the solid physics set-up and the multi-field set-up. The new ANSYS input file has a name of
the form <jobname>.mf and can be used to start the ANSYS Solver as part of an ANSYS Multi-field run.

The following topics are discussed in this section:

• When the ANSYS Input File Needs Processing (p. 21)

• The Processing Step (p. 21)

When the ANSYS Input File Needs Processing
The pre-processing steps for an ANSYS Multi-field run result in the fluid physics set-up (contained in a CFX-Solver
input file), the solid physics set-up (contained in an ANSYS input file) and the ANSYS Multi-field settings (contained
in either the CFX-Solver input file or the ANSYS input file). When the multi-field settings are only contained in
the CFX-Solver input file, then the ANSYS input file must be processed before the run begins to create a new
"multi-field" file with the extension .mf, which contains both the solid physics from the supplied ANSYS input
file and the multi-field settings from the CFX-Solver input file, and this is then used as input for the ANSYS Solver,
instead of the supplied ANSYS input file.

A CFX-Solver input file will contain multi-field settings if it was created in ANSYS MultiField mode, but not
if it was created in ANSYS MultiField via Prep7 mode.

An ANSYS input file will only contain multi-field settings if these were explicitly added (by hand or in the ANSYS
Prep7 user interface); there will be no multi-field settings in an ANSYS input file created by Simulation. A
"multi-field" file created from one run can be used as the ANSYS input file for another run, and this will contain
multi-field settings.

The Processing Step
When CFX-Pre writes a CFX-Solver input file in ANSYS MultiField mode, the CCL in the CFX-Solver input
file contains various MFX settings, which are translated to commands for the ANSYS solver when the ANSYS
input file is processed. This section contains a few notes on how the MFX settings in the CFX-Solver input file are
converted to ANSYS commands.

• Every quantity set in a CFX-Solver input file has units—a timestep has a unit of time, most commonly seconds.
For example, timesteps may appear in the CCL as Timesteps = 0.1 [s]. You can use any unit of the
appropriate dimension to specify any physical quantity, and CFX handles the conversion to a consistent set of
units (CFX Solution Units) as part of setting up the solver run. However, ANSYS commands appear without
units (for example, MFDT,0.1,0.1,0.1) and it is assumed that you have entered the value in units that are
consistent with the rest of the ANSYS set-up. When an MFX run is performed, it is a requirement that the units
used for the ANSYS set-up match the CFX Solution Units. Therefore, when quantities with units in the CFX
CCL are translated to ANSYS commands, the values used are always written in the CFX Solution Unit of the
appropriate dimension. For example, if you specify a coupling time duration of 30.0 [s], and the CFX
Solution Units of time are set to minutes, then the ANSYS command that corresponds to this CCL (MFTI) will
be written with the value 0.5 in implicit units of minutes: MFTI,0.5.

• The CFX CCL records the name of an ANSYS Interface, not its number, where possible. For details, see
Boundary Conditions in ANSYS Multi-field Mode (p. 299) in the ANSYS CFX-Solver Modeling Guide. When
the CFX-Solver input file is processed, this is automatically converted to the required interface number, as
required by the MFLC command.
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• If the CFX CCL contains definitions for backup files or transient results files (of any kind) that are specified
with an Output Frequency of Coupling Step Interval or Every Coupling Step, then an MFOU
command is generated with a corresponding argument, to get ANSYS to write out its results at the same frequency.
For example, if Output Frequency is set to Every Coupling Step then MFOU,1 is written, and if Output
Frequency is set to Coupling Step Interval with the interval set to every five coupling steps, then
MFOU,5 is generated. If multiple backup and transient results objects are present, then the MFOU command
which corresponds to the smallest coupling interval is written.

• The processing always adds a KBC,1 command to the input file, as this is required for any multi-field case.

• The processing always adds the /GST command to ensure output for monitoring the run is available, and the
CMWRITE command to ensure that any named selections or components in the ANSYS input file are available
for CFD-Post to use. For details, see ANSYS Files (p. 74) in the ANSYS CFD-Post User's Guide.

Restart Procedure for ANSYS Multi-field Runs
Restarting an ANSYS Multi-field run involves restarting both the ANSYS and CFX Solvers, in such as way that
both continue from a consistent point in the ANSYS Multi-field run. A run cannot be restarted with new topology
or mesh, but it can be restarted with different physics and/or solver settings.

For restarting the ANSYS part of the run, the key file is the database which contains the settings for the previous
run. Various other files are also required for a restart to work correctly, and these will generally be present at the
end of a successful run. (If the ANSYS input file for the initial run was prepared manually, it must have a SAVE
command after the SOLVE command for all the required files to be generated.)

The procedure for each type of restart is listed below:

• Restart from End of Previous Run (p. 22)

• Restart from Intermediate Point During Previous Run (p. 22)

• Changing CFX Physics or ANSYS Multi-field Settings (p. 23)

• Changing ANSYS Physics (p. 23)

• Restart Limitations (p. 24)

• Singleframe and Multiframe Restarts (p. 24)

Restart from End of Previous Run
This is the most straight-forward restart and can be performed in almost any circumstance when a run has finished
normally (including when the run has been stopped manually). The procedure is as follows:

1. If you stopped the initial run before completion and want to do a restart to finish it off, then the coupling time
duration will already be correct in the multi-field set-up in CFX-Pre. However, if the initial run ran to completion
and you now want to extend it, you must first set the coupling time duration to have an appropriate end time
for the restarted run. This can be done by editing the CCL in the CFX results file from the initial run, or by
re-writing the original CFX-Solver input file with the new setting (found on the Analysis Type panel).

2. Start the CFX-Solver Manager and open the Define Run dialog box. Select the CFX results file from the end
of the previous run as the CFX-Solver input file if this contains the correct coupling time duration; otherwise,
select the CFX-Solver input file with the correct coupling time duration and use the previous results file as an
initial values file.

3. On the MultiField tab, enable the Restart ANSYS Run toggle, and browse to find the database (*.db or
*.rdb) from the initial run. The database can be found in the directory <run_name>.ansys from the
previous run if that run was launched by the CFX-Solver Manager or the CFX-Solver script cfx5solve.

4. Start the run as normal. Behind the scenes, the CFX-Solver script will copy the required files from the previous
ANSYS run into the new ANSYS working directory so that everything should proceed smoothly.

Restart from Intermediate Point During Previous Run
You may want to restart from an intermediate point of a previous run if the initial run was diverging and you want
to restart from a point before it was diverging with some modified solver settings, for example.

Assuming that the restart from an intermediate point is available, the procedure is as follows:
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1. Coupling Initial Time must be set to Value, with the value set to the time value that you want to restart from.
This can be done by editing the CCL in the “full” CFX backup (*.bak) or “full” CFX transient file (*.trn)
from the initial run, or by re-writing the original CFX-Solver input file with the new setting (found on the
Analysis Type panel).

2. Start the CFX-Solver Manager and open the Define Run dialog box. Select the CFX results file from the end
of the previous run as the CFX-Solver input file if this contains the correct coupling initial time; otherwise
select the CFX-Solver input file with the correct coupling initial time and use the previous results file as an
initial values file.

3. On the MultiField tab, enable the Restart ANSYS Run toggle, and browse to find the database (*.rdb)
from the initial run. The database can be found in the directory <run_name>.ansys from the previous run
if that run was launched by the CFX-Solver Manager or the CFX-Solver script cfx5solve.

4. Start the run as normal. Behind the scenes, the CFX-Solver script will copy the required files from the previous
ANSYS run into the new ANSYS working directory so that everything should proceed smoothly.

However, restarting from an intermediate point of a previous run is not always possible:

• If the initial run did not complete normally, it depends on the exact circumstances of the failure as to whether
it is possible to restart from an intermediate point. The ANSYS Solver requires certain information in order to
restart correctly, some of which is only written at the end of a run, and so the ability to restart depends on whether
the ANSYS Solver was able to write that information.

• Restarting from an intermediate point is limited to ANSYS runs which contain only mechanical and/or thermal
physics. If the ANSYS setup contains additional physics such as electromagnetic physics, then it will not be
possible.

• Restarting from an intermediate point relies on the presence of a set of files for a "multiframe restart". For details,
see Singleframe and Multiframe Restarts (p. 24). The availability of these files depends on the presence of a
command RESCONTROL and its setting in the ANSYS input file. In general, ANSYS input files generated from
Simulation have the command RESCONTROL set so that the set of files required is not present. To ensure that
the files are present wherever possible, add the command RESCONTROL,DEFINE,ALL to the ANSYS input
file directly or to a Commands object in the relevant Solution item in the tree within Simulation. More
details can be found in the ANSYS documentation, in “Multiframe Restart”. You can check whether the required
set of files is present by looking for a database with extension *.rdb in the ANSYS working directory from
the initial run. If it is present, then the required file set has been written and you should be able to restart from
an intermediate point, subject to the conditions regarding how the initial run was terminated noted above.

• Restarting from an intermediate point requires a CFX full backup or full transient file for that time value in
addition to having the appropriate ANSYS files for that time value.

Changing CFX Physics or ANSYS Multi-field Settings
Any physics or setup contained in the CFX definition can be modified on a restart, providing that you do not change
the geometry, connectivity, mesh or boundary condition names or locations. The changes can be made by editing
the CFX results file before using it in a restart, or by writing a modified CFX-Solver input file and using the previous
results file as an initial values file.

Changing ANSYS Physics
There is no built-in support for changing the ANSYS physics within Simulation and having it used for restarting
an ANSYS Multi-field run. If you want to change the ANSYS setup for a restart, you will have to add ANSYS
commands to the ANSYS input file. Commands available for an ANSYS input file are documented in the ANSYS
documentation, in ANSYS Commands Reference. If you are not already familiar with working with ANSYS commands,
then it is recommended that you avoid this type of restart.

The recommended procedure for restarting with different ANSYS physics or solver setup is as follows:

1. Start the CFX-Solver Manager and open the Define Run dialog box. Select the appropriate CFX-Solver input
file or results file for the restart.

2. On the MultiField tab, set MFX Run Mode to Process Input File only. Also enable the Restart
ANSYS Run toggle, and browse to find the database (*.db or *.rdb) from the initial run. The database can
be found in the directory <run_name>.ansys from the previous run if that run was launched by the
CFX-Solver Manager or the CFX-Solver script cfx5solve.
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3. Start the run as normal. Behind the scenes, the CFX-Solver script will create the ANSYS working directory c
and place a file called ANSYS.mf inside it.

4. In a text editor, edit the file ANSYS.mf to add ANSYS commands to make any changes to the physics that
you require.

5. In the CFX-Solver Manager, define a new run. Select the appropriate CFX-Solver input file or results file for
the restart.

6. On the MultiField tab, set MFX Run Mode to Start ANSYS and CFX. For ANSYS Input File, select
the ANSYS.mf file that you have just been editing. Toggle off Process ANSYS Input File. Ensure
that the Restart ANSYS Run toggle is still enabled, and browse to find the database (*.db or *.rdb) from
the initial run. The database can be found in the directory <run_name>.ansys from the previous run if that
run was launched by the CFX-Solver Manager or the CFX-Solver script cfx5solve.

7. Start the run. Behind the scenes, the CFX-Solver script will copy the required files from the previous ANSYS
run into the new ANSYS working directory so that everything should proceed smoothly.

Restart Limitations
Restarted simulations will give results that are identical to continuous simulations if fields and loads are converged
within each multi-field timestep.

Discontinuities in the convergence history upon restarts can be eliminated by running the ANSYS field solver first
within each stagger iteration, and executing two or more stagger iterations per multi-field timestep.

Singleframe and Multiframe Restarts
ANSYS has two distinct types of restart: singleframe and multiframe. A full description of what these are is given
in the ANSYS documentation, in “Restarting an Analysis”. This section includes some abbreviated information in
order to note how restarts from within the CFX-Solver Manager are operated.

• A singleframe restart only allows you to restart a run from where it finished. It is available for any ANSYS
physics. The files needed for this type of restart include <jobname>.db and various others.

• A multiframe restart allows you to restart from an intermediate point of the initial run (provided that all appropriate
files are present), or from the end of the previous run. It is only available for a limited set of ANSYS physics
(static or thermal analyses that do not use coupled field elements). The files needed for this type of restart include
<jobname>.db and various others. Note that multiframe restarts from the end of a previously failed run (due
to the solver divergence, for example) are not possible; they restart from an intermediate point instead.

In many cases, either a singleframe or multiframe restart may be performed because both the <jobname>.db and
<jobname>.rdb files exist in the previous run directory. When the cfx5solve script is used, it will automatically
copy all of the files required to properly restart an ANSYS Multi-field simulation. It is worth noting, however, that
singleframe restarts (that is, by selecting the <jobname>.db file) are recommended for simple run continuations
since fewer files will be copied from the previous to the new <jobname>.ansys run directory.
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Chapter 3. CFX-Solver Files
This chapter describes the file types used and generated by CFX-Solver. The CFX-Solver is run using an input file
that is usually the CFX-Solver Input file (.def or .mdef) created by CFX-Pre. For most simulations, the CFX-Solver
generates text output and CFX-Solver Results (.res, .trn, .bak, .mres) files. Other files are also generated depending
on the physical models used in the simulation, and how the simulation is run (e.g. serial or parallel).

Detailed descriptions of these files and how they are used are presented in the following sections:

• Files Used by the CFX-Solver (p. 25)

• Files Generated by the CFX-Solver (p. 27)

Files Used by the CFX-Solver
The CFX-Solver input file usually contains all the information that is required by the CFX-Solver to run a CFD
simulation. This information includes:

• Physical models and fluid property settings

• Boundary conditions

• Initial conditions

• The mesh

• CFX-Solver parameter settings.

However, there are circumstances when the file specified in the Solver Input File option (referred to hereafter as
the Solver Input File) requires additional solution values to initialize the run. These additional initial solution values
are introduced by defining one or more Initial Values objects, each of which refers to either a previously created
results file or a configuration for which a results file has not yet been created. In all cases, these results files merely
supplement the run with solution values that are not available in the input file; simulation specifications in the Solver
Input File are not overridden.

When starting a run using results from Initial Values objects, the mesh from the Solver Input File is used by default
and solution values are either copied or interpolated from the initial values mesh(es) onto the Solver Input File
mesh. Additionally, when initial values files are used, the run history (i.e. monitor and convergence data, simulation
time and timestep counters) is continued by default. You may also choose to not continue the run history.

The following tables describe the behavior resulting from different combinations of Solver Input File and Initial
Values objects for single and multi-configuration simulations.

Single Configuration Simulations

DescriptionInitial Values SpecificationSolver Input File

New simulation (i.e. no
run history) starting

CFX-Solver Input file (.def)

from iteration or time
step # 1.

Continue simulation
(solution values and run

CFX-Solver Results (.res)

history), starting from
the iteration or time step
that follows last
completed in the
previous run.

Supplement initial
conditions in the Solver

Initial Values object(s) using the Results File
option that references a CFX-Solver Results file
(.res, .trn, .bak).

CFX-Solver Input (.def)

Input File with solution
values contained in the
results file referenced by
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Single Configuration Simulations

DescriptionInitial Values SpecificationSolver Input File

the Initial Values
object(s).

Multi-Configuration Simulations

DescriptionConfiguration-Specific Initial Values
Specification

Solver Input File

New simulation (i.e. no
run history) with all

CFX-Solver Input file (.mdef)

configuration analyses
starting from iteration or
time step # 1.

Supplement initial
conditions in

Initial Values object(s) using the Results File
option that references a CFX-Solver Results file
(.res, .trn, .bak).

CFX-Solver Input file (.mdef)

configuration definitions
with those contained in
the results file(s)
referenced by the Initial
Values object(s).

Supplement initial
conditions in

Initial Values object(s) using the Configuration
Results option that references a configuration.

CFX-Solver Input file (.mdef)

configuration definitions
with solution values
contained in the latest
results file
corresponding to the
configuration(s)
referenced by the Initial
Values object(s).

Continue simulation
(solution values and run

CFX-Solver Results file (.mres)

history), starting from
configuration that
follows the one last
completed in the
previous run. The
simulation will proceed
to complete the last
configuration being
executed in the previous
run if the simulation
was stopped
prematurely (e.g. via the
cfx5stop command).
Note that his is the only
way to continue a
multi-configuration
simulation.

Note
• For multi-configuration simulations:
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• Global (or simulation) level Initial Values specifications are not valid,

• A configuration level Solver Input File is implied in the multi-configuration setup (i.e. it is not
required)

• Setting the Initial Values Specification > Use Mesh From option to Solver Input File will activate
the CFX-Interpolator to either copy or interpolate solution values from the mesh in the Initial Values
object(s) to the Solver Input File. See Using the CFX-Interpolator (p. 86) in ANSYS CFX-Solver
Modeling Guide for details.

• Setting the Initial Values Specification > Use Mesh From option to Initial Values will use the
mesh from the Initial Values File and de-activate the CFX-Interpolator. . See Using the Mesh from
the Initial Values File (p. 84) in ANSYS CFX-Solver Modeling Guide for details.

• Unsetting (i.e. deselecting) the Initial Values Specification > Continue History From option will
reset the run history. and use the Initial Values File to provide a basic initial guess for the new run.
See Continuing the History (p. 82) in ANSYS CFX-Solver Modeling Guide for details

• Setting the Initial Values Specification > Continue History From option will continue the run
history from the results file referenced by the specified Initial Values object, and produce the cleanest
restart possible from the Initial Values File. The first iteration or timestep executed follows the last
one completed in the referenced results file. See Continuing the History (p. 82) in ANSYS CFX-Solver
Modeling Guide for details.

Files Generated by the CFX-Solver
The CFX-Solver typically generates two files for each run: the CFX-Solver Output file and the CFX-Solver Results
file. These are discussed in the sections:

• CFX-Solver Output File (p. 28)

• CFX-Solver Output File (Transient Runs) (p. 44)

• CFX-Solver Output File (Interpolation Runs) (p. 45)

• CFX-Solver Output File (Parallel Runs) (p. 46)

• CFX-Solver Output File (Mesh Adaption Runs) (p. 49)

• CFX-Solver Output File (Remeshing Runs) (p. 49)

• CFX-Solver Output File (Conjugate Heat Transfer Runs) (p. 50)

• CFX-Solver Output File (GGI Runs) (p. 50)

• CFX-Solver Output File (Combustion Runs) (p. 52)

• CFX-Solver Output File (Particle Runs) (p. 54)

• CFX-Solver Output File (ANSYS Multi-field Runs) (p. 57)

• CFX-Solver Output File (Radiation Runs) (p. 58)

• CFX-Solver Results File (p. 60)

Additional files are generated for the run as follows:

• For runs that involve the use of the Discrete Transfer or Monte Carlo radiation models, an additional file
containing radiation data can also be generated. See CFX Radiation File (p. 61).

• For parallel runs of the CFX-Solver, an additional CFX partition file can also be generated. See CFX Partition
File (p. 63).

• For ANSYS Multi-field runs, additional files are created. See Additional Files for ANSYS Multi-field
Runs (p. 63).

For multi-configuration simulations, the CFX-Solver generates two additional simulation level text output and
results files in addition to the output and results files generated per configuration. These files are discussed in the
sections:

• CFX Multi-Configuration Output File (p. 64)

• CFX Multi-Configuration Results File (p. 69)
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CFX-Solver Output File
The CFX-Solver Output file is a formatted text file generated by the CFX-Solver and contains information about
your CFX model setup, the state of the solution during execution of the CFX-Solver, and analysis statistics for the
particular run. This is the same information written to the text output window of the CFX-Solver Manager. For
details, see Text Output Window (p. 3).

The file is formatted and divided into sections to allow quick and easy interpretation. The sections which are present
for any calculation may depend upon which physical models are being used (that is, whether the model is transient
or steady-state) and whether the CFX-Solver is being run as several parallel processes or as a single process.

The CFX-Solver will generate an output file with a name based on the CFX-Solver input file. For example, running
the CFX-Solver using the input file named file.def in a clean working directory will generate an output file
named file_001.out.

Header
The header is written at the start of every CFX-Solver Output file and contains information regarding the command
which started the job. This information is used to check which files were used to start the run.

CFX Command Language for the Run
The CFX Command Language section describes the problem definition, including domain specification, boundary
conditions, meshing parameters and solver control.

The section for the command file looks similar to the following:

 +--------------------------------------------------------------------+
 |                                                                    |
 |                    CFX Command Language for Run                    |
 |                                                                    |
 +--------------------------------------------------------------------+

 LIBRARY:
   MATERIAL: Water
     Material Description = Water (liquid)
     Material Group = Water Data, Constant Property Liquids
     Option = Pure Substance
     Thermodynamic State = Liquid
     PROPERTIES:
       Option = General Material
       EQUATION OF STATE:
         Density = 997.0 [kg m^-3]
         Molar Mass = 18.02 [kg kmol^-1]
         Option = Value
       END
       SPECIFIC HEAT CAPACITY:
         Option = Value
         Specific Heat Capacity = 4181.7 [J kg^-1 K^-1]
         Specific Heat Type = Constant Pressure
       END
       REFERENCE STATE:
         Option = Specified Point
         Reference Pressure = 1 [atm]
         Reference Specific Enthalpy = 0.0 [J/kg]
         Reference Specific Entropy = 0.0 [J/kg/K]
         Reference Temperature = 25 [C]
       END
       DYNAMIC VISCOSITY:
         Dynamic Viscosity = 8.899E-4 [kg m^-1 s^-1]
         Option = Value
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       END
       THERMAL CONDUCTIVITY:
         Option = Value
         Thermal Conductivity = 0.6069 [W m^-1 K^-1]
       END
       ABSORPTION COEFFICIENT:
         Absorption Coefficient = 1.0 [m^-1]
         Option = Value
       END
       SCATTERING COEFFICIENT:
         Option = Value
         Scattering Coefficient = 0.0 [m^-1]
       END
       REFRACTIVE INDEX:
         Option = Value
         Refractive Index = 1.0 [m m^-1]
       END
       THERMAL EXPANSIVITY:
         Option = Value
         Thermal Expansivity = 2.57E-04 [K^-1]
       END
     END
   END
 END
 FLOW: Flow Analysis 1
   SOLUTION UNITS:
     Angle Units = [rad]
     Length Units = [m]
     Mass Units = [kg]
     Solid Angle Units = [sr]
     Temperature Units = [K]
     Time Units = [s]
   END
   ANALYSIS TYPE:
     Option = Steady State
     EXTERNAL SOLVER COUPLING:
       Option = None
     END
   END
   DOMAIN: Default Domain
     Coord Frame = Coord 0
     Domain Type = Fluid
     Location = B1.P3
     BOUNDARY: Default Domain Default
       Boundary Type = WALL
       Location = F1.B1.P3,F2.B1.P3,F4.B1.P3,F5.B1.P3,F6.B1.P3,F8.B1.P3
       BOUNDARY CONDITIONS:
         HEAT TRANSFER:
           Option = Adiabatic
         END
         MASS AND MOMENTUM:
           Option = No Slip Wall
         END
         WALL ROUGHNESS:
           Option = Smooth Wall
         END
       END
     END
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     BOUNDARY: in1
       Boundary Type = INLET
       Location = in1
       BOUNDARY CONDITIONS:
         FLOW REGIME:
           Option = Subsonic
         END
         HEAT TRANSFER:
           Option = Static Temperature
           Static Temperature = 315 [K]
         END
         MASS AND MOMENTUM:
           Normal Speed = 2 [m s^-1]
           Option = Normal Speed
         END
         TURBULENCE:
           Option = Medium Intensity and Eddy Viscosity Ratio
         END
       END
     END
     BOUNDARY: in2
       Boundary Type = INLET
       Location = in2
       BOUNDARY CONDITIONS:
         FLOW REGIME:
           Option = Subsonic
         END
         HEAT TRANSFER:
           Option = Static Temperature
           Static Temperature = 285 [K]
         END
         MASS AND MOMENTUM:
           Normal Speed = 2 [m s^-1]
           Option = Normal Speed
         END
         TURBULENCE:
           Option = Medium Intensity and Eddy Viscosity Ratio
         END
       END
     END
     BOUNDARY: out
       Boundary Type = OUTLET
       Location = out
       BOUNDARY CONDITIONS:
         FLOW REGIME:
           Option = Subsonic
         END
         MASS AND MOMENTUM:
           Option = Average Static Pressure
           Pressure Profile Blend = 0.05
           Relative Pressure = 0 [Pa]
         END
         PRESSURE AVERAGING:
           Option = Average Over Whole Outlet
         END
       END
     END
     DOMAIN MODELS:
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       BUOYANCY MODEL:
         Option = Non Buoyant
       END
       DOMAIN MOTION:
         Option = Stationary
       END
       MESH DEFORMATION:
         Option = None
       END
       REFERENCE PRESSURE:
         Reference Pressure = 1 [atm]
       END
     END
     FLUID DEFINITION: Water
       Material = Water
       Option = Material Library
       MORPHOLOGY:
         Option = Continuous Fluid
       END
     END
     FLUID MODELS:
       COMBUSTION MODEL:
         Option = None
       END
       HEAT TRANSFER MODEL:
         Option = Thermal Energy
       END
       THERMAL RADIATION MODEL:
         Option = None
       END
       TURBULENCE MODEL:
         Option = k epsilon
       END
       TURBULENT WALL FUNCTIONS:
         Option = Scalable
       END
     END
   END
   OUTPUT CONTROL:
     RESULTS:
       File Compression Level = Default
       Option = Standard
     END
   END
   SOLVER CONTROL:
     Turbulence Numerics = First Order
     ADVECTION SCHEME:
       Option = Upwind
     END
     CONVERGENCE CONTROL:
       Maximum Number of Iterations = 100
       Minimum Number of Iterations = 1
       Physical Timescale = 2 [s]
       Timescale Control = Physical Timescale
     END
     CONVERGENCE CRITERIA:
       Residual Target = 1.E-4
       Residual Type = RMS
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     END
     DYNAMIC MODEL CONTROL:
       Global Dynamic Model Control = On
     END
   END
 END
 COMMAND FILE:
   Version = 12.0.1
   Results Version = 12.0
 END
 SIMULATION CONTROL:
   EXECUTION CONTROL:
     INTERPOLATOR STEP CONTROL:
       Runtime Priority = Standard
       EXECUTABLE SELECTION:
         Double Precision = Off
       END
     END
     PARALLEL HOST LIBRARY:
       HOST DEFINITION: watjpvandoo
         Host Architecture String = winnt-amd64
         Installation Root = D:\Program Files\ANSYS Inc\v%v\CFX
       END
     END
     PARTITIONER STEP CONTROL:
       Multidomain Option = Independent Partitioning
       Runtime Priority = Standard
       EXECUTABLE SELECTION:
         Use Large Problem Partitioner = Off
       END
       PARTITIONING TYPE:
         MeTiS Type = k-way
         Option = MeTiS
         Partition Size Rule = Automatic
       END
     END
     RUN DEFINITION:
       Run Mode = Full
       Solver Input File = \
         D:\Users\jpvandoo\Documentation\Tutorials\examples\StaticMixer.def
     END
     SOLVER STEP CONTROL:
       Runtime Priority = Standard
       EXECUTABLE SELECTION:
         Double Precision = Off
       END
       PARALLEL ENVIRONMENT:
         Number of Processes = 1
         Start Method = Serial
       END
     END
   END
 END

CFD Job Information
This section describes the job characteristics in terms of the Run mode (sequential or parallel), the machine on
which the job was started, and the time and date of the start of the run.
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The section for job information looks similar to the following:

+--------------------------------------------------------------------+
|                          Job Information                           |
+--------------------------------------------------------------------+
Run mode:       serial run
Host computer:  pesky
Job started:    Thu Nov 20 15:07:27 2008

Memory Allocated for the Run

Note
Allocated storage generally exceeds the required storage. 1 word = 4 bytes, 1 Kword = 1000 words, 1
Kbyte = 1024 bytes

The section for memory usage looks similar to the following:

+--------------------------------------------------------------------+
 |        Memory Allocated for Run  (Actual usage may be less)        |
 +--------------------------------------------------------------------+

  Data Type      Kwords  Words/Node  Words/Elem      Kbytes Bytes/Node

  Real           1014.6     1478.98     2348.56      3963.2    5915.92
  Integer        1206.6     1758.85     2792.99      4713.2    7035.41
  Character      2967.7     4326.09     6869.67      2898.1    4326.09
  Logical          65.0       94.75      150.46       253.9     379.01
  Double            3.1        4.51        7.16        24.2      36.06

Mesh Statistics
The mesh statistics summarize domain-specific and global (that is, the combination of all domains):

• mesh quality diagnostics,

• the total number of nodes, elements and boundary faces in the mesh, and

• the area fractions of mesh interfaces that were unmapped

Mesh quality diagnostics include measures of mesh orthogonality, expansion and aspect ratio (see Mesh Issues (p.
321)) For each measure, there are value ranges that are considered good, acceptable, and poor (i.e. may produce
accuracy or convergence problems). These ranges are annotated with OK, ok, and !, respectively, in the mesh
diagnostics summary. The relevant minimum or maximum value is presented for each measure, plus a summary of
the percent of the mesh with values in each of the good, acceptable and poor ranges. Note that these percentages
are rounded to the nearest integer value. In the sample output presented below, the worst expansion factor is 37,
which is considered poor (i.e. annotated with !). While slightly more than 1% of the impeller mesh exhibits similarly
poor values, less than 1% of the global mesh is considered poor and ‘<1' is entered in the summary.

The section for mesh statistics looks similar to the following:

 +--------------------------------------------------------------------+
 |                          Mesh Statistics                           |
 +--------------------------------------------------------------------+
 | Domain Name          | Orthog. Angle | Exp. Factor  | Aspect Ratio |
 +----------------------+---------------+--------------+--------------+
 |                      | Minimum [deg] |   Maximum    |    Maximum   |
 +----------------------+---------------+--------------+--------------+
 | impeller             |       34.7 ok |        37  ! |        13 OK |
 | tank                 |       61.4 OK |        11 ok |       303 OK |
 | Global               |       34.7 ok |        37  ! |       303 OK |
 +----------------------+---------------+--------------+--------------+
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 |                      |  %!  %ok  %OK | %!  %ok  %OK | %!  %ok  %OK |
 +----------------------+---------------+--------------+--------------+
 | impe                 |   0   11   89 |  1   32   67 |  0    0  100 |
 | tank                 |   0    0  100 |  0    2   98 |  0    3   97 |
 | Global               |   0    3   97 | <1   11   89 |  0    2   98 |
 +----------------------+---------------+--------------+--------------+

 Domain Name : impeller

     Total Number of Nodes                                =        1710

     Total Number of Elements                             =        7554
         Total Number of Tetrahedrons                     =        7206
         Total Number of Prisms                           =         238
         Total Number of Pyramids                         =         110

     Total Number of Faces                                =        1494

 Domain Name : tank

     Total Number of Nodes                                =        4558

     Total Number of Elements                             =        3610
         Total Number of Hexahedrons                      =        3610

     Total Number of Faces                                =        2212

 Global Statistics :

     Global Number of Nodes                               =        6268

     Global Number of Elements                            =       11164
         Total Number of Tetrahedrons                     =        7206
         Total Number of Prisms                           =         238
         Total Number of Hexahedrons                      =        3610
         Total Number of Pyramids                         =         110

     Global Number of Faces                               =        3706

 Domain Interface Name : ImpellerPeriodic

     Non-overlap area fraction on side 1                  =    0.00E+00
     Non-overlap area fraction on side 2                  =    0.00E+00

 Domain Interface Name : TankPeriodic1 TankPeriodic2

     Non-overlap area fraction on side 1                  =    0.00E+00
     Non-overlap area fraction on side 2                  =    0.00E+00

Initial Average Scales
These are average scales based on the initial flow field. If the initial velocity field is zero, then the initial average
velocity scale will also be zero.

The section for initial average scales looks similar to the following:

+--------------------------------------------------------------------+
|                      Average Scale Information                     |
+--------------------------------------------------------------------+
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Domain Name : StaticMixer                                =  3.2113E+00
Global Length 
     Density                                             =  9.9800E+02
     Dynamic Viscosity                                   =  1.0000E-03
     Velocity                                            =  0.0000E+00
     Thermal Conductivity                                =  5.9100E-01
     Specific Heat Capacity at Constant Pressure         =  4.1900E+03
     Prandtl Number                                      =  7.0897E+00

Checking for Isolated Fluid Regions
For serial runs, the solver checks to see if any fluid domain contains volumetric regions which are isolated pockets.
This check cannot be performed for parallel solver runs.

Solved Equations
This section lists the dependent variables solved and the equations to which they relate as well as the estimated
physical timestep if calculated automatically.

Equations are given two labels: the individual name and a combined name used for combining residuals together.
Residuals for multi-domain problems are combined provided the domains are connected together and have the same
domain type (solid or fluid/porous). If there are multiple groups of the same domain type, then the group residual
is identified by the name of the first domain in the connected group.

The section for solved equations looks similar to the following:

 +--------------------------------------------------------------------+
 |              The Equations Solved in This Calculation              |
 +--------------------------------------------------------------------+
 Subsystem : Momentum and Mass
   U-Mom
   V-Mom
   W-Mom
   P-Mass
 Subsystem : Thermal Radiation
   I-Radiation
 Subsystem : Heat Transfer
   H-Energy
 Subsystem : Temperature Variance
   T-Variance
 Subsystem : TurbKE and Diss.K
   K-TurbKE
   E-Diss.K
 Subsystem : Mixture Fraction
   Z-Mean
   Z-Variance
 Subsystem : Mass Fractions
   NO-Mass Fraction

Convergence History
The convergence history section details the state of the solution as it progresses. Equation residual information at
specified locations allows you to monitor the convergence. Convergence difficulties can often be pinpointed to a
particular part of the solution (for example, the momentum equation), and/or a particular location.

The tables shown in the convergence history have the following columns:

• Rate

The rate is defined as seen in Equation 3.1 (p. 36) where Rn is the residual at iteration n, and −Rn 1 is the residual
at an earlier iteration. Rates less than 1.0 indicate convergence.
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(Eq. 3.1)=
−

Rate R
R
n

n 1

• RMS Res

The value of the root mean square normalized residual taken over the whole domain.

• Max Res

The value of the maximum normalized residual in the domain.

• Linear Solution

The three columns in this section refer to the performance of the linear (inner) solvers. The first column is the
average number of iterations the linear solvers attempted to obtain the specified linear equation convergence
criteria (within a specified number of iterations). The second column gives the normalized residuals for the
solutions to the linear equation. The last column can have one of four entries:

• * indicates that there was a numerical floating point exception and this resulted in the failure of the linear
solvers.

• F indicates that the linear solvers did not reduce the residuals (that is, the solution was diverging), but the
linear solvers may carry on if the divergence is not catastrophic.

• ok indicates that the residuals were reduced, but that the degree of reduction did not meet the specified
criteria.

• OK indicates that the specified convergence criteria for the reduction of residuals was achieved.

After the convergence criteria has been achieved, or the specified number of timesteps has been reached, CFX-Solver
appends additional information, calculated from the solution, to the &cfxsolvout-tl; file.

The convergence history for a steady state analysis looks similar to the following:

+--------------------------------------------------------------------+
|                       Convergence History                          |
+--------------------------------------------------------------------+
======================================================================
OUTER LOOP ITERATION =    1                     CPU SECONDS = 2.68E+00
----------------------------------------------------------------------
|       Equation       | Rate | RMS Res | Max Res |  Linear Solution |
+----------------------+------+---------+---------+------------------+
| U - Mom              | 0.00 | 1.5E-10 | 5.4E-09 |       1.5E+10  ok|
| V - Mom              | 0.00 | 1.6E-04 | 3.2E-03 |       6.4E+01  ok|
| W - Mom              | 0.00 | 2.5E-10 | 6.4E-09 |       1.1E+10  ok|
| P - Mass             | 0.00 | 2.2E-03 | 3.0E-02 | 12.0  9.5E-02  OK|
+----------------------+------+---------+---------+------------------+
| H-Energy             | 0.00 | 3.6E-03 | 3.6E-02 |  5.4  8.0E-03  OK|
+----------------------+------+---------+---------+------------------+
======================================================================
OUTER LOOP ITERATION =    2                     CPU SECONDS = 1.24E+01
----------------------------------------------------------------------
|       Equation       | Rate | RMS Res | Max Res |  Linear Solution |
+----------------------+------+---------+---------+------------------+
| U - Mom              |99.99 | 5.2E-03 | 7.5E-02 |       4.8E-02  OK|
| V - Mom              |99.76 | 1.6E-02 | 1.6E-01 |       1.4E-02  OK|
| W - Mom              |99.99 | 8.4E-03 | 1.2E-01 |       7.9E-02  OK|
| P - Mass             | 4.26 | 9.3E-03 | 1.3E-01 |  8.3  8.4E-02  OK|
+----------------------+------+---------+---------+------------------+
| H-Energy             | 0.35 | 1.3E-03 | 8.8E-03 |  9.4  2.9E-03  OK|
+----------------------+------+---------+---------+------------------+
................
................
======================================================================
OUTER LOOP ITERATION =   29                     CPU SECONDS = 2.44E+02
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----------------------------------------------------------------------
|       Equation       | Rate | RMS Res | Max Res |  Linear Solution |
+----------------------+------+---------+---------+------------------+
| U - Mom              | 0.86 | 7.7E-05 | 3.1E-04 |       5.1E-02  OK|
| V - Mom              | 0.86 | 9.1E-05 | 3.7E-04 |       4.8E-02  OK|
| W - Mom              | 0.86 | 1.9E-05 | 1.6E-04 |       5.0E-02  OK|
| P - Mass             | 0.87 | 3.7E-05 | 1.7E-04 |  8.3  3.0E-02  OK|
+----------------------+------+---------+---------+------------------+
| H-Energy             | 0.86 | 5.7E-06 | 5.5E-05 |  9.5  9.8E-03  OK|
+----------------------+------+---------+---------+------------------+
CFD Solver finished: Wed Oct 25 16:01:48 2000
CFD Solver wall clock seconds: 1.0000E+00

If a steady state analysis is continued, then the outer loop iterations and CPU seconds for the current run are enclosed
in parenthesis, as shown below. Values not enclosed in parenthesis are the totals for the overall analysis.

======================================================================
OUTER LOOP ITERATION =   30 (    1) CPU SECONDS = 2.48E+02 ( 3.38E+00)
----------------------------------------------------------------------
|       Equation       | Rate | RMS Res | Max Res |  Linear Solution |
+----------------------+------+---------+---------+------------------+
| U - Mom              | 0.00 | 1.5E-04 | 1.2E-03 |       4.6E-02  OK|
| V - Mom              | 0.00 | 2.1E-04 | 1.2E-03 |       3.8E-02  OK|
| W - Mom              | 0.00 | 1.5E-04 | 2.1E-03 |       1.3E-02  OK|
| P - Mass             | 0.00 | 3.2E-05 | 1.5E-04 |  8.3  3.4E-02  OK|
+----------------------+------+---------+---------+------------------+
| H-Energy             | 0.00 | 7.7E-06 | 8.5E-05 |  9.5  9.1E-03  OK|
+----------------------+------+---------+---------+------------------+

Computed Model Constants
If the Zero Equation model is used to model turbulence, the overall turbulence viscosity is provided.

The section for computed model constants looks similar to the following:

+--------------------------------------------------------------------+
|                      Computed Model Constants                      |
+--------------------------------------------------------------------+
Turbulence viscosity for Turbulence Model 1   = 3.3667E+00

Termination and Interrupt Condition Summary
After executing each coefficient iteration and time step (or outer iteration), the solver evaluates all internal termination
conditions and user-defined interrupt control conditions. After a termination or interrupt, any of these conditions
that are true are reported in the CFX-Solver Output file as outlined below.

 ======================================================================
               Termination and Interrupt Condition Summary  
 ======================================================================
CFD Solver: <internal termination condition description> 
User: <interrupt condition object name> 

Global Conservation Statistics
Global conservation statistics are generated for all transport equations with the exception of turbulence equations
that have special wall treatment. These are good checks for the convergence of a solution. Small values of global
imbalance indicate that conservation has essentially been achieved. The percentage imbalance of a quantity is
calculated as follows:
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=% imbalance Domain Imbalance
Maximum Over All Domains

where “Maximum Over All Domains” is the maximum absolute value, over all boundaries and sources, in all
domains. For domain sources, with the exception of user defined source terms, the positive and negative contributions
are balanced separately.

For details, see Monitoring and Obtaining Convergence (p. 336) in the ANSYS CFX-Solver Modeling Guide.

The section for global conservation statistics looks similar to the following:

 ======================================================================
              Boundary Flow and Total Source Term Summary
 ======================================================================

 +--------------------------------------------------------------------+
 |                               U-Mom                                |
 +--------------------------------------------------------------------+
 Boundary         : CatConv Default                        -9.4754E-01
 Boundary         : Inlet                                   1.6971E+00
 Boundary         : InletSide Side 1                        1.3262E-05
 Boundary         : Outlet                                 -1.0523E+00
 Boundary         : OutletSide Side 1                      -1.7085E-07
 Sub-Domain       : catalyst                                2.6129E-01
 Neg Accumulation : CatConv                                 4.1436E-02
 Domain Interface : InletSide (Side 1)                     -1.1166E-02
 Domain Interface : InletSide (Side 2)                      1.1166E-02
 Domain Interface : OutletSide (Side 1)                    -1.4308E-05
 Domain Interface : OutletSide (Side 2)                     1.4308E-05
                                                           -----------
 Domain Imbalance :                                        -3.6059E-05

 Domain Imbalance, in %:                                     -0.0002 %

 +--------------------------------------------------------------------+
 |                               V-Mom                                |
 +--------------------------------------------------------------------+
 Boundary         : CatConv Default                        -3.3355E-02
 Boundary         : Inlet                                   1.1009E-07
 Boundary         : InletSide Side 1                        7.2564E-06
 Boundary         : Outlet                                 -4.7561E-04
 Boundary         : OutletSide Side 1                       1.9734E-08
 Sub-Domain       : catalyst                                3.4056E-02
 Neg Accumulation : CatConv                                -2.4319E-04
 Domain Interface : InletSide (Side 1)                     -4.7260E-04
 Domain Interface : InletSide (Side 2)                      4.7262E-04
 Domain Interface : OutletSide (Side 1)                     7.5672E-06
 Domain Interface : OutletSide (Side 2)                    -7.5672E-06
                                                           -----------
 Domain Imbalance :                                        -1.0275E-05

 Domain Imbalance, in %:                                      0.0000 %

 +--------------------------------------------------------------------+
 |                               W-Mom                                |
 +--------------------------------------------------------------------+
 Boundary         : CatConv Default                        -1.1450E+01
 Boundary         : Inlet                                  -1.6971E+00
 Boundary         : InletSide Side 1                        1.3180E-01
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 Boundary         : Outlet                                  1.0628E+00
 Boundary         : OutletSide Side 1                      -6.8369E-02
 Sub-Domain       : catalyst                                1.2137E+01
 Neg Accumulation : CatConv                                -1.8195E-01
 Domain Interface : InletSide (Side 1)                      2.2715E+01
 Domain Interface : InletSide (Side 2)                     -2.2592E+01
 Domain Interface : OutletSide (Side 1)                    -1.0548E+01
 Domain Interface : OutletSide (Side 2)                     1.0493E+01
                                                           -----------
 Domain Imbalance :                                         1.4353E-03

 Domain Imbalance, in %:                                      0.0063 %

 +--------------------------------------------------------------------+
 |                               P-Mass                               |
 +--------------------------------------------------------------------+
 Boundary         : Inlet                                   2.8382E-02
 Boundary         : Outlet                                 -5.6938E-02
 Neg Accumulation : CatConv                                 2.8576E-02
 Domain Interface : InletSide (Side 1)                     -3.0665E-02
 Domain Interface : InletSide (Side 2)                      3.0665E-02
 Domain Interface : OutletSide (Side 1)                     5.6543E-02
 Domain Interface : OutletSide (Side 2)                    -5.6543E-02
                                                           -----------
 Domain Imbalance :                                         2.0828E-05

 Domain Imbalance, in %:                                      0.0366 %

 +--------------------------------------------------------------------+
 |                            I-Radiation                             |
 +--------------------------------------------------------------------+
 Boundary         : CatConv Default                        -1.4392E+01
 Boundary         : Inlet                                   1.9442E+01
 Boundary         : InletSide Side 1                        3.8307E-01
 Boundary         : Outlet                                 -6.1793E+00
 Boundary         : OutletSide Side 1                      -1.7803E-01
 Domain Src (Neg) : CatConv                                -2.9646E-01
 Domain Src (Pos) : CatConv                                 3.0447E-01
 Domain Interface : InletSide (Side 1)                     -4.6702E+02
 Domain Interface : InletSide (Side 2)                      4.6702E+02
 Domain Interface : OutletSide (Side 1)                    -7.4487E+01
 Domain Interface : OutletSide (Side 2)                     7.4490E+01
                                                           -----------
 Domain Imbalance :                                        -9.0640E-01

 Domain Imbalance, in %:                                     -0.1941 %

 +--------------------------------------------------------------------+
 |                              H-Energy                              |
 +--------------------------------------------------------------------+
 Boundary         : CatConv Default                         1.4284E+01
 Boundary         : Inlet                                   8.6049E+03
 Boundary         : InletSide Side 1                       -3.8344E-01
 Boundary         : Outlet                                 -2.3960E+02
 Boundary         : OutletSide Side 1                       1.7809E-01
 Domain Src (Neg) : CatConv                                -3.0461E-01
 Domain Src (Pos) : CatConv                                 2.9616E-01
 Neg Accumulation : CatConv                                -8.3717E+03
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 Domain Interface : InletSide (Side 1)                     -7.6620E+03
 Domain Interface : InletSide (Side 2)                      7.6620E+03
 Domain Interface : OutletSide (Side 1)                     1.3624E+02
 Domain Interface : OutletSide (Side 2)                    -1.3624E+02
                                                           -----------
 Domain Imbalance :                                         7.6699E+00

 Domain Imbalance, in %:                                      0.0891 %

Calculated Wall Forces and Moments
The CFX-Solver calculates the pressure and viscous components of forces on all boundaries specified as walls. The
drag force on any wall can be calculated from these values as follows:

Lift is the net force on the body in the direction perpendicular to the direction of flow. In the above diagram, the
lift is the sum of the forces on the wall in the vertical direction, that is, the sum of the pressure force and the viscous
force components in the y direction.

Drag is the net force on the body in the direction of the flow. In the above diagram, the drag is the sum of the forces
on the wall in the horizontal direction, that is, the sum of the pressure force and the viscous force components in
the x direction.

It is apparent from this that viscous force is not a pure shear force since it also has a small component in the normal
direction, arising in part from a normal component in the laminar flow shear stress.

The pressure and viscous moments are related to the pressure and viscous forces calculated at the wall. The pressure
moment is the vector product of the pressure force vector Fn and the position vector r. The viscous moment is the

vector product of the viscous force vectorFt and the position vector r. As an example, review Equation 3.2 (p. 40)

where Mn and Mt are the pressure and viscous moments respectively.

(Eq. 3.2)
= ×

= ×

M r F

M r F
n n

t t

These are summed over all the surface elements in the wall.

It is important to note that forces are evaluated in the local reference frame and that they do not include reference
pressure effects. The pressure force is calculated as the integral of the relative pressure over the wall area and not
as the integral of the sum of the reference and relative pressures. You can include reference pressure effects in the
force calculation by setting the expert parameter include pref in forces = t.

It is also important to note that for rotating domains in a transient run, forces are evaluated in the reference frame
fixed to the initial domain orientation. These quantities are not influenced by any rotation that might occur during
a transient run or when a rotational offset is specified. However, results for rotating domains in a transient run may
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be in the rotated position (depending on the setting of Options in CFD-Post) when they are subsequently loaded
into CFD-Post for post-processing.

The sections for calculated wall forces and moments look similar to the following:

 ======================================================================
                     Wall Force and Moment Summary
 ======================================================================

 Notes:
 1. Pressure integrals exclude the reference pressure.  To include
    it, set the expert parameter 'include pref in forces = t'.

 +--------------------------------------------------------------------+
 |                      Pressure Force On Walls                       |
 +--------------------------------------------------------------------+
                                    X-Comp.      Y-Comp.      Z-Comp.

 Domain Group: Bottom Box

 Copy of Walls                    7.5841E+01   8.4350E+01  -5.2096E+02
 Top Box Default                 -5.4841E+01   0.0000E+00   0.0000E+00
 Walls                            4.8468E+01   1.2755E+02   5.0230E+02
                                  -----------  -----------  -----------
 Domain Group Totals :            6.9468E+01   2.1190E+02  -1.8659E+01

 +--------------------------------------------------------------------+
 |                       Viscous Force On Walls                       |
 +--------------------------------------------------------------------+
                                    X-Comp.      Y-Comp.      Z-Comp.

 Domain Group: Bottom Box

 Copy of Walls                   -3.4280E-04  -1.8638E-03  -5.7310E-04
 Top Box Default                 -4.7982E-05   5.5391E-06  -2.2129E-05
 Walls                            2.9180E-04  -4.3111E-05  -6.2137E-04
                                  -----------  -----------  -----------
 Domain Group Totals :           -9.8980E-05  -1.9014E-03  -1.2166E-03

Maximum Residual Statistics
The location and occurrence of maximum and peak residuals can help to pinpoint convergence difficulties and help
to indicate the state of convergence of your solution.

The sections for maximum residual statistics look similar to the following:

+--------------------------------------------------------------------+
|                   Locations of Maximum Residuals                   |
+--------------------------------------------------------------------+
|       Equation       |  Node # |     X     |     Y     |     Z     |
+--------------------------------------------------------------------+
| U - Mom              |     728 | 6.168E-01 | 5.387E-02 |-6.187E-01 |
| V - Mom              |      85 | 6.136E-01 | 1.902E+00 | 6.846E-01 |
| W - Mom              |     483 |-6.772E-01 | 2.826E-01 |-8.441E-01 |
| P - Mass             |     413 | 7.552E-01 |-3.366E-01 |-7.821E-01 |
| H-Energy             |    2083 | 6.121E-01 | 1.640E+00 | 1.178E+00 |
+--------------------------------------------------------------------+
+--------------------------------------------------------------------+
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|                      Peak Values of Residuals                      |
+--------------------------------------------------------------------+
|       Equation       |   Loop #  |  Peak Residual | Final Residual |
+--------------------------------------------------------------------+
| U - Mom              |        2  |   5.22793E-03  |   7.67906E-05  |
| V - Mom              |        2  |   1.55203E-02  |   9.05021E-05  |
| W - Mom              |        2  |   8.44563E-03  |   1.87603E-05  |
| P - Mass             |        2  |   9.33986E-03  |   3.72930E-05  |
| H-Energy             |        1  |   3.58668E-03  |   5.74081E-06  |
+--------------------------------------------------------------------+

False Transient Information
This is only applicable to steady-state simulations (serial and parallel). The information is equation based, that is
there is one line per equation solved. For each equation, the type of timestepping used is displayed as Auto,
Physical or Local.

Both Auto and Physical run as false transients. This means that although the simulation is steady state, a transient
term with an associated timestep is used to relax the equations during convergence. In this case, the total elapsed
pseudo-time is also printed.

The section for false transient information looks similar to the following:

+--------------------------------------------------------------------+
|                   False Transient Information                      |
+--------------------------------------------------------------------+
|       Equation       |       Type        |   Elapsed Pseudo-Time   |
+--------------------------------------------------------------------+
| U - Mom              | Physical          |      5.80000E+01        |
| V - Mom              | Physical          |      5.80000E+01        |
| W - Mom              | Physical          |      5.80000E+01        |
| P - Mass             | Physical          |      5.80000E+01        |
| H-Energy             | Physical          |      5.80000E+01        |
+--------------------------------------------------------------------+

Final Average Scales
These are average scales for the final flow field.

The section for final average scales looks similar to the following:

+--------------------------------------------------------------------+
|                     Average Scale Information                      |
+--------------------------------------------------------------------+
Domain Name : StaticMixer
Global Length                                          =  3.2113E+00
 Density                                             =  9.9800E+02
 Dynamic Viscosity                                   =  1.0000E-03
 Velocity                                            =  1.4534E+00
 Advection Time                                      =  2.2095E+00
 Reynolds Number                                     =  4.6581E+06
 Thermal Conductivity                                =  5.9100E-01
 Specific Heat Capacity at Constant Pressure         =  4.1900E+03
 Prandtl Number                                      =  7.0897E+00
 Temperature Range                                   =  3.0008E+01

Variable Range Information
These are the maximum and minimum values for each variable in the flow field.

The section for variable range information looks similar to the following:
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+--------------------------------------------------------------------+
|                     Variable Range Information                     |
+--------------------------------------------------------------------+
Domain Name : StaticMixer
+--------------------------------------------------------------------+
|      Variable Name                         |    min    |    max    |
+--------------------------------------------------------------------+
| Velocity u                                 | -1.65E+00 |  1.61E+00 |
| Velocity v                                 | -2.26E+00 |  2.25E+00 |
| Velocity w                                 | -4.13E+00 |  2.58E-01 |
| Pressure                                   | -6.71E+02 |  1.38E+04 |
| Density                                    |  9.98E+02 |  9.98E+02 |
| Dynamic Viscosity                          |  1.00E-03 |  1.00E-03 |
| Specific Heat Capacity at Constant Pressure|  4.19E+03 |  4.19E+03 |
| Thermal Conductivity                       |  5.91E-01 |  5.91E-01 |
| Thermal Expansivity                        |  2.10E-04 |  2.10E-04 |
| Eddy Viscosity                             |  1.89E+01 |  1.89E+01 |
| Temperature                                |  2.85E+02 |  3.15E+02 |
| Static Enthalpy                            |  1.19E+06 |  1.32E+06 |
+--------------------------------------------------------------------+

CPU Requirements
The section for CPU requirements looks similar to the following:

+--------------------------------------------------------------------+
 |           CPU Requirements of Numerical Solution - Total           |
 +--------------------------------------------------------------------+

 Subsystem Name                  Discretization       Linear Solution
                                (secs.   %total)     (secs.   %total) 
 ----------------------------------------------------------------------
 Momentum and Mass              2.50E-01  10.5 %     7.81E-02   3.3 %
                                -------- -------     --------  ------
 Subsystem Summary              2.50E-01  10.5 %     7.81E-02   3.3 %

 Variable Updates               1.25E-01    5.3 %
 File Reading                   1.41E-01    5.9 %
 File Writing                   6.25E-02    2.6 %
 Miscellaneous                  1.72E+00   72.4 %
                                --------
 Total                          2.38E+00

Job Information
The section for job information looks similar to the following:

 +--------------------------------------------------------------------+
 |                          Job Information                           |
 +--------------------------------------------------------------------+
 Host computer: machinename
 Job finished:   Fri Feb 10 15:14:32 2006
 Total CPU time: 9.524E+01 seconds
             or: (          0:         0:         1:    35.240 )
                 (       Days:     Hours:   Minutes:   Seconds )
 Total wall clock time: 2.720E+02 seconds
             or: (          0:         0:         1:    42.000 )
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                 (       Days:     Hours:   Minutes:   Seconds )
End of solution stage.

CFX-Solver Output File (Transient Runs)
For transient runs, the CFX-Solver outputs convergence information for each coefficient iteration.

At the completion of each timestep iteration, the following information is also written to the CFX-Solver Output
file:

• Global conservation statistics

• Calculated wall forces and moments

• Maximum residual statistics

• Average scale information

Convergence History
The convergence history for a transient analysis looks similar to the following:

=======================================================================
 TIME STEP =   2   SIMULATION TIME = 5.00E-01    CPU SECONDS = 2.14E+01
 ----------------------------------------------------------------------
 COEFFICIENT LOOP ITERATION =   1
 ----------------------------------------------------------------------
 |       Equation       | Rate | RMS Res | Max Res |  Linear Solution |
 +----------------------+------+---------+---------+------------------+
 | U - Mom              |99.99 | 9.6E-01 | 7.7E+00 |       5.8E-04  OK|
 | V - Mom              |99.99 | 2.2E-01 | 2.9E+00 |       2.7E-03  OK|
 | W - Mom              |99.99 | 4.2E-01 | 4.4E+00 |       5.4E-04  OK|
 | P - Mass             |  .12 | 3.0E-03 | 4.0E-02 | 12.0  4.6E-02  OK|
 +----------------------+------+---------+---------+------------------+
 | Smoke                |  .89 | 6.4E-02 | 7.3E-01 |  5.4  5.4E-05  OK|
 +----------------------+------+---------+---------+------------------+
 | K-TurbKE             |  .53 | 2.1E-01 | 5.0E-01 |  5.4  3.9E-05  OK|
 +----------------------+------+---------+---------+------------------+
 | E-Diss.K             |  .73 | 5.2E-01 | 9.5E-01 |  5.4  2.4E-05  OK|
 +----------------------+------+---------+---------+------------------+
 ----------------------------------------------------------------------
 COEFFICIENT LOOP ITERATION =   2                CPU SECONDS = 2.83E+01
 ----------------------------------------------------------------------
 |       Equation       | Rate | RMS Res | Max Res |  Linear Solution |
 +----------------------+------+---------+---------+------------------+
 | U - Mom              |  .14 | 1.4E-01 | 1.3E+00 |       2.0E-03  OK|
 | V - Mom              |  .16 | 3.5E-02 | 4.9E-01 |       8.3E-03  OK|
 | W - Mom              |  .14 | 5.8E-02 | 1.0E+00 |       1.6E-03  OK|
 | P - Mass             |  .65 | 1.9E-03 | 3.7E-02 |  8.3  5.3E-02  OK|
 +----------------------+------+---------+---------+------------------+
 | Smoke                |  .29 | 1.9E-02 | 2.6E-01 |  5.4  5.6E-05  OK|
 +----------------------+------+---------+---------+------------------+
 | K-TurbKE             |  .17 | 3.6E-02 | 2.2E-01 |  5.4  8.2E-05  OK|
 +----------------------+------+---------+---------+------------------+
 | E-Diss.K             |  .16 | 8.3E-02 | 2.4E-01 |  5.4  6.4E-05  OK|
 +----------------------+------+---------+---------+------------------+
 ----------------------------------------------------------------------
 COEFFICIENT LOOP ITERATION =   3                CPU SECONDS = 3.50E+01
 ----------------------------------------------------------------------
 |       Equation       | Rate | RMS Res | Max Res |  Linear Solution |
 +----------------------+------+---------+---------+------------------+
 | U - Mom              |  .24 | 3.3E-02 | 2.8E-01 |       3.8E-03  OK|
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 | V - Mom              |  .23 | 8.0E-03 | 1.1E-01 |       1.4E-02  OK|
 | W - Mom              |  .25 | 1.4E-02 | 2.5E-01 |       3.3E-03  OK|
 | P - Mass             |  .68 | 1.3E-03 | 2.0E-02 |  8.3  3.6E-02  OK|
 +----------------------+------+---------+---------+------------------+
 | Smoke                |  .36 | 6.8E-03 | 1.1E-01 |  5.4  6.1E-05  OK|
 +----------------------+------+---------+---------+------------------+
 | K-TurbKE             |  .38 | 1.4E-02 | 1.2E-01 |  5.4  8.7E-05  OK|
 +----------------------+------+---------+---------+------------------+
 | E-Diss.K             |  .39 | 3.3E-02 | 1.2E-01 |  5.4  8.4E-05  OK|
 +----------------------+------+---------+---------+------------------+

If a transient analysis is continued, then the time step counter, simulation time, and CPU seconds for the current
run are enclosed in parenthesis below the totals for the overall analysis, as shown below.

=======================================================================
 TIME STEP =     3 SIMULATION TIME = 7.50E-01    CPU SECONDS = 2.84E+01
 (THIS RUN:      1                   2.50E-01                  7.00+00)
 ----------------------------------------------------------------------
 COEFFICIENT LOOP ITERATION =   1
 ----------------------------------------------------------------------
 |       Equation       | Rate | RMS Res | Max Res |  Linear Solution |
 +----------------------+------+---------+---------+------------------+
 | U - Mom              |99.99 | 9.6E-01 | 7.7E+00 |       5.8E-04  OK|
 | V - Mom              |99.99 | 2.2E-01 | 2.9E+00 |       2.7E-03  OK|
 | W - Mom              |99.99 | 4.2E-01 | 4.4E+00 |       5.4E-04  OK|
 | P - Mass             |  .12 | 3.0E-03 | 4.0E-02 | 12.0  4.6E-02  OK|
 +----------------------+------+---------+---------+------------------+
 | Smoke                |  .89 | 6.4E-02 | 7.3E-01 |  5.4  5.4E-05  OK|
 +----------------------+------+---------+---------+------------------+
 | K-TurbKE             |  .53 | 2.1E-01 | 5.0E-01 |  5.4  3.9E-05  OK|
 +----------------------+------+---------+---------+------------------+
 | E-Diss.K             |  .73 | 5.2E-01 | 9.5E-01 |  5.4  2.4E-05  OK|
 +----------------------+------+---------+---------+------------------+

CFX-Solver Output File (Interpolation Runs)
This section outlines the additional information that is written to the CFX-Solver Output file for CFX-Solver jobs
that require interpolation.

======================================================================
                 Interpolating Onto Domain "Bottom Box"
 ======================================================================

 Total Number of Nodes in the Target Domain              =          343
 Bounding Box Volume of the Target Mesh                  =  2.70000E+01

 Checking all source domains from the source file:
   Target mesh is different from domain "Top Box".

 Searching for Candidate Source Domains:

 Warning: The target mesh does not intersect with any source meshes 
          that have the same domain type and motion. 
          Skip the interpolation. 

 ======================================================================
                  Interpolating Onto Domain "Top Box"
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 ======================================================================

 Total Number of Nodes in the Target Domain              =          343
 Bounding Box Volume of the Target Mesh                  =  2.70000E+01

 Checking all source domains from the source file:
   Target mesh is the same as domain "Top Box".

 Start direct copying of variables from domain "Top Box".

 +--------------------------------------------------------------------+
 |                     Variable Range Information                     |
 +--------------------------------------------------------------------+
 +--------------------------------------------------------------------+
 |      Variable Name                         |    min    |    max    |
 +--------------------------------------------------------------------+
 | Thermal Conductivity                       |  2.61E-02 |  2.61E-02 |
 | Courant Number                             |  9.86E-02 |  4.52E+00 |
 | Density                                    |  1.18E+00 |  1.18E+00 |
 | Static Entropy                             |  0.00E+00 |  0.00E+00 |
 | Pressure                                   |  1.59E+01 |  6.01E+01 |
 | Specific Heat Capacity at Constant Pressure|  1.00E+03 |  1.00E+03 |
 | Specific Heat Capacity at Constant Volume  |  1.00E+03 |  1.00E+03 |
 | Temperature                                |  2.98E+02 |  2.98E+02 |
 | Velocity                                   |  2.02E-01 |  8.09E+00 |
 | Dynamic Viscosity                          |  1.83E-05 |  1.83E-05 |
 +--------------------------------------------------------------------+

CFX-Solver Output File (Parallel Runs)
This section outlines the additional information that is written to the CFX-Solver Output file for CFX-Solver jobs
submitted in parallel.

Partitioning Information
If the partitioning step is run, partitioning information pertaining to the current job is displayed. This includes how
the mesh is divided, and CPU requirements for the partitioning process.

The section for partitioning information looks similar to the following:

+--------------------------------------------------------------------+
 |                     Vertex Based Partitioning                      |
 +--------------------------------------------------------------------+

 Partitioning of domain: Bottom Box

 - Partitioning tool:       MeTiS multilevel k-way algorithm
 - Number of partitions:             2
 - Number of graph-nodes:          343
 - Number of graph-edges:         1764

 +--------------------------------------------------------------------+
 |                      Partitioning Information                      |
 +--------------------------------------------------------------------+

 Partitioning information for domain: Bottom Box

        +------------------+------------------------+-----------------+
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        |     Elements     |        Vertices        |     Faces       |
 +------+------------------+------------------------+-----------------+
 | Part |   Number     %   |   Number     %   %Ovlp |  Number     %   |
 +------+------------------+------------------------+-----------------+
 | Full |       216        |       343              |      216        |
 +------+------------------+------------------------+-----------------+
 |    1 |       173   61.8 |       317   61.9  36.6 |      175   62.5 |
 |    2 |       107   38.2 |       195   38.1  27.2 |      105   37.5 |
 +------+------------------+------------------------+-----------------+
 | Sum  |       280  100.0 |       512  100.0  33.0 |      280  100.0 |
 +------+------------------+------------------------+-----------------+

 +--------------------------------------------------------------------+
 |                 Partitioning CPU-Time Requirements                 |
 +--------------------------------------------------------------------+

 - Preparations                                       0.000E+00 seconds
 - Low-level mesh partitioning                        0.000E+00 seconds
 - Gather zone interface information                  0.000E+00 seconds
 - Global partitioning information                    0.000E+00 seconds
 - Element and face partitioning information          0.000E+00 seconds
 - Vertex partitioning information                    0.000E+00 seconds
 - Partitioning information compression               0.000E+00 seconds
 - Summed CPU-time for mesh partitioning              0.000E+00 seconds

Job Information
The section for job information includes master and slave partition process details, and looks similar to the following:

+--------------------------------------------------------------------+
 |                          Job Information                           |
 +--------------------------------------------------------------------+

 Run mode:       parallel run (MPI)

 Host computer:    Speedy
 Par. Process:     Master running on mesh partition:       1
 Solver Build:     Wed Nov 19 04:07:01 EST 2008
 Attributes:       double-int32-64bit-novc8-noifort-novc6-optimised-su...
 Job started:      Wed Nov 19 15:39:39 2008

 Host computer:    Speedier
 Par. Process:     Slave  running on mesh partition:       2
 Solver Build:     Wed Nov 19 04:07:01 EST 2008
 Attributes:       double-int32-64bit-novc8-noifort-novc6-optimised-su...
 Job started:      Wed Nov 19 15:39:39 2008

Host Information
The section for host information looks similar to the following:

+-----------------------------------------------------------------------+
|                           Host Information                            |
+-----------------------------------------------------------------------+
| Name            |  Rel. Speed  | # of Proc. | # of Part  | Stat. Load |
+-----------------+--------------+------------+------------+------------+
| camel           |      1.00000 |          1 |          1 |    100.0 % |
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| giraffe         |      1.00000 |          1 |          1 |    100.0 % |
+-----------------+--------------+------------+------------+------------+

Memory Usage Information
The section for memory usage information looks similar to the following:

+--------------------------------------------------------------------+
 |        Memory Allocated for Run  (Actual usage may be less)        |
 +--------------------------------------------------------------------+

 Allocated storage in:    Kwords
                          Words/Node
                          Words/Elem
                          Kbytes
                          Bytes/Node

 Partition | Real       | Integer    | Character| Logical  | Double
 ----------+------------+------------+----------+----------+----------
         1 |     2095.0 |     1679.2 |   3417.7 |     65.0 |      8.0
           |    3809.15 |    3053.14 |  6213.99 |   118.18 |    14.55
           |    6914.29 |    5542.00 | 11279.52 |   214.52 |    26.40
           |    16367.4 |     6559.5 |   3337.6 |     63.5 |     62.5
           |   30473.16 |   12212.55 |  6213.99 |   118.18 |   116.36
 ----------+------------+------------+----------+----------+----------
         2 |     1937.7 |     1672.6 |   3417.7 |     65.0 |      8.0
           |    4185.05 |    3612.62 |  7381.63 |   140.39 |    17.28
           |    7598.74 |    6559.39 | 13402.73 |   254.90 |    31.37
           |    15138.1 |     6533.8 |   3337.6 |     63.5 |     62.5
           |   33480.42 |   14450.50 |  7381.63 |   140.39 |   138.23
 ----------+------------+------------+----------+----------+----------
     Total |     4032.7 |     3351.9 |   6835.4 |    130.0 |     16.0
           |    5878.59 |    4886.11 |  9964.13 |   189.50 |    23.32
           |    9334.98 |    7758.96 | 15822.67 |   300.93 |    37.04
           |    31505.5 |    13093.2 |   6675.2 |    127.0 |    125.0
           |   47028.68 |   19544.43 |  9964.13 |   189.50 |   186.59
 ----------+------------+------------+----------+----------+----------

Completed Job Information
The section for completed job information looks similar to the following:

+--------------------------------------------------------------------+
|                          Job Information                           |
+--------------------------------------------------------------------+
Host computer:  fastmachine1
Par. Process:   Master running on mesh partition:       1
Job finished:   Thu Nov 28 16:44:01 2005
Total CPU time: 9.025E+02 seconds
             or: (          0:         0:        15:     2.517 )
                 (       Days:     Hours:   Minutes:   Seconds )
Host computer:  slowermachine
Par. Process:   Slave  running on mesh partition: 2
Job finished:   Wed Nov 28 16:54:30 2005
Total CPU time: 1.291E+03 seconds
             or: (          0:         0:        21:    31.034 )
                 (       Days:     Hours:   Minutes:   Seconds )
Total wall clock time: 1.146E+03 seconds
            or: (          0:         0:        19:    6.000 )
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                (       Days:     Hours:   Minutes:   Seconds )
--> Master-Partition Nr.  1 reaches final synchronization point!
--> Slave-Partition  Nr.  2 reaches final synchronization point!
End of solution stage.
+--------------------------------------------------------------------+
| The results from this run of the CFX-Solver have been written      |
| to z:\temp\BluntBody_001.res                                                     
+--------------------------------------------------------------------+
This run of the CFX-Solver has finished.

CFX-Solver Output File (Mesh Adaption Runs)
When a mesh adaption step is complete, the CFX-Solver Manager reports the new meshing information, including
the total number of vertices, elements and faces. The CFX-Solver then continues to determine a solution, using the
adapted mesh.

The section for mesh refinement looks similar to the following:

+--------------------------------------------------------------------+
|                                                                    |
|                         Mesh Refinement                            |
|                                                                    |
+--------------------------------------------------------------------+
Adaption step 2 of 3.
Number of elements initially marked for refinement:         480
Number of elements removed because:
 They already meet the minimum length criteria:               0
 They are in regions not marked for refinement:               0
 They are already in the deepest refinement level:            0
 There are not enough nodes available to refine them:      -425
                                                     ----------
                                                             55
                                                     ----------
Target number of nodes at end of step:                     1512
Number of vertices in the final mesh:                      1999
Number of elements in the final mesh:                      1560
+--------------------------------------------------------------------+
|         Total number of Vertices, Elements, and Faces               |
+--------------------------------------------------------------------+
Domain Name      : nozzle vmi
     Total Number of Nodes                  =       1999
     Total Number of Elements               =       1560
         Total Number of Tetrahedrons       =        146
         Total Number of Hexahedrons        =        818
         Total Number of Pyramids           =        596
     Total number of Faces                  =       1702

CFX-Solver Output File (Remeshing Runs)
Each time a run is terminated or interrupted, all remeshing definitions associated with that run are considered for
activation. If any definitions are active, then output similar to the following is generated:

+--------------------------------------------------------------------+
 |                                                                    |
 |                             Remeshing                              |
 |                                                                    |
 +--------------------------------------------------------------------+
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 Remesh Object: Remesh
   Activated by condition: Number of TimeSteps

   Executing remesh command:
      C:\Program Files\ANSYS
      Inc\v110\icemcfd\win64_amd\bin\icemcfd.bat -batch -script
      d:\builds\v120\CFX\etc\Remeshing\icemcfd_Remesh.rpl

 CFX Solver Results generated before remeshing have been written to:
   d:\ICEMRemesh\ballvalve1_001\5_oldmesh.res

 Text output generated during remeshing has been written to:
   d:\ICEMRemesh\ballvalve1_001\5_remesh.out

Each active remesh object is listed, along with the name of the solver interrupt condition(s) that activated it, and
the command used to generate the new mesh. Any output generated during remeshing is redirected into a text file,
which, along with the CFX-Solver Results file from the previous run, is placed into the final results directory for
the run. The locations of these files is listed in the output.

Once the updated meshes have been generated, CFX-Pre loads the CFX-Solver Results file from the previous run,
replaces the old meshes with the updated ones, and writes a new CFX-Solver Input file.

A CFX-Solver run is then started with the new CFX-Solver Input file, using the CFX-Solver Results file from the
previous run for initial values. Partitioning is also performed for parallel run modes.

CFX-Solver Output File (Conjugate Heat Transfer Runs)

Thermal Energy at Solid Boundary
When a solid domain is included, CFX-Solver Manager reports the thermal energy that flows into and out of the
solid, across existing boundaries. If the solid has a source term, the total thermal energy added is included in the
output file, along with the global imbalance.

The section for thermal energy at a solid boundary looks similar to the following:

+--------------------------------------------------------------------+
|         Boundary T-Energy - 2 Flow and Total Source Term Summary   |
+--------------------------------------------------------------------+
Boundary   : Default Solid               0.0000E+00
Boundary   : Default Fluid Solid2       -3.0742E+06
Subdomain  : heater                      3.0685E+06
                                         -----------
Global T-Energy - 2 Balance:            -5.6725E+03
Global Imbalance, in %:                                      -0.1852 %

CFX-Solver Output File (GGI Runs)
Running the CFX Flow Solver for cases that include GGI interfaces is similar to cases without GGI connections.
The following differences, however, will be observed:

• At the start of the simulation, all GGI connection conditions are processed. This may require the computational
effort of the order of a single iteration or timestep of the flow simulation. If a GGI connection condition is found
to contain non-overlapping portions, the percentage of the area of each side that is non-overlapping is reported.
This is a useful diagnostic, and should be reviewed to confirm that the expected amount of non-overlapping
area has been detected.

+--------------------------------------------------------------------+
|             Total Number of Nodes, Elements, and Faces             |
+--------------------------------------------------------------------+
Domain Name : rotor
     Total Number of Nodes                                =       38360
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     Total Number of Elements                             =       33202
         Total Number of Hexahedrons                      =       33202
     Total Number of Faces                                =        9970
 Domain Name : stator
     Total Number of Nodes                                =       33320
     Total Number of Elements                             =      106660
         Total Number of Tetrahedrons                     =       75265
         Total Number of Prisms                           =       31395
     Total Number of Faces                                =       17871
 Domain Interface Name : Rotor Periodic
     Non-overlap area fraction on side 1                  =       0.0 %
     Non-overlap area fraction on side 2                  =       0.0 %
 Domain Interface Name : Stator Periodic
     Non-overlap area fraction on side 1                  =       0.0 %
     Non-overlap area fraction on side 2                  =       0.0 %

• Residual diagnostics will be reported for each set of connected domains having the same physical type. For
example, the mass and momentum equation residuals will be reported independently for each flow passage.

======================================================================
OUTER LOOP ITERATION =   35                     CPU SECONDS = 4.64E+03
----------------------------------------------------------------------
|       Equation       | Rate | RMS Res | Max Res |  Linear Solution |
+----------------------+------+---------+---------+------------------+
| U-Mom-rotor          | 0.92 | 2.2E-05 | 3.6E-04 |                  |
| V-Mom-rotor          | 0.90 | 3.6E-05 | 1.0E-03 |                  |
| W-Mom-rotor          | 0.91 | 4.1E-05 | 9.1E-04 |                  |
| P-Mass-rotor         | 0.94 | 1.2E-05 | 4.7E-04 |                  |
| U-Mom-stator         | 0.89 | 2.1E-05 | 1.1E-03 |       1.3E-02  OK|
| V-Mom-stator         | 0.84 | 9.9E-05 | 3.1E-03 |       3.1E-02  OK|
| W-Mom-stator         | 0.86 | 7.4E-05 | 3.8E-03 |       2.6E-02  OK|
| P-Mass-stator        | 0.89 | 1.4E-05 | 3.8E-04 | 10.0  6.6E-02  OK|
+----------------------+------+---------+---------+------------------+
| H-Energy-rotor       | 0.92 | 7.7E-06 | 2.5E-04 |                  |
| H-Energy-stator      | 0.88 | 5.4E-06 | 1.7E-04 |  6.1  5.4E-02  OK|
+----------------------+------+---------+---------+------------------+
| K-TurbKE-rotor       | 1.62 | 1.2E-04 | 5.7E-03 |                  |
| K-TurbKE-stator      | 0.86 | 1.1E-04 | 3.5E-03 |  6.1  9.7E-02  OK|
+----------------------+------+---------+---------+------------------+
| E-Diss.K-rotor       | 2.52 | 4.0E-04 | 1.6E-02 |                  |
| E-Diss.K-stator      | 0.87 | 1.8E-04 | 4.9E-03 |  7.5  1.5E-03  OK|
+----------------------+------+---------+---------+------------------

• Flows across GGI interfaces will be reported in flow summary diagnostics. Changes in GGI flows will occur
in various situations. For example, momentum flows change as they undergo rotation at rotational periodic GGI
connections. All transport equation flows, including the mass equation, change for the case of pitch change at
a frame change GGI connection, as well as the energy equation flows as conservation changes from absolute
frame to relative frame energy components. Forces are also reported in the momentum flow balances at contiguous
and periodic GGI connections, for cases having non-overlapping portions of the interface.

• Various quantities such as ranges of dependent variables, locations of maximum residuals, etc., are reported at
the end of the simulation on a per-domain basis.

+--------------------------------------------------------------------+
|                   Locations of Maximum Residuals                   |
+--------------------------------------------------------------------+
|       Equation       |  Node # |     X     |     Y     |     Z     |
+--------------------------------------------------------------------+
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| U-Mom-rotor          |    5109 | 3.849E-01 | 4.761E-02 | 1.572E-01 |
| V-Mom-rotor          |    4501 | 3.846E-01 | 5.065E-02 | 1.176E-01 |
| W-Mom-rotor          |    3085 | 3.802E-01 | 5.029E-02 | 1.177E-01 |
| P-Mass-rotor         |    3642 | 3.799E-01 | 5.260E-02 | 1.572E-01 |
| U-Mom-stator         |   32356 | 4.535E-01 | 5.403E-02 | 5.000E-02 |
| V-Mom-stator         |     496 | 4.541E-01 | 5.343E-02 | 4.939E-02 |
| W-Mom-stator         |     496 | 4.541E-01 | 5.343E-02 | 4.939E-02 |
| P-Mass-stator        |    2275 | 4.536E-01 | 5.349E-02 | 4.949E-02 |
| H-Energy-rotor       |   18527 | 4.535E-01 | 5.694E-02 | 5.263E-02 |
| H-Energy-stator      |     498 | 4.541E-01 | 5.352E-02 | 4.961E-02 |
| K-TurbKE-rotor       |    8583 | 4.110E-01 | 4.671E-02 | 5.692E-02 |
| E-Diss.K-rotor       |    8598 | 4.109E-01 | 4.667E-02 | 5.719E-02 |
| K-TurbKE-stator      |    7264 | 4.540E-01 | 5.358E-02 | 4.959E-02 |
| E-Diss.K-stator      |    7264 | 4.540E-01 | 5.358E-02 | 4.959E-02 |
+--------------------------------------------------------------------+

CFX-Solver Output File (Combustion Runs)
Running a combustion simulation in the CFX-Solver is similar to multicomponent fluid runs with the extensions
explained in the following.

Multicomponent Specific Enthalpy Diffusion (MCF)
This applies also to non-reacting multicomponent flow: Multicomponent fluids with heat transfer, for which the
Unity Lewis Number formulation for MCF energy diffusion is applied, are reported.

+--------------------------------------------------------------------+
|          Multi-Component Specific Enthalpy Diffusion                        |
+--------------------------------------------------------------------+
Unity Lewis Number (Le=1) for multi-component specific enthalpy
diffusion applied for fluids below.
Domain Name : run
   Mixture

Single Step Reactions Heat Release
For single step reactions the heat release per chemical amount of reaction is reported. Numbers are in solver units.
Positive numbers indicate exothermic reactions (heat is released) and negative numbers indicate endothermic
reactions (energy required for the reaction to occur). The total heat release in the domain resulting from a particular
reaction can be computed by multiplying the reactions heat release by its molar reaction rate and integrating over
the domain.

+--------------------------------------------------------------------+
|                 Single Step Reactions Heat Release                 |
+--------------------------------------------------------------------+
Enthalpy per [mol] of reaction at reference conditions
(Pressure= 1.01325E+05, Temperature= 2.98150E+02)
    HCO Oxygen                                           =  5.5799E+05
    HCN NO Destruction PDF                               =  1.8194E+05
    HCN NO Formation PDF                                 =  1.3458E+03
    Reburn NO Fuel Gas PDF                               =  2.7885E+05
    Prompt NO Fuel Gas PDF                               = -9.0298E+04
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    Thermal NO PDF                                       = -1.8060E+05
    Fuel Gas Oxygen                                      =  5.1127E+05

Stoichiometric Mixture Fraction
The stoichiometric mixture fraction is reported when a Flamelet model or Burning Velocity model is used.
If the stoichiometric mixture fraction is not specified in the definition of the Flamelet library reaction object, the
stoichiometric value is reported as <unknown>.

+--------------------------------------------------------------------+
|                  Stoichiometric Mixture Fraction                   |
+--------------------------------------------------------------------+
Stoichiometric mixture fraction (Zst) for fluids with mixture
fraction combustion models.
Domain Name : run
    Mixture                                           Zst = 5.5000E-02

Hydrocarbon Fuel Model: Proximate / Ultimate Analysis
For the hydrocarbon fuel model (the Hydrocarbon Fuel option for the Material setting) the results of the
proximate/ultimate analysis calculation are reported:

• The initial composition of the particles (component mass fractions). These values will be applied when no
user-specified initial particle composition is specified (default).

• Molar mass and reference specific enthalpy for the Volatiles material that is released to the gas phase. The
values reported here by default overrule the data specified in the corresponding material object.

• For single step reactions the relative stoichiometric coefficients, which are derived from the fuel analysis, are
reported. These values are applied when the Fuel Analysis option is specified in the reaction for the
corresponding reactant or product.

• For multiphase reactions the relative mass coefficients, which are derived from the fuel analysis, are reported.
These values are applied when the Fuel Analysis option is specified in the reaction for the corresponding
reactant or product.

======================================================================
                  HC Fuel Proximate/Ultimate Analysis
======================================================================
Initial mass fractions for particle : HC Fuel
    Ash                                                  =  1.2580E-01
    Char                                                 =  0.0000E+00
    Raw Combustible                                      =  8.7420E-01
Volatiles material properties : Fuel Gas
    Molar Mass [kg/kmol]                                 =      18.234
    Ref. Spec. Enthalpy (p= 1.01325E+05, T= 2.98150E+02) = -7.1827E+06
+--------------------------------------------------------------------+
|              Autocomputed Stoichiometric Coefficients              |
+--------------------------------------------------------------------+
Reaction (volatiles oxidation) : Fuel Gas Oxygen
  Reactants:
    Fuel Gas                                             =  1.0000E+00
    O2                                                   =  1.3558E+00
  Products:
    CO2                                                  =  9.3953E-01
    H2O                                                  =  1.1267E+00
Reaction (NO reburn) : Reburn NO Fuel Gas PDF
  Reactants:
    Fuel Gas                                             =  3.6879E-01
    NO                                                   =  1.0000E+00
  Products:
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    CO2                                                  =  3.4648E-01
    H2O                                                  =  4.1552E-01
    N2                                                   =  5.0000E-01
+--------------------------------------------------------------------+
|                   Autocomputed Mass Coefficients                   |
+--------------------------------------------------------------------+
Reaction (devolatilisation) : HC Fuel Devolat HCN
  Reactants:
    HC Fuel.Raw Combustible                              =  1.0000E+00
  Products:
    Gas Mixture HCN NO.Fuel Gas                          =  5.0003E-01
    Gas Mixture HCN NO.HCN                               =  1.1857E-02
    HC Fuel.Char                                         =  4.8812E-01
Reaction (char oxidation) : HC Fuel Char Gibb HCN
  Reactants:
    Gas Mixture HCN NO.O2                                =  2.6049E+00
    HC Fuel.Char                                         =  1.0000E+00
  Products:
    Gas Mixture HCN NO.CO2                               =  3.5817E+00
    Gas Mixture HCN NO.HCN                               =  2.3164E-02

CFX-Solver Output File (Particle Runs)

Particle Transport Equations
This section lists the particle transport equations solved during the solver run for each independent domain.

 +--------------------------------------------------------------------+
 |      Particle Transport Equations Solved in This Calculation       |
 +--------------------------------------------------------------------+
Domain Type : Default Domain
   x-Mom-Sand Fully Coupled
   y-Mom-Sand Fully Coupled
   z-Mom-Sand Fully Coupled
   x-Mom-Sand One Way Coupled
   y-Mom-Sand One Way Coupled
   z-Mom-Sand One Way Coupled

For additional information, see Solved Equations (p. 35).

Particle Fate Diagnostics
Within the particle transport model, each particle is tracked until one of the abort criteria is satisfied or the particle
escapes the domain. Particles may also be aborted if a tracking error is found. Because each particle is tracked from
its injection point until some abort criteria is met, it does not influence other particles. Thus, a tracking error for
one particle does not necessarily stop the execution of the CFX-Solver run. However, if some fundamental problem
is found during tracking, then the flow calculations terminates after printing an error message.

At the end of each particle integration step, a diagnostic summary is generated that indicates the fate of all injected
particles as outlined below:

 +--------------------------------------------------------------------+
 |                      Particle Fate Diagnostics                     |
 +--------------------------------------------------------------------+
 | Particle type          | Fate type                       Particles |
 +--------------------------------------------------------------------+
 | Sand Fully Coupled     | Entered domain                :       200 |
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 |                        | Left domain                   :       200 |
 +--------------------------------------------------------------------+

The following fate types may be encountered during particle tracking:

Absorbed by Porous Media
This message indicates the number of particle that have been absorbed by the porous media and is determined by
the Absorption Diameter setting. For details, see Particle Absorption (p. 138) in the ANSYS CFX-Pre User's
Guide.

Continue from Last Time Step (Transient Only)
See Waiting for Next Time Step (Transient only) (p. 56).

Collected on Walls
This message indicates that particles are trapped at the wall because both the parallel and perpendicular restitution
coefficients are zero. As a result, the particle tracking is terminated and the remaining momentum of the particles
is transferred to the wall as a force. For details, see Restitution Coefficients for Particles (p. 200) in the ANSYS
CFX-Solver Modeling Guide.

Entered Domain
This message indicates the number of particles that were injected into the domain either at a boundary or particle
injection region.

Exceeded Distance Limit
This message indicates that these particles have exceeded the maximum tracking distance with respect to the particle
traveling distance. If a large number of particles show this fate, you may need to increase the maximum tracking
distance. For details, see Maximum Tracking Distance (p. 215). Any remaining mass, momentum and energy, which
needs to be exchanged with the fluid to equilibrate the aborted particle with the local fluid properties, is exchanged
in the current control volume.

Exceeded Integration Limit
This message indicates that these particles have exceeded the maximum number of integration steps with respect
to the total number of particle integration steps. If a large number of particles show this fate, you may need to
increase the maximum number of integration steps. For details, see Maximum Number of Integration Steps (p. 215).
Any remaining mass, momentum and energy, which needs to be exchanged with the fluid to equilibrate the aborted
particle with the local fluid properties, is exchanged in the current control volume.

Exceeded Time Limit
This message indicates that these particles have exceeded the maximum tracking time with respect to the particle
traveling time. If a large number of particles show this fate, you may need to increase the maximum tracking time.
For details, see Maximum Tracking Time (p. 215). Any remaining mass, momentum and energy, which needs to
be exchanged with the fluid to equilibrate the aborted particle with the local fluid properties, is exchanged in the
current control volume.

Fell Below Minimum Diameter
This message indicates that evaporating or reacting particles are not tracked below a diameter of 1.0E-8 [m] because
they are too small to have any effect. The minimum diameter can be controlled by expert parameter pt minimum
diameter, see Particle-Tracking Parameters (p. 375).

Integration Error
This message indicates that the tracking of these particles was terminated due to an unexpected error in the particle
tracking integration. If a small number of particles terminate in this way, it is not generally a cause for concern.
Any remaining mass, momentum and energy of the particle is neglected.
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Left Domain
This message indicates the number of particles that have escaped from the domain and are no longer tracked. Any
remaining particle mass, momentum and energy also escapes the domain with particles. This is the normal abort
criterion for particles traveling through inlets, openings and outlets.

Sliding along Walls
This message indicates that particles have stopped as they were hitting the wall below the minimum specified impact
angle. For details, see Fluid Values for Walls (p. 118) in the ANSYS CFX-Pre User's Guide.

Waiting for Next Time Step (Transient only)
All particles that are alive at the end of a fluid time step get the fate Waiting for Next Time Step. When
the next fluid time step is performed, then these particles are continued to be tracked and their fate is changed to
Continue from Last Time Step. So across two time steps, both numbers should be the same.

Transient Particle Diagnostics
The transient particle diagnostics allow you to monitor various quantities, like total mass of particles in the domain,
penetration of particles from a given PIR (Particle Injection Region), or user-defined location. For details, see
Transient Particle Diagnostics (p. 207) in the ANSYS CFX-Solver Modeling Guide. A typical diagnostics output
that is recorded in the CFX-Solver Output file is shown below:

 +--------------------------------------------------------------------+
 |                   Transient Particle Diagnostics                   |
 +--------------------------------------------------------------------+

 Water Droplets

  Total Particle Mass
     Total Particle Mass                       2.0000E-02
  Penetration from PIR
     Axial Penetration                         1.7655E-01
     Radial Penetration                        1.8561E-01
     Normal Penetration                        6.6197E-02
     Spray Angle                               1.9856E+01
  Penetration from Location
     Axial Penetration                         1.7655E-01
     Radial Penetration                        1.8561E-01
     Normal Penetration                        6.6197E-02
     Spray Angle                               4.1836E+01

Particle Convergence History
Coupled particles are solved several times during the simulation and each particle tracking step leads to updated
sources for the transport equations of the coupled continuous phase. A convergence criterion for the particle solver
is the relative change of the generated sources of two successive particle tracking steps. Therefore, a table containing
summary of all coupled particle equations, separately listed for each particle type, is generated at the end of each
particle tracking step. This table contains the information on integrated sources as well as the source change rate
as outlined below.

 +--------------------------------------------------------------------+
 |   Particle Equation    |  Total source and source change rates     |
 +--------------------------------------------------------------------+
 |                        | Equation            Source      Rate      |
 +--------------------------------------------------------------------+
 | Domain: PipeValve                                                  |
 +--------------------------------------------------------------------+
 | Sand Fully Coupled     | x-Mom               4.016E-02   0.0085    |
 |                        | y-Mom               7.765E-02   0.0062    |
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 |                        | z-Mom               1.261E-01   0.0035    |
 +--------------------------------------------------------------------+

The Source column refers to the new particle source to the φ  equation, which is calculated as the sum over all
vertices of the absolute particle source values to that equation. For details, see Particle Source Change Target (p.
214) and Particle Under Relaxation Factors (p. 214) in the ANSYS CFX-Solver Modeling Guide.

The Rate column shows the fractional change in the source between the current and the previous injection. The
source change rate can also be graphically monitored in the CFX-Solver Manager.

For additional information, see Convergence Control for Particle Transport (p. 222) in the ANSYS CFX-Solver
Modeling Guide.

Integrated Particle Flows
At the end of a run, the integrated particle mass, momentum and energy flows over all boundaries and at all particle
injection regions are printed to the CFX-Solver Output file. If the expert parameter MONITOR TOTALS is set to
T, the same information is printed at the end of each particle tracking step. In a transient run, the time integrated
total particle flows are also listed at the end of a run.

CPU Requirements of Numerical Solution
At the end of the run, a summary of the CPU time spent inside of the particle tracking routine is given as outlined
in the table below. This information may be used to determine the time spent per particle.

+--------------------------------------------------------------------+
|               CPU Requirements of Numerical Solution               |
+--------------------------------------------------------------------+

 Subsystem Name                  Discretization       Linear Solution
                                (secs.   %total)     (secs.   %total) 
 ----------------------------------------------------------------------
 Momentum and Mass              1.00E+02  48.2 %     1.79E+01   8.6 %
 TurbKE and Diss.K              3.46E+01  16.6 %     2.17E+01  10.4 %
                                -------- -------     --------  ------
 Subsystem Summary              1.35E+02  64.9 %     3.96E+01  19.1 %

 Particle Tracking              2.18E+01   10.5 %
 Variable Updates               5.91E+00    2.8 %
 File Reading                   6.25E-02    0.0 %
 Miscellaneous                  5.72E+00    2.7 %
                                --------
 Total                          2.08E+02

CFX-Solver Output File (ANSYS Multi-field Runs)
An ANSYS Multi-field run can be launched from the CFX-Solver Manager (or from the command line using the
cfx5solve command) or from the CFX Launcher. Some content is added to the output file for all ANSYS
Multi-field runs, and extra content is added in the case of a run launched by CFX.

If the ANSYS input file is processed, then this is noted in the output file, and the location of the new input file which
is created is recorded.

+--------------------------------------------------------------------+
|                                                                    |
|            Processing ANSYS Input File (Running CCL2MF)            |
|                                                                    |
+--------------------------------------------------------------------+
Created /home3/cfdsjw/tmp/comp/StaticMixer_001.ansys/ANSYS.mf

If the ANSYS Solver was started by CFX, then this is also noted in the output file.
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+--------------------------------------------------------------------+
|                                                                    |
|                       Starting ANSYS Solver                        |
|                                                                    |
+--------------------------------------------------------------------+

The host name and port number used by CFX-Solver to communicate to the ANSYS Solver is recorded. If you
started only CFX-Solver using the CFX-Solver Manager or the command line, then you will have provided these;
otherwise, the port number is determined automatically by the ANSYS Solver and communicated to CFX-Solver
by the start-up script.

Connecting to the following master process:
     Host Name   : sceptre
     Port Number :  34586

Information on what data will be exchanged on what boundaries is recorded so that you can check that all is as you
expect it to be.

+--------------------------------------------------------------------+
|    Boundary Condition Data Supplied by External Solver Coupling    |
+--------------------------------------------------------------------+
ANSYS Multi-field Solver : ANSYS
     CFX Boundary    : Interface
     CFX Variable    : Total Mesh Displacement
     ANSYS Interface : 1
     ANSYS Variable  : DISP

For steady-state runs only, each time a new coupling step begins, it is noted in the output file.

======================================================================
|                    COUPLING STEP =    1                            |
======================================================================

The output file also notes each time a new stagger iteration begins.

----------------------------------------------------------------------
|                 COUPLING/STAGGER ITERATION =    1                  |
----------------------------------------------------------------------

CFX-Solver Output File (Radiation Runs)

Convergence History
When the Thermal Radiation P1, Discrete Transfer, or Monte Carlo model has been selected,
a new variable, I-Radiation, is computed.

P1 Model

======================================================================
OUTER LOOP ITERATION =    1                     CPU SECONDS = 3.67E+01
----------------------------------------------------------------------
|       Equation       | Rate | RMS Res | Max Res |  Linear Solution |
+----------------------+------+---------+---------+------------------+
...
+----------------------+------+---------+---------+------------------+
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| I-Radiation          | 0.00 | 3.6E-08 | 4.6E-07 |  5.2  3.5E-02  OK|
+----------------------+------+---------+---------+------------------+

Discrete Transfer Model
I-Radiation data is output every nth iteration, where n is specified by an Iteration Interval parameter
(which can be set in Solver Control > Advanced Options > Thermal Radiation Control in CFX-Pre). The row
containing this data has its own column headings, which override the table headings just for the row. The column
headings are:

• #Its is the number of iterations required to obtain a converged radiation solution to within a specified tolerance.
This number is usually 1 unless there are reflective boundaries (emissivity less than 1). The default maximum
number of iterations and tolerances are 10, and 0.01 respectively. These values can be set in Solver Control >
Advanced Options > Thermal Radiation Control > Ray Tracing.

• Vol Chg is the maximum normalized change in volumetric absorbed radiation at convergence.

• Sur Chg is the maximum normalized change in surface absorbed radiation at convergence.

• %Lost is the percentage of ray traces lost due to tracking errors, or non-overlap boundaries at domain interfaces.
Values greater than 5% are an indication of a setup error.

• %Imbal is the percentage imbalance of radiative energy. This value should be 0 or a small value. Otherwise,
the results are not reliable.

+----------------------+------+---------+---------+------------------+
| I-Radiation          | #Its | Vol Chg | Sur Chg | %Lost  %Imbal    |
|   Gray               |    1 | 0.0E+00 | 0.0E+00 |  0.38    1.94    |
+----------------------+------+---------+---------+------------------+

This variable is also included in the Locations of Maximum Residuals and Peak Values of
Residuals tables that appear in the output file.

Monte Carlo Model
I-Radiation data is output every nth iteration, where n is specified by an Iteration Interval parameter
(which can be set in the Solver Control in CFX-Pre on the Advanced Options tab). The row containing this data
has its own column headings, which override the table headings just for the row. The column headings are:

• %SD Sur is the maximum normalized standard deviation of the irradiation flux at an element face on a boundary
(Irradiation Flux.Normalized Std Deviation).

• %SD Vol is the maximum normalized standard deviation of the radiation intensity within a finite element
(Radiation Intensity.Normalized Std Deviation).

• %Lost is the percentage of histories lost due to tracking errors or non-overlap boundaries at domain interfaces.
Values greater than 5% are indication of a setup error.

• %Imbal is the percentage imbalance of radiative energy. This value should be 0 or a small value. Otherwise,
the results are not reliable.

+----------------------+------+---------+---------+------------------+
| I-Radiation          |      | %SD Sur | %SD Vol | %Lost  %Imbal    |
|   Full Spectrum      |      | 4.6E+01 | 1.0E+02 |  0.00    0.00    |
+----------------------+------+---------+---------+------------------+

The Variable Range Information table has the output variable Radiation Intensity listed.

Summary Fluxes
• It should be noticed that for heat flux specified boundaries (adiabatic, for example) the specified heat flux can

verified by adding q rad to the boundary flow in the H-Energy flow summary.

(Eq. 3.3)= +q q qspec rad cond

• An I-Radiation section is included...

59

Release 12.0 - © 2009 ANSYS, Inc. All rights reserved.

Contains proprietary and confidential information of ANSYS, Inc. and its subsidiaries and affiliates.

CFX-Solver Output File (Radiation Runs)



 +--------------------------------------------------------------------+
 |                            I-Radiation                             |
 +--------------------------------------------------------------------+
 Boundary         : Airin                                  -1.5659E+03
 Boundary         : Combustor Default                      -3.5729E+02
 Boundary         : Downcomer Wall                         -5.1864E+02
 Boundary         : Fuelin                                 -1.0076E+03
 Boundary         : Outlet                                  1.6636E+01
 Domain           : Combustor                               5.2454E+03
 Domain Interface : Domain Interface 1                      5.3004E-01
 Domain Interface : Domain Interface 2                     -5.2638E+00
 Domain Interface : LowerGGI                               -1.9895E-01
 Domain Interface : Periodic                                1.1727E+01
 Domain Interface : UpperGGI                                1.6994E-01
                                                           -----------
 Domain Imbalance :                                         1.8195E+03
 Domain Imbalance, in %:                                     19.2758 %

When the Rosseland model is selected:

• No additional equation is solved. Hence, no thermal radiation flow summary will be available.

• The total heat flux is reported by the H-Energy flow summary.
(Eq. 3.4)+q qrad cond

• The CPU Requirements of Numerical Solution table reports the amount of CPU time spent due to the use of a
thermal radiation model.

CFX-Solver Results File
The CFX-Solver results file is generated by the CFX-Solver and contains a full description of the flow simulation
including:

• Volume mesh

• Flow solution

The CFX-Solver will generate a results file with a name based on the CFX-Solver input file. For example, running
the CFX-Solver using the input file named file.mdef in a clean working directory will generate a results file
named file_001.res. Given a clean working directory, the CFX-Solver will generate a results file with a name
based on the CFX-Solver input file. This results file contains the calculated solution values at each mesh node in
addition to the original information contained in the CFX-Solver input file. The integer index is incremented each
time subsequent simulations are executed in the working directory from the same CFX-Solver input file.

Note
CFX-Solver input files must not contain spaces when run with an associated ANSYS input file (inp).

In CFX, there are two additional types of files that may contain results: transient results and backup files. All backup
and transient files are placed in a subdirectory beneath the working directory that is named according to the results
file. For example, if the working directory contains the results file file_001.res, then backup and transient
results files are placed in the subdirectory named file_001. Backup and transient files all have names with
extension .bak and .trn, respectively. For details on how to create these results files in CFX-Pre, see Backup
Tab (p. 154) in the ANSYS CFX-Pre User's Guide and Transient Results Tab (p. 155) in the ANSYS CFX-Pre
User's Guide. For details on how to create backup results files while the run is executing, see Backup Run
Command (p. 98). Note that transient results files are only created during transient simulations.

The naming convention for each backup and transient results file is outlined as follows:

• If a file has a name including _full, then it is a full results file that contains a complete set of results and the
mesh (for example, 32_full.trn or 32_full.bak). These files can be loaded into CFD-Post directly if
required, and can be to restart a simulation.
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• If a file has a name that does not include _full, then it is not a full results file and may contain only selected
variables and no mesh (for example, 32.trn or 32.bak). Do not try to load one of these files directly into
CFD-Post; instead, load the ANSYS CFX results file (named file_001.res in the example described above)
and use the transient selector to switch between the final results and the results contained in these files.

• In general, transient and backup files contain results for the timestep corresponding to the integer prefix in the
file name. For example, 32_full.trn contains results from the 32nd timestep or outer iteration.

• For simulations involving couplers with external solvers (such as ANSYS Multi-field runs), files with a name
including _CS (such as 3_CS.trn or 7_CS_full.bak) may be present. These backup or transient files are
indexed by the coupling step rather than the CFX timestep or outer iteration. For example, 3_CS.trn corresponds
to the results at the end of the 3rd coupling step, not necessarily the 3rd timestep (although the two may be
coincident). These files are created in the same way as standard transient and backup files in CFX-Pre, but with
a frequency of Every Coupling Step or Coupling Step Interval.

CFD-Post
The CFX-Solver Results file may be used as input to CFD-Post in order to view the results and produce hard copy
output. It may also be used to produce files which are suitable for use with other post-processors by using the CFX
Export facility. For details, see File Export Utility (p. 131).

CFX-Solver
The CFX-Solver Results file may also be used as input to the CFX-Solver. The solution is used as the initial values
field from which to start a further analysis. For details, see Files Used by the CFX-Solver (p. 25).

CFX Radiation File
When using the Monte Carlo or Discrete Transfer radiation models, output information for radiation is written to
a results data file named results.rg[number].dat. This default file name will be used unless an error occurs
when attempting to open the file as a new file for write access, in which case a new name is created by altering the
last character (for example, results.rg2.dab), and a message with the new name is written to standard output.

A sample results.rg[number].dat file is shown below:

Zone         Volume    Temperature Refr. B=1  Emiss Co.  Scat Co.   ...
Room$1       1.309E-02  2.951E+02  1.000E+00  1.000E-02  0.000E+00  ...
Room$2       1.104E-02  2.951E+02  1.000E+00  1.000E-02  0.000E+00  ...
.
.
.
Room$1551    2.172E-03  2.951E+02  1.000E+00  1.000E-02  0.000E+00  ...
Room$1552    5.090E-04  2.951E+02  1.000E+00  1.000E-02  0.000E+00  ...

Total heating and cooling   4.130E+02   3.873E+02

Total path length    1.834E+00

Surface data

Zone         Surface               Area     Temperature Rough   Emiss    ...

Room$1       Room Default$1        6.774E-02  2.991E+02 1.00  1.000E+00  ...
Room$1       VentOut$2             3.232E-02  2.951E+02 1.00  1.000E+00  ...
Room$2       VentOut$12            2.532E-02  2.951E+02 1.00  1.000E+00  ...
.
.
.
Room$1551    Room Default$10633    2.166E-02  2.991E+02 1.00  1.000E+00 ...
Room$1552    Room Default$10634    1.376E-02  2.991E+02 1.00  1.000E+00 ...
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Total surface heating and cooling     2.211E+04   2.179E+04

Total non-thermal emission   3.464E+02

Net total absorbed power     3.624E+00    1.609E-06%

Total surface current and absorbed flux:-     9.818E-01   1.834E-02

PROCESS   1
***********

Number of histories      29423

 IWORK =     264568
 CPU time used     6.906

CFX Radiation File Contents
A CFX Radiation file contains the volume information, surface information, and some miscellaneous quantities
such as the net total heating, parameters which measure the work needed and the CPU time used. Finally, if
radiometers have been included, the results for each radiometer will be printed out. Note that the CPU time does
not include the time required to compute the radiometer value.

Volume Information
The volume information is given in a table with the following columns:

• Zone is the radiation element's internal name

• Volume is the volume of the radiation element

• Temperature is the temperature of the element

• Refr. B=1 is the refractive index of the element

• Emiss Co. is the emission coefficient (Units: per length)

• Scat Co. is the scattering opacity coefficient (Units: per length)

• Path len. is the average length when crossing a radiation element

• Heating is average volumetric absorbed radiation

• Emission is the volumetric emitted radiation

• (H-E)*VOL is the amount of radiative energy that shows up as a square term in the energy equation

• Error % is the standard deviation of the path length.

For non-grey models the emission and scattering coefficients are the spectrum integrated coefficients. In a grey
model the absorption coefficient equals the emission coefficient, in a non-grey model it can be obtained from the
intensity and the heating.

The next five columns contain the results. The seventh is the total path length of photons in the zone (Monte Carlo)
or the mean radiation intensity (discrete transfer). The eighth is the heating per unit volume, the ninth the cooling
per unit volume and the tenth the net total radiative heating rate for the zone. The last column gives the statistical
percentage error for Monte Carlo or the number of samples (rays traced through the zone) used for the heating
quadrature in the discrete transfer case.

Finally comes the total heating and cooling rates for the entire volume and, for Monte Carlo, the total mean path
length of photons in the geometry. Non-grey models will also have the band by band cooling.

Surface Information
In this output the first column is the zone name and the second the surface name. The third is the surface temperature,
the fourth the surface roughness and the fifth is the surface emissivity, spectrum integrated in the case of a non-grey
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model. Grey surfaces have an albedo equal to one minus the emissivity, in the non-grey case the integrated albedo
can be obtained from the surface heating and the incident flux (see ).

The next five columns contain the results. The sixth is the surface current (Monte Carlo) or average incident radiation
flux (discrete transfer). The seventh is the heating per unit area, the eighth the cooling per unit area and the ninth
the net total radiative heating. The last column is the statistical error (Monte Carlo) or the number of surface nodes
used for sampling (discrete transfer).

Finally comes the total heating and cooling rates for all the surfaces in the geometry. Non-grey models will also
show the band by band cooling.

After the above information, the overall net heating for the model is printed. This is a measure of how good the
calculation was since this figure should be zero. For a Monte Carlo calculation the total surface current and absorbed
photon flux is printed, these figures should sum to unity and can therefore be used as another measure of the accuracy
of the calculation. Next the number of histories computed (Monte Carlo) or the number of angular ordinates (Discrete
transfer) is printed. The last numbers are the work estimator and the CPU time. The work estimator is defined in
terms of units of work where a unit of work is the computational effort to trace a photon (ray) to the next event
(surface) and process that event (update the recursion relation) for Monte Carlo (Discrete transfer). If radiometers
have been calculated, the angular calibration table that is used will be printed; then for each radiometer location,
the following will be written: location, direction, temperature, flux.

CFX Partition File
The CFX partition file is generated by the CFX-Solver and used as input for a parallel run. The partition file is used
to store information about the partitioning of the mesh. The partition file can be used to view mesh partitions before
running the CFX-Solver. To do this, set the expert parameter write partition number=t before partitioning,
then combine the partition file with the CFX-Solver input file that was used to produce the partition file.

On UNIX systems, type:

cat filename.def filename_001.par > newfilename.res

On Windows systems, type:

copy /b filename.def + filename_001.par newfilename.res

This creates a results file that can be loaded in CFD-Post and contains the variable Real partition number.

Note
A partition file generated in ANSYS CFX 11.0 or earlier versions is not supported in ANSYS CFX 12.0.
If such a file is used in ANSYS CFX 12.0, then an error message is generated.

Additional Files for ANSYS Multi-field Runs
For an ANSYS Multi-field run, the CFX-Solver does not produce any extra files. However, if the ANSYS Solver
is launched by CFX, a new directory with a name of the form <Run Name>.ansys is created. This is used as
the ANSYS working directory and many files will be created here by ANSYS. In addition, the CFX processing of
the ANSYS files produces two extra files:

• Components File - this has a name of the form *.cm and can be found in the ANSYS working directory. It is
created to contain some region definitions for CFD-Post when it reads the ANSYS results files. For details, see
ANSYS Files (p. 74) in the ANSYS CFD-Post User's Guide.

• ANSYS Multi-field input file - this has a name of the form *.mf and can be found in the ANSYS working
directory. It is created whenever you ask for the provided ANSYS input file to be processed as part of defining
a run. It contains the ANSYS setup (solid physics) together with the multi-field commands that are constructed
from the ANSYS Multi-field settings in the CFX-Solver input file. For details, see Processing the ANSYS Input
File (p. 21).
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CFX Multi-Configuration Output File
Multi-configuration simulations involve the sequential and sometimes repeated execution of defined configurations.
The CFX-Solver generates a multi-configuration output file to summarize the global problem definition and execution
of configurations.

The CFX-Solver will generate a multi-configuration output file with a name based on the CFX-Solver Input file.
For example, running the CFX-Solver using the input file named file.mdef in a clean working directory will
generate the output file named file_001.out.

Header
The header is written at the start of every multi-configuration output file and contains information regarding the
command which started the simulation. This information is useful to check which files were used to start the run.

CFX Command Language for the Run
The CFX Command Language section describes the global (that is, simulation level) problem, which includes library
definitions (such as materials, expressions, etc…) and simulation control specifications (such as, configuration
definitions).

The section for the command file looks similar to the following:

+--------------------------------------------------------------------+
 |                                                                    |
 |                    CFX Command Language for Run                    |
 |                                                                    |
 +--------------------------------------------------------------------+

 LIBRARY:
   MATERIAL: Air at 25 C
     Material Description = Air at 25 C and 1 atm (dry)
     Material Group = Air Data, Constant Property Gases
     Option = Pure Substance
     Thermodynamic State = Gas
     PROPERTIES:
       Option = General Material
       EQUATION OF STATE:
         Density = 1.185 [kg m^-3]
         Molar Mass = 28.96 [kg kmol^-1]
         Option = Value
       END
       SPECIFIC HEAT CAPACITY:
         Option = Value
         Specific Heat Capacity = 1.0044E+03 [J kg^-1 K^-1]
         Specific Heat Type = Constant Pressure
       END
       REFERENCE STATE:
         Option = Specified Point
         Reference Pressure = 1 [atm]
         Reference Specific Enthalpy = 0. [J/kg]
         Reference Specific Entropy = 0. [J/kg/K]
         Reference Temperature = 25 [C]
       END
       DYNAMIC VISCOSITY:
         Dynamic Viscosity = 1.831E-05 [kg m^-1 s^-1]
         Option = Value
       END
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       THERMAL CONDUCTIVITY:
         Option = Value
         Thermal Conductivity = 2.61E-02 [W m^-1 K^-1]
       END
       ABSORPTION COEFFICIENT:
         Absorption Coefficient = 0.01 [m^-1]
         Option = Value
       END
       SCATTERING COEFFICIENT:
         Option = Value
         Scattering Coefficient = 0.0 [m^-1]
       END
       REFRACTIVE INDEX:
         Option = Value
         Refractive Index = 1.0 [m m^-1]
       END
       THERMAL EXPANSIVITY:
         Option = Value
         Thermal Expansivity = 0.003356 [K^-1]
       END
     END
   END
 END
 SIMULATION CONTROL:
   CONFIGURATION CONTROL:
     CONFIGURATION: Both Boxes Transient
       Flow Name = Copy of Both Domains
       ACTIVATION CONTROL:
         CONTROL CONDITION: After Top Box Steady State
           Configuration Name List = Top Box Steady Only
           Option = End of Configuration
         END
       END
       CONFIGURATION EXECUTION CONTROL:
         INITIAL VALUES SPECIFICATION:
           INITIAL VALUES CONTROL:
             Use Mesh From = Solver Input File
           END
           INITIAL VALUES: Initial Values 1
             Configuration Name = Top Box Steady Only
             Option = Configuration Results
           END
         END
         PARTITIONER STEP CONTROL:
           Multidomain Option = Independent Partitioning
           Runtime Priority = Standard
           EXECUTABLE SELECTION:
             Double Precision = No
           END
           PARTITIONING TYPE:
             MeTiS Type = k-way
             Option = MeTiS
             Partition Size Rule = Automatic
           END
         END
         SOLVER STEP CONTROL:
           Runtime Priority = Standard
           EXECUTABLE SELECTION:
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             Double Precision = On
           END
           PARALLEL ENVIRONMENT:
             Start Method = HP MPI Local Parallel
           END
         END
       END
     END
     CONFIGURATION: Top Box Steady Only
       Flow Name = Top Domain Steady State
       ACTIVATION CONTROL:
         CONTROL CONDITION: Cyclical Activation
           Configuration Name List = Both Boxes Transient
           Option = End of Configuration
         END
         CONTROL CONDITION: Start of Sim
           Option = Start of Simulation
         END
       END
       CONFIGURATION EXECUTION CONTROL:
         INITIAL VALUES SPECIFICATION:
           INITIAL VALUES CONTROL:
             Continue History From = Initial Values 1
             Use Mesh From = Solver Input File
           END
           INITIAL VALUES: Initial Values 1
             Configuration Name = Both Boxes Transient
             Option = Configuration Results
           END
         END
         PARTITIONER STEP CONTROL:
           Multidomain Option = Independent Partitioning
           Runtime Priority = Standard
           EXECUTABLE SELECTION:
             Double Precision = No
           END
           PARTITIONING TYPE:
             MeTiS Type = k-way
             Option = MeTiS
             Partition Size Rule = Automatic
           END
         END
         SOLVER STEP CONTROL:
           Runtime Priority = Standard
           EXECUTABLE SELECTION:
             Double Precision = On
           END
           MEMORY CONTROL:
             Memory Allocation Factor = 2
           END
           PARALLEL ENVIRONMENT:
             Start Method = HP MPI Local Parallel
           END
         END
       END
     END
   END
   TERMINATION CONTROL:
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     CONTROL CONDITION: Control Condition 1
       Configuration Name = Top Box Steady Only
       Maximum Number of Configuration Steps = 2
       Option = Maximum Number of Configuration Steps
     END
   END
   EXECUTION CONTROL:
     RUN DEFINITION:
       Solver Input File = mcfg1.mdef
     END
   END
 END

Simulation Execution Summary
The body of the multi-configuration output file summarizes the configuration execution sequence. The output is
divided into simulation and configuration steps.

At each simulation step, the simulation step counter is incremented and the activation conditions for all configurations
are evaluated. All active configurations are executed, but in no particular order. Once all active configurations have
finished their execution for the current simulation step, a new step begins. Subsequent simulation steps are executed
until any of the following occurs:

• there are no active configurations in a simulation step

• any simulation termination control conditions are satisfied

• the user stops the simulation while in progress by using Stop Current Run in the multi-configuration simulation
workspace, or by executing the cfx5stop command for the simulation run directory.

Additional details regarding configuration activation conditions and simulation termination controls are provided
in Configurations (p. 221) in ANSYS CFX-Pre User's Guide and Termination Control (p. 219) in ANSYS CFX-Pre
User's Guide, respectively.

A new configuration setup occurs, and the configuration step counter is incremented, each time a given configuration
is executed. Configuration step output includes the following information:

• the configuration step counter value

• the name of the configuration

• a listing of all configuration activation conditions that were satisfied

• the status at the end of the run (e.g. whether it succeeded or failed, or if the user stopped the run in progress)

• notes regarding any CFX Command Language (CCL) changes made using Edit Run in Progress during the
run.

A sample simulation execution summary is provided below. This summary presents the execution of three simulation
steps.

1. Only the Top Box Steady Only configuration was active and ran. This configuration was activated by the
Start of Sim condition defined in Simulation Control > Configuration > General Settings > Activation
Condition(s) and ran successfully.

2. Only the Both Boxes Transient configuration was active and ran. This configuration was activated by the
After Top Box Steady State condition, and ran successfully. During this run, changes to both LIBRARY and
FLOW CCL were made using Edit Run in Progress, and the included notes indicate how these changes will
be propagated to subsequent configuration runs.

3. On the Top Box Steady Only configuration was active and ran. Notice that the configuration step counter for
this run indicates that this is the second time this configuration has been run, and that the configuration was
activated by the Cyclical Activation condition. This run also completed successfully.

+--------------------------------------------------------------------+
 |                                                                    |
 |                        Simulation Execution                        |
 |                                                                    |
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 +--------------------------------------------------------------------+

 ======================================================================
 SIMULATION STEP =        1
 ----------------------------------------------------------------------
 |  Config.  | Configuration Name                                     |
 |   Step    | * Execution Details                                    |
 +-----------+--------------------------------------------------------+
 |        1  | Top Box Steady Only                                    |
 |           | * Act. by : Start of Sim                               |
 |           | * Status  : Succeeded                                  |
 +-----------+--------------------------------------------------------+

 ======================================================================
 SIMULATION STEP =        2
 ----------------------------------------------------------------------
 |  Config.  | Configuration Name                                     |
 |   Step    | * Execution Details                                    |
 +-----------+--------------------------------------------------------+
 |        1  | Both Boxes Transient                                   |
 |           | * Act. by : After Top Box Steady State                 |
 |           | * Status  : Succeeded                                  |
 |           | * NOTE    : The LIBRARY definition changed during this |
 |           |             run.  These changes will be applied to all |
 |           |             remaining configuration runs.              |
 |           | * NOTE    : The FLOW definition changed during this    |
 |           |             run.  These changes will be applied to all |
 |           |             remaining runs of this configuration.      |
 +-----------+--------------------------------------------------------+

 ======================================================================
 SIMULATION STEP =        3
 ----------------------------------------------------------------------
 |  Config.  | Configuration Name                                     |
 |   Step    | * Execution Details                                    |
 +-----------+--------------------------------------------------------+
 |        2  | Top Box Steady Only                                    |
 |           | * Act. by : Cyclical Activation                        |
 |           | * Status  : Succeeded                                  |
 +-----------+--------------------------------------------------------+

Simulation Termination Condition Summary
This section of the multi-configuration output file identifies the reason(s) for terminating the simulation. In the
example provided below, the user defined condition named Control Condition 1 was satisfied. For information
regarding how this condition was defined, refer to the discussion in Termination Control (p. 219) in ANSYS CFX-Pre
User's Guide.

======================================================================
 TERMINATION CONDITION SUMMARY
 ----------------------------------------------------------------------
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   * User: Control Condition 1

CFX Multi-Configuration Results File
The CFX-Solver will generate a results file with a name based on the CFX-Solver Input file. For example, running
the CFX-Solver using the input file named file.mdef in a clean working directory will generate the
multi-configuration results file named file_001.mres.

For multi-configuration simulations, the CFX-Solver Input and CFX-Solver Results files are very similar; both are
small files that contain only high level information about the simulation. In particular, the results file contains:

• global information about the simulation’s overall definition (such as Library CCL, configuration definitions
and sequencing, etc…)

• information about the configuration files (*.cfg which contain configuration specific settings and meshes)

• information about the CFX-Solver Results files (for details, see CFX-Solver Results File (p. 60)) generated for
each configuration step.

CFX-Solver Output and CFX-Solver Results files for each configuration (and configuration step) executed are
contained within the multi-configuration simulation’s run directory. For example, running the CFX-Solver using
the input file named file.mdef in a clean working directory will generate a file and directory structure similar
to the following:

• file_001.mres

• file_001.out

• file_001/

• Configuration1_001

• Configuration1_001.out

• Configuration1_001.res

• Configuration1_002.out

• Configuration1_002.res

• Configuration2_001

• Configuration2_001.out

• Configuration2_001.res

In this case, the directories file_001/Configuration1_001 and file_001/Configuration2_001
each contain the transient and backup files created during the respective configuration runs.
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Chapter 4. Residual Plotting
CFX-Solver calculates solutions to various equations. However, many cases result in residual values. This is due
to an equation not being fully satisfied. Of course, if the solution is exact, then the residual is zero. However, because
equation results only approximate physics, the results in a solution do not always match reality.

This chapter describes:

• Equation Residual (p. 71)

• Convergence Results and RMS (p. 71)

• Transient Residual Plotting (p. 72)

• Residual Plotting for ANSYS Multi-field Runs (p. 72)

Equation Residual
CFX-Solver calculates the solution to various equations, given the appropriate boundary conditions and models for
your particular CFD problem. For details, see Governing Equations (p. 17) in the ANSYS CFX-Solver Theory
Guide.

At any stage of a calculation, each equation will not be satisfied exactly, and the “residual” of an equation identifies
by how much the left-hand-side of the equation differs from the right-hand-side at any point in space. If the solution
is “exact,” then the residual is zero. Exact means that each of the relevant finite volume equations is satisfied
precisely. However, because these equations only model the physics approximately, this does not mean that the
solution exactly matches what happens in reality. If a solution is converging, residuals should decrease with successive
timesteps.

For example, assume that a given residual is 0.0005 kg s^-1. It is not obvious whether such a residual is large or
small. For instance, if the problem involves flows such that about 0.5 kg flows into (and out of) each mesh element
every second, then a residual of 0.0005 kg s^-1 means the equation is satisfied to within one part in a thousand,
which is likely a reasonable solution. However, if the problem involves flows of about 0.001 kg s^-1 into each mesh
element, then the residual is nearly as large as the flow, and the solution is not good.

To make the scales of the residuals meaningful, the solver normalizes values by dividing the appropriate scales at
each point. Solver Manager plots these normalized residuals using a log (base 10) scale.

The exact details of how the residuals are normalized are involved. For details, see Residual Normalization Procedure
(p. 254) in the ANSYS CFX-Solver Theory Guide. However, it is useful to know that residuals are divided by the
solution range. If linear solution diverges, this range may be very large and the normalized residuals would be
meaningless.

Convergence Results and RMS
A measure of how well the solution is converged can be obtained by plotting the residuals for each equation at the
end of each timestep. A reasonably converged solution requires a maximum residual level no higher than 5.0E-4.
Typically, the RMS (Root Mean Square) residual will be an order of magnitude lower than this.

The RMS residual is obtained by taking all of the residuals throughout the domain, squaring them, taking the mean,
and then taking the square root of the mean. This should present an idea of a typical magnitude of the residuals.

The Maximum Residuals and/or the RMS Residuals can be displayed in the convergence history plots by selecting
a specific monitor in Monitor Settings. For details, see Monitors Tab (p. 92).

The increase of a residual after any particular timestep does not imply that the solution is diverging. It is usual for
residuals to occasionally get larger, especially at the beginning of a run.

Note that even though convergence is good, there are still places where the residuals become larger temporarily.

It is also possible to have runs that do not converge at all, but simply deviate around the same values.

If the solution fails to converge, or convergence is happening only very slowly, some tips on how to improve the
convergence are available. For details, see Monitoring and Obtaining Convergence (p. 336) in the ANSYS CFX-Solver
Modeling Guide.
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Tip
If you want to obtain residual plots for old runs, select File > Monitor Finished Run and select a file
to view.

Transient Residual Plotting
When monitoring a transient run with the plotting of coefficient loop data selected, CFX-Solver Manager outputs
the monitor data for each coefficient loop (cloop) within each timestep. Each timestep is divided by the number of
inner coefficient loops. The values are produced for all variables in each cloop.

With the plotting selected, CFX-Solver Manager outputs the graph of monitor data, plotting a point for each
coefficient loop evenly across the space between the previous timestep and the current one, so that the final coefficient
loop datum is plotted on the X coordinate of the current timestep. For details, see Global Plot Settings Tab (p. 97).

Example: Assume that four coefficient loops were run for timestep 39. The first cloop value for a plotted variable
appears at position 38.25, the second at 38.5, the third at 38.75, and the fourth and final value is plotted at 39.

Residual Plotting for ANSYS Multi-field Runs
The CFX-Solver Manager can be used to launch an ANSYS Multi-field Run. For such a run, it is not sufficient to
consider only the convergence of CFX-Solver when deciding if results are converged: in addition, the convergence
of CFX-Solver and the convergence of the data exchanged between the CFX and ANSYS Solvers must also be
considered. The CFX-Solver Manager shows extra plots when monitoring an ANSYS Multi-field run to allow a
graphical display of these extra convergence quantities.

For details, refer to the following sections:

• Coupling CFX to an External Solver: ANSYS Multi-field Simulations (p. 295) in the ANSYS CFX-Solver
Modeling Guide

• ANSYS Field Solver Plots (p. 72)

• ANSYS Interface Loads Plots (p. 73)

For the extra plots to be displayed, the CFX-Solver Manager must have started CFX-Solver by selecting an MFX
Run Mode of either Start ANSYS and CFX or Start ANSYS only (see MultiField Tab (p. 9)), or
CFX-Solver must have been started from the command line with the cfx5solve command. It is not possible for
CFX-Solver Manager to display these plots if CFX-Solver was started by the CFX Launcher or from the command
line directly.

ANSYS Field Solver Plots
These plots are only produced when the solid physics is set to use large displacements or when other non-linear
analyses are performed. It shows convergence information from CFX-Solver. Full details of the quantities plotted
are described in the ANSYS user documentation, in “Newton-Raphson Procedure”.

In general, the CRIT quantities are the convergence criteria for each relevant variable, and the L2/L1/INF quantities
represent the L2 Norm/L1 Norm/Infinite Norm (respectively) of the relevant variable (which one is available for
each variable depends on the norm chosen using the CNVTOL command, and will default to L2 if the ANSYS input
file was produced by Simulation). The convergence criteria can change during a run as the default criteria is calculated
using a reference value for each quantity which is updated as the solution progresses. For convergence, the L2, L1,
or INF value should be below the criteria.

The x-axis of the plot is the cumulative iteration number for ANSYS, which does not correspond to timesteps,
coupling steps, or stagger iterations. Several ANSYS iterations will be performed for each timestep or coupling
step, depending on how quickly ANSYS converges. You will usually see a somewhat spiky plot, as each quantity
will be unconverged at the start of each time or coupling step, and then convergence will improve.

Several ANSYS Field Solver plots may be present, depending on the physics being solved within ANSYS.
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ANSYS Interface Loads Plots
These plots show the convergence for each quantity which is part of the data exchanged between the CFX and
ANSYS Solvers. There will always be two plots: ANSYS Interface Loads (Structural) and ANSYS Interface Loads
(Thermal). The structural plot contains convergence information on forces and displacements, and the thermal plot
contains information on temperature and heat flows/fluxes.

For each variable (each x-, y- and z-component of the load is a separate variable), the convergence norm for the
data transferred across the interface is given by:

(Eq. 4.1)
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where Φ represents the L2 norm of the transferred load, u old is the load component transferred at the last stagger
iteration, u new  is the load component transferred at this stagger iteration, and the sum is over all the individual load
component values transferred (at different points in space). Each quantity is considered to be converged when

<Φ Φmin, where Φmin is the convergence target for that quantity set in CFX-Pre (see Solver Controls, External
Coupling Tab (p. 300) in the ANSYS CFX-Solver Modeling Guide) or directly by the multi-field commands in the
ANSYS input file (MFCO command).

Note
The definition of the convergence norm in Equation 4.1 (p. 73) was changed in Release 12.0. To achieve
convergence in Release 12.0 (and later) that is similar to that achieved prior to Release 12.0, set the new
convergence target to be the square root of the convergence target used prior to Release 12.0. Furthermore,
the default value for the convergence target in Release 12.0 was changed to 0.01.

Convergence of each quantity transferred across the interface is reported as e, where:

(Eq. 4.2)=e Φ Φ
Φ

log( ⁄ )
log(10⁄ )

min

min

and this is the quantity plotted on the ANSYS Interface plots. This implies that each quantity has converged when
the reported convergence reaches a negative value. In general, the ANSYS Interface Loads (Structural) plot will
contain six lines, corresponding to three force components (FX, FY, and FZ) and three displacements (UX, UY,
and UZ), and the ANSYS Interface Loads (Thermal) plot will contain two lines (temperature and heat flow/flux).
However, if the simulation is effectively 2D (only one element across), then forces and displacements in the third
dimension are not exchanged and the corresponding lines will not be present.

The x-axis of the plot corresponds to the cumulative number of stagger iterations (coupling iterations) and there are
several of these for every timestep. A “spiky” plot is expected as the quantities will not be converged at the start of
a timestep.
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Chapter 5. Editing CFX-Solver Input Files
This chapter discusses the details of editing existing CFX-Solver input (or results) files to make minor changes to
a CFD model, without having to use CFX-Pre:

• Workflow Overview (p. 75)

• Command File Editor Overview (p. 75)

• Menus in the Command File Editor (p. 76)

• Command File Editor Rules (p. 78)

• Command File Editor Appearance (p. 79)

• Editing the Command Language (CCL) File (p. 79)

• Command Language File Rules (p. 79)

• RULES and VARIABLES Files (p. 80)

Workflow Overview
Modifications to CFX-Solver input (results) files can be performed using either the Command Editor dialog box
in CFX-Solver Manager or the cfx5cmds command from the command line, as shown in Figure 5.1, “CFX-Solver
Input File Modification Workflows” (p. 75).

Figure 5.1. CFX-Solver Input File Modification Workflows

Command File Editor Overview
The simplest method of making changes to an existing CFX-Solver input file is to use the Command File editor.
The Command File editor provides a tree-structured representation of a CFX-Solver input file. This allows
modification of parameter settings and the addition of new parameters to existing CFX-Solver input files as required.
Edit CFX-Solver File Command (p. 101)

The Command File editor can be invoked in multiple ways and each way provides a different function:

• Tools > Edit CFX-Solver File

Edit CFX-Solver File Command (p. 101)

• Tools > Edit Run In Progress

For details, see Edit Run In Progress Command (p. 105).
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• Tools > Edit Current Results File

For details, see Edit Current Results File Command (p. 105).

Menus in the Command File Editor
The Command File editor has three menus:

• File Menu (p. 76)

• Edit Menu (p. 76)

• Help Menu (p. 78)

File Menu
The File menu contains:

• Save Command (p. 76)

• Validate Command (p. 76)

• Exit Command (p. 76)

Save Command
Saves the file and returns the CFX Command Language file information to the CFX-Solver input file.

Validate Command
Checks the format of the CFX Command Language file for necessary content and reports any errors. Validation of
units is performed each time a parameter is edited.

Exit Command
Closes the Command File editor. A prompt is displayed if there are unsaved changes.

Edit Menu
The Edit menu contains:

• Add Parameter Command (p. 76)

• Edit Parameter Command (p. 77)

• Delete Parameter Command (p. 77)

• Add Expert Parameter Section Command (p. 78)

• Find Command (p. 78)

• Find Next Command (p. 78)

Add Parameter Command
Some categories (e.g., the FLOW > SOLVER CONTROL > CONVERGENCE CONTROL section) allow additional
parameters that are not shown by default.

The Add Parameter option is used to:

• Add a new parameter to a category when the category is selected.

• Add an expert parameter to the CFX Command Language file after the Expert Parameter Section has been
created. For details, see Add Expert Parameter Section Command (p. 78).

If a parameter can be added to a section, a dialog box displays with a drop-down list of available parameters. Ensure
that parameters being added make sense and use correct units as required.

1. Select a parameter that allows additional parameters to be added.

2. Select Edit > Add Parameter.
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3. In the drop down list select a parameter.

4. Under Value, enter specific information about the parameter.

For details, see Command File Editor Rules (p. 78).

5. Click OK.

Note that it is also possible to add a parameter that is not in the drop-down list by typing its name into the top field
and then entering a value. The CFX-Solver will subsequently fail if either the supplied name or value is inappropriate.

Edit Parameter Command
The Edit Parameter option allows changes to an existing expert parameter in the CFX Command Language file.

When the Command File editor is first opened, the Root is displayed. It contains three categories: LIBRARY,
EXECUTION CONTROL (seen only when editing version 5.5 or later .res files) and FLOW.

In .def files, only two categories are displayed: LIBRARY and FLOW.

Note
Parameters that can be edited display the value in green. Other parameters cannot be changed from the
Command File editor.

Expanding categories
Additional information about a category can be seen by expanding it.

• Click the plus/minus boxes to expand or reduce the category selection.

Tip
Right-click to expand the category and all of its subcategories.

Editing entries

Important
Editing the CFX Command Language file changes the CFX-Solver input file, but does not make changes
to the CFX-Pre case file. In other words, changes made by the Command File editor are used by the
CFX-Solver but do not appear when the case file is reopened in CFX-Pre.

1. Expand the Name of the entry until a Value in green or orange is displayed.

Editable values display in green or in orange.

2. Double-click the value to edit.

The Edit Parameter dialog box is displayed.

3. Edit the value as required.

In some parameters this may require edits to text and in others a selection in a drop-down list box. For details,
see Command File Editor Rules (p. 78).

4. Click OK.

5. When all modifications have been made, save the file.

Changes made to the CFX Command Language file are written in the CFX-Solver input file.

Delete Parameter Command
The Delete Parameter option is used to remove an expert parameter from the CFX Command Language file.
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Add Expert Parameter Section Command
The Add Expert Parameter Section provides access to the expert parameters in CFX. An expert parameter section
must be created before adding expert parameters to the CFX Command Language file.

Before adding any expert parameters to the CFX Command Language file, first add an expert parameters section
to the tree structure displayed in the Command File editor.

1. Select Edit > Add Expert Parameter Section.

The EXPERT PARAMETERS: section is added to the bottom of the FLOW branch of the tree.

2. Expand FLOW.

3. Select EXPERT PARAMETERS.

4. Add parameters as required.

For details, see Add Parameter Command (p. 76).

Once the value for an expert parameter has been set, it can be edited as needed. For details, see Edit Parameter
Command (p. 77).

Find Command
Allows searching of the CFX Command Language file for a keyword or keywords.

Find Next Command
Finds the next occurrence of the keyword or keywords.

Help Menu
The Help menu contains:

• Help On CFX-5 Definition File Editor Command (p. 78)

• Help On Expert Parameters Command (p. 78)

On CFX-5 Definition File Editor Command
The help associated with the Command File editor is launched.

On Expert Parameters Command
The CFX-Solver Expert Control Parameters help is launched.

Command File Editor Rules
If unsure as to an appropriate value to enter, select Help > On Expert Parameters from the main Command File
editor window to view a description and valid values for the parameters.

The following rules apply when using the Command File editor:

• Everything is case-sensitive. Use care to distinguish upper case letters from lower case letters.

• Parameter names must start with a letter (not a number or symbol). Subsequent characters can be letters, numbers,
spaces or tabs.

• Spaces appearing before or after a name are not considered to be part of the name.

• Multiple spaces and tabs appearing inside a name are treated as a single space.

• For parameters requiring a logical value, enter T or t for true, and F or f for false. For many parameters requiring
an integer value only a few integer values are valid.

These rules should suffice for simple editing operations. To perform more complicated editing operations, consider
editing the command file directly. For details, see Editing the Command Language (CCL) File (p. 79).

Release 12.0 - © 2009 ANSYS, Inc. All rights reserved.

78 Contains proprietary and confidential information of ANSYS, Inc. and its subsidiaries and affiliates.

Help Menu



Command File Editor Appearance
Some of the file information under the Name and Value headings may be truncated when the tree structure is
expanded. The amount of space allocated to the name or the value can be configured.

1. Position the mouse cursor between the Name and Value headings.

That is, place the cursor over the line that separates the two headings. The cursor appears as a double line with
an arrow to the left and the right.

2. Click and drag to expand or contract the width of the column.

For lengthy lines (such as those that contain lists), double-click on the line. This opens the line in a configurable
dialog box for viewing and editing.

Editing the Command Language (CCL) File
In some circumstances, more significant changes may be required to the CFX-Solver input file than the Command
File editor allows. CFX allows the use of a text editor to edit the CFX Command Language file.

Note
This feature is for expert users only. Extreme care must be taken when editing a CFX Command Language
file. Changes made to the CFX Command Language file are reflected in the CFX-Solver input file and
may have negative effects on the model. It is strongly advised that original files are backed up before
edits are made to them.

To generate the CFX Command Language file, use the cfx5cmds command in a UNIX terminal or a Windows
command line. Ensure this is set up correctly to run CFX commands. For details, see Command Line (p. 3) in the
ANSYS CFX Reference Guide.

Command Language File Rules
The following rules apply when using a text editor to change a CFX Command Language file:

• Changing the solution units outside of CFX-Pre is not recommended. For details, see Solution Units (p. 143)
in the ANSYS CFX-Pre User's Guide.

• Everything apart from expert parameter names is case-sensitive. Use care to distinguish upper case letters from
lowercase letters. It is recommended that lower case letters are used for expert parameter names to match those
shown in the Command File Editors expert parameters section.

• The name of any variable must start with a letter (not a number or symbol). Subsequent characters can be letters,
numbers, spaces, or tabs.

• Spaces appearing before or after a name are not considered to be part of the name.

• Multiple spaces and tabs appearing inside a name are treated as a single space.

• Nothing is sensitive to indentation. Indentation is used only to make the appearance of the text clearer.

• The comment character is the pound, or number sign (#). Anything appearing to the right of this character is
ignored. For instance:

PARAMETER = 3.2   # This text is ignored

• The line continuation character is the backslash (\). To break a long line of text into two or more lines, insert
a backslash character at the end of the first line. For instance, both of the following lines are handled the same
way:

NAME = default temperature used in the first simulation
NAME = default temperature used in the first simulation
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• A line containing CFX Expression Language must be no more than 256 characters long. Other lines can be of
any length.

The RULES and VARIABLES files can be a useful guide when editing a CCL file. For details, see RULES and
VARIABLES Files (p. 80).

Some objects in the CCL file can be defined with a default value and then overridden by local values. For example,
the SOLVER CONTROL section of a CCL file may look like:

SOLVER CONTROL :
 CONVERGENCE CONTROL :
  Maximum Number of Iterations = 100
  Timescale Control = Physical Timescale
  Physical Timescale = 5.E-1 [s]
 END
 EQUATION CLASS : momentum
  CONVERGENCE CONTROL :
   Timescale Control = Physical Timescale
   Physical Timescale = 1.E-1 [s]
  END
 END
 CONVERGENCE CRITERIA :
  Residual Type = RMS
  Residual Target = 1.E-4
 END
 ADVECTION SCHEME :
  Option = Upwind
  END
 DYNAMIC MODEL CONTROL :
  Global Dynamic Model Control = No
 END
END

The first CONVERGENCE CONTROL object defines values that apply to all equation classes. The physical time
scale is then locally overridden for the momentum equation class. Other objects, including the ADVECTION
SCHEME, can be locally overridden in the same way. The order in which objects appear is not important, so an
object can be assigned an override before its default has been set. Only some parameters may be set to a different
local value; for example, it does not make sense to set the Maximum Number of Iterations locally.

RULES and VARIABLES Files
The RULES and VARIABLES files can be useful when editing a CCL file. They provide information on valid
options, variables, and dependencies. Both files are located in <CFXROOT>/etc/ and can be viewed in any text
editor.

Note
In some cases, the RULES and VARIABLES files contain information about variables, parameters,
models and options that are not yet fully supported in the CFX-Solver. Use caution with features that
are not documented elsewhere as these may cause the CFX-Solver to fail or produce invalid results.

VARIABLES File
The VARIABLES file lists all the variables available in the CFX-Solver. Information provided for each variable
appears similar to the following:

VARIABLE: vel
 Option = Definition
 MMS Name  = VEL
 Long Name = Velocity
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 Tensor Type = VECTOR
 Quantity = Velocity
 Status = P
 User Level = 1
 Output to Jobfile = No
 Output to Postprocessor = Yes
 Component Short Names = \
  u, \
  v, \
  w
 Component Long Names = \
  Velocity u, \
  Velocity v, \
  Velocity w
 Component MMS Names = \
  VEL-1, \
  VEL-2, \
  VEL-3
 General Availability = ADAPTION, RESULTS, CEL
 Variable Description = Velocity
 Variable Scope = PHASE
END

The following information can be identified:

• The name appearing immediately after VARIABLE: (in this case vel) is the CFX-Solver name or short name
for the variable.

• For scalar quantities (Tensor Type = SCALAR), the name appearing after VARIABLE: is the name that
must be used in any CEL expressions. The MMS Name and Long Name are not valid names to use for this
purpose.

• For vector and tensor quantities (Tensor Type = VECTOR and Tensor Type = SYMTEN2), the
Component Short Names (u, v and w in this case) are names that must be used in any CEL expressions.

• The User Level setting controls when the variable is seen. Variables of User Level = 1 will appear in
drop-down variable selection menus in CFD-Post. Variables with User Level = 2 or User Level = 3
will only appear in the full list of variables.

• The Output to Postprocessor setting controls if the variable is written to the results file for use in
CFD-Post. A variable must be involved in the simulation before is has the potential to be written out.

• The General Availability field determines when a variable can be used. Only variables whose
General Availability includes CEL can be used in CEL expressions.

• The names of all VARIABLE, EQUATION DEFINITION and FUNCTION objects are reserved names. These
names should not be used as the name for any CEL expressions, Additional Variables, user routines, or user
functions, etc.

The end of the VARIABLES file contains a section listing call back definitions. Using call backs which are not
documented, or using them on locations other than those documented will produce invalid results. For details, see
Quantitative Function List (p. 142) in the ANSYS CFX Reference Guide.

RULES File
The RULES file contains information about which models and parameters are valid options. This includes
SINGLETON, OBJECT and PARAMETER items.

RULES
The first items in the RULES file list the top level SINGLETON objects. All other items are children of these optional
top level objects.

• RULES: This could be used to modify the list of allowed options. This should always be done locally.
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• LIBRARY: Includes libraries for materials, reactions, CEL and user routines. Add new materials and reactions
using a local library.

• FLOW: Contains the current problem definition.

• USER: Where user parameters may be stored for later retrieval through User Fortran.

• COMMAND FILE: Contains the command file version number.

• EXECUTION CONTROL: Contains information about the parallel setup and other settings controlled in the
CFX-Solver Manager.

Details about models that are not available can also be found through the user interface. For example, the
SINGLETON: ADVECTION SCHEME item includes the QUICK scheme.

SINGLETON
A SINGLETON object is permitted to appear once as the child of a parent object. For this reason SINGLETON
objects do not have names associated with them, for example:

LIBRARY :
 CEL :
  EXPRESSIONS :

Each of these three items is a SINGLETON object. The LIBRARY SINGLETON may only have one CEL
SINGLETON, and the CEL SINGLETON may only have one EXPRESSIONS SINGLETON. Parameters and child
definitions do not need to be grouped for a SINGLETON into a single location; this is done automatically by the
CFX-Solver. For example, the following is valid:

LIBRARY :
 CEL :
  EXPRESSIONS :
   myexp1 = 1 [ m ]
  END
 END
END
...
LIBRARY :
 CEL :
  EXPRESSIONS :
   myexp2 = 2 [ m ]
  END
 END
END

OBJECT
An OBJECT is similar to a SINGLETON except that more than one can appear as the child of a parent object. For
this reason each OBJECT must have a name, for example:

FLOW :
 DOMAIN : domain1
  ...
 END
 DOMAIN : domain2
  ...
 END
END

Two OBJECT items of type DOMAIN have been defined with names domain1 and domain2. These are children
of the FLOW SINGLETON.
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PARAMETER
A PARAMETER consists of a name, followed by the “=” character, followed by a value. Many parameters in the
RULES file cannot be set in a CCL file and therefore cannot be altered.

• The Parameter Type tells you the type of values the parameter is allowed to take. It could be Real, Real
List, Integer, Integer List, String or String List. When a list is valid, items should be comma
separated.

• Some parameters contain an Allowed String List. This contains valid strings that can be used for that
parameter.

• Each PARAMETER that you can set has a Dependency List which lists the variables the PARAMETER can
depend upon. XYZ refers to the x, y and z coordinates. XYZT refers to the x, y and z coordinates and time. The
CCL file can be edited based on the dependencies listed here.

• If a PARAMETER contains the item Dynamic Reread Item = Yes, then it can be modified while a run
is in progress. Some SINGLETON objects also contain this item. For details, see Edit Run In Progress Command
(p. 105).

83

Release 12.0 - © 2009 ANSYS, Inc. All rights reserved.

Contains proprietary and confidential information of ANSYS, Inc. and its subsidiaries and affiliates.

RULES File



Release 12.0 - © 2009 ANSYS, Inc. All rights reserved.

Contains proprietary and confidential information of ANSYS, Inc. and its subsidiaries and affiliates.



Chapter 6. File Menu
This chapter describes the commands available from the CFX-Solver File menu:

Define Run Command
Running the CFX-Solver involves passing it the geometry, models, boundary conditions, and start-up information
that it needs to calculate a solution to your CFD problem. The Define Run form is where you specify the information
which is passed to the CFX-Solver. Some runs of the CFX-Solver require you to specify only the name of the
CFX-Solver input file; others also require the name of an initial values file. Extra tabs become available when Show
Advanced Controls is selected. For details, see The Define Run Dialog Box (p. 7).

Monitor Run in Progress Command
Used when CFX-Solver Manager has been closed and a run currently underway in the Solver needs to be displayed.

1. Select File > Monitor Run in Progress.

The Select a Run Directory (.dir) dialog box is displayed.

2. Browse to the directory containing the current run.

3. Select the current run.

4. Click OK.

Data up to the current timestep is loaded.

Monitor Finished Run Command
Used to view the residual plots of a finished run.

1. Select File > Monitor Finished Run.

The Monitor Finished Run dialog box is displayed.

2. Under File Type, select the type of files to view.

3. Browse to the directory containing the finished run.

4. Select the run to view.

If required, select a different file.

5. Click OK.

The data is loaded.

Close Command
Closes all windows related to the current run. Any other runs that were open are not affected, and the last open run
prior to the current run is displayed. If the Solver was in progress on the current run, it continues to operate in the
background. The run can be re-monitored; see Monitor Run in Progress Command (p. 85) or Monitor Finished Run
Command (p. 85), as appropriate.

Quit Command
Exits CFX-Solver Manager. Closing CFX-Solver Manager does not stop CFX-Solver jobs that are currently running.
CFX-Solver Manager can be re-opened to take control of these jobs again simply by opening CFX-Solver Manager
and selecting Monitor Run in Progress. For details, see Monitor Run in Progress Command (p. 85).

1. Select File > Quit.

2. Click Quit.
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Chapter 7. Setting CFX-Solver Manager
Options

The Edit > Options dialog enables you to set various general preferences. Settings are retained per user.

1. Select Edit > Options.

The Options dialog box appears.

2. Set options as required. If desired, select CFX Defaults to use all of the default settings.

If you are using ANSYS Workbench and want to use its default settings, select Workbench Defaults.

For descriptions of the available options, see:

• CFX-Solver Manager Options (p. 87)

• Common Options (p. 88)

3. Click OK.

CFX-Solver Manager Options
When the Options dialog box appears, CFX-Solver Manager options can be set under SolverManager.

Default Layout Mode
You may specify a default layout mode to specify what mode monitors are presented when starting a new run. Select
from the following:

• Multiple Windows

• Tabbed

Show Original Variable Names
If selected, the variable names will be shown with their original names. By default, this option is not selected and
is generally left at that default setting.

Don't write Backup file on Edit Run In Progress
By default, a backup file is written. For details, see Edit Run In Progress Command (p. 105).

Default License Mode
The Default License Mode setting is applicable when using CFX in ANSYS Workbench when a license key
supporting preprocessing, postprocessing, and solving is available. The options are:

• Current WB License

CFX-Solver uses the license selected by ANSYS Workbench. The latter selects licenses according to the settings
found under Tools > Options > Licensing > License Management. For details, see the ANSYS Workbench
documentation.

When running the CFX-Solver using this method, the license key capable of preprocessing, postprocessing, and
solving is used for the solver, and becomes unavailable to provide access to meshing, pre-processing, or
post-processing during that time.

• Separate License

CFX-Solver checks out a separate license, leaving the ANSYS Workbench selected license key available so
that you can use the latter to do other work while the solver is running.
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Save Workspace to Results File
By default, this option is selected, enabling the CFX-Solver Manager workspace state to be saved automatically
into the results file for the run. This means that if you subsequently re-monitor the run, any custom plots or plot
settings that you used for the original run will be preserved.

Note that with this option selected, opening any ANSYS CFX results file in Release 11.0, or later, of the CFX-Solver
Manager will modify the results file in such a way that it becomes incompatible with Release 10.0, or earlier, of
the CFX-Solver Manager. In general, compatibility cannot be guaranteed whenever an ANSYS CFX results file
from a particular release is opened in a CFX-Solver Manager from a later release. The results file will still be
functional for the CFX-Solver from the earlier release, but you will not be able to monitor such a run using the
CFX-Solver Manager from the earlier release. You should, therefore, disable Save Workspace to Results File
when switching back and forth between different releases of the CFX-Solver Manager. You should also disable this
option if you want to retain an unmodified results file.

Monitor
Multiple options exist that can be monitored as required.

• The visibility for each type of residual can be toggled on or off. Settings take effect the next time a run is started,
or the next time a results file is viewed.

• If visibility is disabled for all residuals in a plot monitor, the monitor will not be created.

• For details, see Customizing CFX-Solver Manager (p. 5).

Monitor options are available to specify global residual display preferences. Settings chosen on the form apply for
all future solver runs and override default display settings for monitors. Monitors can still be created using the
Workspace menu. For details, see New Monitor Command (p. 97).

Common Options
Auto Save

Select the time between automatic saves.

To turn off automatic saves, set Auto Save to Never.

Note
This option affects more than one CFX product.

Temporary directory

To set a temporary directory, click Browse  to find a convenient directory where the autosave feature will

save state files.

Appearance
The appearance of the GUI can be controlled from the Appearance options. The default GUI style will be set to
that of your machine. For example, on Windows, the GUI has a Windows look to it. If, for example, a Motif
appearance to the GUI is preferred, select to use this instead of the Windows style.

1. Under GUI Style, select the user interface style to use.

2. For Font and Formatted Font, specify the fonts to use in the application.

Note
It is important not to set the font size too high (over 24 pt. is not recommended) or the dialog boxes
may become difficult to read. Setting the font size too small may cause some portions of the text
to not be visible on monitors set at low resolutions. It is also important not to set the font to a family
such as Webdings, Wingdings, Symbols, or similar type faces, or the dialog boxes become illegible.
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Note
Formatted Font affects only the font used in CFX-Solver Manager for the out file display.

Viewer Setup
1. Select Double Buffering to use two color buffers for improved visualization.

For details, see Double Buffering (p. 89).

2. Select or clear Unlimited Zoom.

For details, see Unlimited Zoom (p. 89).

Double Buffering
Double Buffering is a feature supported by most OpenGL implementations. It provides two complete color buffers
that swap between each other to animate graphics smoothly. If your implementation of OpenGL does not support
double buffering, you can clear this check box.

Unlimited Zoom
By default, zoom is restricted to prevent graphics problems related to depth sorting. Selecting Unlimited Zoom
allows an unrestricted zoom.

Mouse Mapping
The mouse-mapping options allow you to assign viewer actions to mouse clicks and keyboard/mouse combinations.
These options are available when running in standalone mode. To adjust or view the mouse mapping options, select
Edit > Options, then Viewer Setup > Mouse Mapping. For details, see Mouse Button Mapping (p. 49).

Units
1. Under System, select the unit system to use. Unit systems are sets of quantity types for mass, length, time, and

so on.

The options under System include SI, CGS, English Engineering, British Technical, US
Customary, US Engineering, or Custom. Only Custom enables you to redefine a quantity type (for
example, to use inches for the dimensions in a file that otherwise used SI units).

The most common quantity types appear on the main Options dialog; to see all quantity types, click More
Units.

2. Select or clear Always convert units to Preferred Units.

If Always convert units to Preferred Units is selected, the units of entered quantities are immediately converted
to those set on this dialog.

For example, if you have set Velocity to [m s^-1] on this dialog to make that the preferred velocity unit,
and elsewhere you enter 20 [mile hr^-1] for a velocity quantity, the entered value is immediately
converted and displayed as 8.94078 [m s^-1].
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Chapter 8. Workspace Menu
The Workspace menu controls layout, plots, and text windows, which are visible in the viewer. With the Workspace
menu you can:

• Back up, restart, or stop the current run

• Change the properties for the current workspace

• Create new monitors for simulations

• Switch between multiple windows and tabbed GUI layout (using the Toggle Layout menu option)

• Switch between viewing RMS and Maximum residual values at any time during or after a run.

This chapter describes:

• Workspace Properties Command (p. 91)

• New Monitor Command (p. 97)

• Stop Current Run Command (p. 97)

• Restart Current Run Command (p. 98)

• Backup Run Command (p. 98)

• Arrange Command (p. 98)

• Toggle Layout Type Command (p. 98)

• Load Layout Command (p. 99)

• Save Layout Command (p. 99)

• View RMS Residuals Command (p. 100)

• View MAX Residuals Command (p. 100)

• Reset to Default Workspace Command (p. 100)

• Close Command (p. 100)

Workspace Properties Command
By default, appropriate monitors are automatically created by CFX-Solver Manager for the particular type of
simulation you are running. The type and/or number of plots that appear can be changed by using Workspace
Properties. Not all of the default plots relevant to the solution are displayed: you can choose them in the Monitors
menu. For details, see Monitors Menu (p. 107).

When loading a results file or starting a solver run, CFX-Solver Manager checks the type of run before creating the
correct plots. For example, a volume fraction plot will be created for multiphase simulations.

Workspace properties are controlled from:

• General Settings Tab (p. 91)

• Monitors Tab (p. 92)

• Global Plot Settings Tab (p. 97)

General Settings Tab
This tab displays the following workspace information that cannot be edited.

• Out File displays the path and name of the CFX output file for the run displayed in CFX-Solver Manager.

• Directory displays the path and name of the directory for the run displayed in CFX-Solver Manager.

The locations can be set in the Working Directory option when defining the run. For additional information, see
Define Run Command (p. 85) and Run Definition Tab (p. 8). Information on selecting different runs is available
in Workspace Selector (p. 2).
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Monitors Tab
The Monitors tab allow customization of the CFX-Solver Manager viewer area and text windows. The following
types of monitors are available:

• Plot Monitor (p. 92)

• Residual Monitor (p. 92)

• Text Monitor (p. 92)

Plot Monitor
Plot monitors show the values of expressions versus timestep.

Residual Monitor
Residual monitors show the values of residuals for equation variables versus timestep.

Text Monitor
Text monitors show the contents of text files that are updated as the run proceeds.

Filter Selector
The Filter selector is a drop down list that shows the monitor types available in CFX-Solver Manager. Use this
selector to control the monitors displayed under the Monitors tab by selecting All, Plot Monitor, Residual
Monitor or Text Monitor. The All setting displays a full list of available monitors.

Creating Monitors
Monitors can be created within Workspace Properties. However, they can also be created directly from the
Workspace menu by selecting New Monitor.

1. Select Workspace > Workspace Properties.

2. Select Monitors.

3. Click New .

The New Monitor dialog box is displayed.

4. Under Name, type the name of the new monitor.

5. Under Type, select Plot Monitor, Residual Monitor or Text Monitor.

6. Click OK.

The Monitor Properties dialog box is displayed.

7. Configure the monitor as required.

• General Settings Tab (p. 93)

• Range Settings Tab (p. 93)

• Plot Lines Tab (p. 94)

Modifying Monitors
1. Select Workspace > Workspace Properties.

2. Select Monitors.

3. Select the monitor to modify.

4. Click Edit .

The Monitor Properties dialog box is displayed.
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5. Configure the monitor as required.

• General Settings Tab (p. 93)

• Range Settings Tab (p. 93)

• Plot Lines Tab (p. 94)

Deleting Monitors
1. Select Workspace > Workspace Properties.

2. Select Monitors.

3. Select the monitor to delete.

4. Click Delete .

Monitor Properties
Monitor properties differ depending on the type of monitor. Up to three tabs are available to configure monitor
properties.

• General Settings Tab (p. 93)

• Range Settings Tab (p. 93)

• Plot Lines Tab (p. 94)

General Settings Tab
1. Under Window Label, type the name to display for the monitor.

2. If working with a text monitor:

1. Under Text File Name, click Browse  and select a file containing the definition for the text monitor.

This can be any .out file.

2. Select or clear Disable this Monitor.

If selected, the monitor is disabled.

3. If working with a plot monitor or a residual monitor:

1. Under Background Color, click Color Selector  and set the background color.

2. Select or clear Display Legend.

If selected, the legend is displayed in the monitor.

3. Under Grid Mode select Both, X, Y or None.

This determines if grid lines appear along the X or Y axis, on both or not at all.

4. Under Grid Color, click Color Selector  and set the grid color.

4. Select or clear Visibility.

If selected, the monitor is displayed.

Range Settings Tab
1. Under Timestep Range Option, select Display All, Most Recent, Fixed or This Run Only.

• Display All displays values for every iteration. If viewing a restarted run, results from the previous
run are also visible.

• Most Recent displays the current iteration and a number of previous iterations.
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• Fixed displays a beginning and end iteration which is always displayed, regardless of the current iteration
number.

• This Run Only displays the range for the current run. If the run is a restart, previous runs are not
included in the range.

2. Under Variable Axis, select or clear Use Logarithmic Scale.

If selected, Set Manual Scale (Log) is automatically selected.

3. Under Set Manual Scale (Log) or Set Manual Scale (Linear) set the Upper Bound and Lower Bound values
for the variable axis.

4. Complete the timestep configuration based on the Timestep Range Option selected.

• Most Recent requires a value for Timestep Window Size.

• Fixed requires values for First Timestep and Last Timestep.

Plot Lines Tab
Variables which are available to plot can come from a variety of sources. Select the source by setting Variable Set
appropriately. Available settings are:

• CFX Solver: This option will be available for all CFX runs, and allows the specification of all variables relating
to the CFX run.

• ANSYS Field Solver: This option is only available if an ANSYS Multi-field Run is being performed with
ANSYS running a non-linear simulation, and allows the selection of ANSYS convergence variables.

• ANSYS Interface Loads: This option is only available if an ANSYS Multi-field Run is being performed, and
allows the selection of the variables relating to the data exchanged between the ANSYS and CFX Solvers.

Plot lines can be displayed as required:

1. Expand a plot line variable by clicking + next to it.

Categories are displayed.

2. Expand a category by clicking + next to it.

3. Select or clear specific plot line variables.

4. If working with a Residual Monitor, under Residual Mode, select RMS or MAX.

Residual Mode acts as a visibility filter for variables of Residual type selected by default. If a variable of type
Residual is not selected by default it is plotted even if its type does not match the Residual Mode setting.

5. Click Apply.

CFX Variables
While not all variable types are available at any given time, the following is a complete list of all variable types
available for monitoring a CFX run.

• ACCUMULATED TIMESTEP (p. 95)

• BALANCES (p. 95)

• FLOW (p. 95)

• FORCE (p. 95)

• NEG ACCUMULATION (p. 95)

• RESIDUAL (p. 95)

• SOURCE (p. 95)

• TIMESTEP (p. 95)

• USER (p. 95)

Further details on the output of the solver are available. For details, see CFX-Solver Files (p. 25).
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ACCUMULATED TIMESTEP
The accumulated timestep values are plotted.

BALANCES
These are the normalized sum of the flows (that is, the % imbalance) for a given equation on a particular domain.
The absolute flow is normalized by the maximum flow, calculated by looking at flows on all domains for that
particular equation.

FLOW
The flows listed in the CFX-Solver Manager are the absolute amounts of a variable transported through a boundary
condition. For example, the flow for the continuity (P-Mass) equation is the mass flow of a particular phase through
the boundary condition. The flow for the energy (H-Energy) equation is the energy flow per unit time through the
boundary condition.

FORCE
For details, see Calculated Wall Forces and Moments (p. 40).

NEG ACCUMULATION
Negative accumulation is the transient term contribution to the balance equation. For details, see BALANCES (p. 95).

RESIDUAL
For details, see Residual Plotting (p. 71).

SOURCE
Sources are the amount of a variable created or consumed in a particular three dimensional region of a domain. The
region might be user defined, if user defined source terms were set up, or the region might be the entire domain.
Source values which are defined for the entire domain are automatically computed by the solver, and vary depending
on the models which are being used. For example, automatically computed source values will appear in the turbulent
kinetic energy equation which represent the production and dissipation of turbulence.

TIMESTEP
Under the TIMESTEP heading, the only variable available is Accumulated Time Step. CFX-Solver Manager
uses this variable to plot the x-axis of ANSYS Field Solver and ANSYS Interface Loads plots. It represents the
cumulative iteration number in the following way:

• For the ANSYS Field Solver plot, the cumulative iteration number counts the number of iterations which the
ANSYS solver has performed in order to converge. Several ANSYS iterations will be performed for each
timestep or coupling step, depending on how quickly ANSYS converges.

• For the ANSYS Interface Loads plot, the cumulative iteration number counts the number of stagger iterations
performed by the ANSYS Multi-field solver.

USER
If monitor points have been created, a USER category is available. This can be expanded to select the monitor points
to plot. For details, see Monitor Tab (p. 157) in the ANSYS CFX-Pre User's Guide.

Configuring Plot Lines

Plot line variables can be configured as required.

1. Expand a plot line variable by clicking + next to it.

Categories are displayed.

2. Expand a category by clicking + next to it.

3. Select or clear specific plot line variables.

4. If working with a Residual Monitor, under Residual Mode, select RMS or MAX.
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Residual Mode acts as a visibility filter for variables of Residual type selected by default. If a variable of
type Residual is not selected by default it is plotted even if its type does not match the Residual Mode
setting.

5. Click Apply.

ANSYS GST and NLH Variables
The variables available for plotting when monitoring the contents of ANSYS GST and NLH files are mostly common,
and are described together.

ANSYS
The variables that are typically present in a GST or NLH files under the ANSYS heading are listed in the table
below together with a brief description (for the context of an ANSYS Multi-field MFX simulation). Other variables
may be present depending on the solution physics and the specified convergence targets. For full details, see the
ANSYS Product documentation.

DescriptionVariable Name

For details, refer to the ANSYS documentation in “Timestep
Bisection”.

Bisection

For details, refer to the ANSYS documentation in “Line Search”.Line Search Parameter

In the context of an ANSYS Multi-field run, Load Step is the
same as a multi-field timestep or Coupling Step.

Load Step

The largest change detected in the degree of freedom of interest over
the last two equilibrium iterations

Max DOF Incr

The ANSYS field solver may be set to use a smaller timestep than
the multi-field timestep. This is known as sub-cycling. In this case,
the multi-field timestep is broken into a series of sub-steps.

Sub-step

Multi-field time (current simulation time for a transient case)Time

Current time increment (may be variable if adaptive timestepping is
used)

Time Incr

Only in the GST file. For details, see ANSYS Field Solver
Plots (p. 72).

<variable> CRIT, <variable> L2, <variable>
L1, <variable> INF

Only in the NLH file. For details, see ANSYS Interface Loads
Plots (p. 73).

UX, UY, UZ, FX, FY, FZ, TEMP, HFLU

Plotting by a Specific Variable
While the CFX-Solver is running, the default setting is to plot the data as a function of Accumulated Time
Step. However, you may choose to view the data as a function of any available variable.

For example, you may choose to plot an important monitored quantity as a function of residual level. The existing
residual plot provides information on the exact convergence level, while this plotting feature gives another way to
determine how far you need to converge the solution, by combining residual information with monitored quantities.
For example, if you were to plot Mass Averaged Outlet Total Pressure vs. Mass Residual you
would see how quickly this important quantity stabilizes as a function of the residual convergence level. You may
then set a residual target for future runs that allows the CFX-Solver to stop when the established residual levels are
sufficient for the "important monitored quantity".

You can change the variable that is plotted on the X-axis for any specific plot as follows:

1. Right-click the plot you wish to modify (see Convergence History Plots (p. 2)) and select Monitor Properties
from the shortcut menu.
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2. On the Range Settings tab, set Plot Data By to Specified Variable and select the variable you wish
to use as the X-axis variable.

Global Plot Settings Tab
Plotting of coefficient loop/cloop data is turned off by default.

For transient runs, this selects or clears plotting of cloop data for each inner loop. This is in addition to plotting data
for each outer loop/timestep. For details, see Transient Residual Plotting (p. 72).

Note
As turning on the cloop setting results in a three to seven times increase in the size of the monitor data
file, it affects the performance of the CFX-Solver Manager.

1. Select Workspace > Workspace Properties > Global Plot Settings.

2. Select or clear Plot Coefficient Loop Data.

3. Under Plot Data By select Time Step or Simulation Time.

Variables are plotted against accumulated Time Step (the default) or against Simulation Time. The
latter is useful when using non-uniform timesteps.

New Monitor Command
This menu allows a shortcut to the creation of new monitors. However, if other properties associated with a workspace
need to be defined, full Workspace Properties should be viewed. Monitors can then be created as required.

• Workspace Properties Command (p. 91)

• Monitors Tab (p. 92)

Stop Current Run Command
To stop the CFX-Solver as soon as possible, use one of the following methods:

• Select Workspace > Stop Current Run.

• Click Stop Current Run .

If running CFX-Solver from the command line, use the command: cfx5stop. For an example of the cfx5stop
command, see Command-Line Samples (p. 118).

When CFX-Solver stops, the run is marked as finished, and a message appears. This message names the run and
specifies it has terminated at your request. Additional information about the run is also listed. Once manually
terminated, a run can be manipulated in the same way that a completed run .

Runs Using Mesh Adaption
If a stop current run command is issued for a run that uses mesh adaption, then only the current CFX-Solver run is
terminated; the overall simulation, which includes equation solution and mesh adaption, is not. The CFX-Solver is
automatically restarted after executing the next adaption step (if any remain), and the simulation continues.

Runs Using Remeshing
If a stop current run command is issued for a run that uses remeshing, then the overall simulation is terminated.

Runs Using External Solver Couplings
If a stop current run command is issued for a run that uses external solver couplings (for example, ANSYS
Multi-field), then the overall simulation is. For ANSYS Multi-field couplings, termination occurs at the end of the
current Load Step, for details see the Coupled Field Analysis Guide in the Mechanical APDL user documentation.
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In particular, steady state analyses will run until completion, and transient analyses will run until the end of the
current time step.

Multi-Configuration Runs
If a stop run command is issued in a workspace for a specific configuration, then only the current CFX-Solver run
for that configuration will be terminated; the overall simulation is not. All remaining configurations that are defined
for the simulation are subsequently run (unless a stop run command is also issued for them). If a stop run command
is issued in the simulation-level workspace, which is labeled according to the name of the multi-configuration
CFX-Solver Input file (* .mdef), then the overall simulation is terminated. The CFX-Solver run for the
configuration currently being executed is terminated as soon as possible, and no additional configurations are
executed.

Restart Current Run Command
You can restart a run that is finished or stopped. Restarting a run starts the run with the same settings as the previous
run, including Parallel settings.

There are numerous ways a run can be set up to restart; these are described in Restarting a Run (p. 16). To perform
the restart, either:

• Select Workspace > Restart Current Run.

• Click Restart Current Run .

Backup Run Command
Backing up a run creates a backup file of the results at the end of the timestep that is currently calculating. This file
contains sufficient information for restarting a run for visualization. You should generate backup files if a solution
may be diverging and an intermediate solution needs to be retained.

To back up a run, either:

• Select Workspace > Backup Run.

• Click Backup Run .

The backup file is stored in a subdirectory within the working directory. This subdirectory is given the same name
as the current run.

Arrange Command
Arranging the workspace deletes all monitors that are currently showing, regenerates them, and redisplays them by
optimizing the display based on available screen space. This has no impact on the display if the layout type has
been toggled to display multiple overlapping tabs. For details, see Toggle Layout Type Command (p. 98).

To arrange the workspace, either:

• Select Workspace > Arrange.

• Click Arrange Workspace .

Toggle Layout Type Command
Two layout modes exist. One is set up with multiple overlapping tabs used to switch between monitors and the other
displays each monitor in its own window. These may be toggled as required.

To toggle the workspace layout, either:

• Select Workspace > Toggle Layout Types.

• Click Toggle Layout Types .
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Load Layout Command
Layouts can be loaded as required. Before loading a layout, there must be layouts that have been saved. For details,
see Save Layout Command (p. 99).

To load a previously saved layout:

1. Select Workspace > Load Layout or click Load Layout .

The Layout File dialog box is displayed.

2. Select the location containing the file to load.

3. Select the file to load.

4. Click Open.

As the new workspace replaces the existing one CFX-Solver Manager requires confirmation that the new
workspace should overwrite the existing one.

5. Click Yes.

The new layout is loaded.

Save Layout Command
Once a layout has been configured to display preferred settings views, it can be saved. Once saved, layouts can be
loaded as required. For details, see Load Layout Command (p. 99).

This is useful when carrying out different runs for the same problem. For example, there may be a layout with
preferred settings after changing a boundary condition value. Another layout may be preferred for viewing a
turbulence model. By saving and loading a layout, it is simple to switch between these views.

The saved layout fully restores settings only for problems with the same domain and boundary names as the problem
that was selected in the when the layout was saved. If the saved layout is loaded when the current problem has
different domain and/or boundary names, variables to plot must be reselected. For details, see Duplicating a Plot
Monitor (p. 99).

1. Configure the current layout to the appearance to save.

That is, display various monitors, position them, set up the layout type and so on.

2. Select Workspace > Save Layout.

The Layout File dialog box is displayed.

3. If required, set the path location to a different directory.

4. Under File name, type the name of the file to save.

5. Click Save.

If the name already exists, a warning dialog box is displayed.

• Overwrite replaces the old file with the new document.

• Re-select returns to the Layout File dialog box.

• Cancel closes the open dialog boxes.

Duplicating a Plot Monitor
Rather than creating plot monitors manually, an existing one can be duplicated and modified.

The easiest way to create your own plot monitor is to copy the definition of an existing monitor and edit it to include
the new variables. The default monitor files (.mst) can be found in the <CFXROOT>/etc/CFX/ directory. For
example, if you want to view turbulence data on the same plot as mass and momentum you could enter the following:
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^RESIDUAL,RMS,.*-Mom;^RESIDUAL,RMS,.*-Diss.K; \
^RESIDUAL,RMS,.*-TurbKE;

As stated previously, the string for which a search is made can be found from the variable lists in the Plot Lines
panel of the Monitors form. For details, see Plot Lines Tab (p. 94).

View RMS Residuals Command
To display the RMS values of the residuals, select Workspace > View RMS Residuals.

For more information about residuals, see Residual Plotting (p. 71).

View MAX Residuals Command
To display the MAX values of the residuals, select Workspace > View Max Residuals.

For more information about residuals, see Residual Plotting (p. 71).

Reset to Default Workspace Command
Resets the default workspace to the state it was in immediately after the run was started, or after a finished run was
loaded. This can be useful when retrieving plots that have been accidentally deleted, or when reloading the original
plots after a change to their definition.

Note
Resetting the default workspace deletes any custom monitors.

1. Select Workspace > Reset to Default Workspace.

2. Click Yes.

Close Command
For information on the Close command, see Close Command (p. 85).
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Chapter 9.Tools Menu
The Tools menu controls layout, plots and text windows which are visible in the viewer. The current run can also
be backed up, restarted or stopped.

Properties for the current workspace can be changed, and new monitors created for simulations.

This chapter describes:

• Edit CFX-Solver File Command (p. 101)

• Export Command (p. 101)

• Export to ANSYS MultiField Command (p. 102)

• Interpolate Command (p. 102)

• Edit Run In Progress Command (p. 105)

• Edit Current Results File Command (p. 105)

• Post-Process Results Command (p. 106)

• View Environment Command (p. 106)

Edit CFX-Solver File Command
The command file section of a CFX-Solver input file can be modified. This allows modifications to a CFX-Solver
input file without the need to use CFX-Pre. The most useful application of this is in the modification of a simulation
when re-running the simulation may be too time consuming.

When a CFX-Solver input file is selected for modification, the Command File Editor is launched. For details, see
Editing CFX-Solver Input Files (p. 75).

1. Select Tools > Edit CFX-Solver File.

2. Browse to the directory containing the CFX-Solver input file to edit.

3. Select the CFX-Solver input file.

4. Click Open.

The Command File Editor is launched.

Export Command
If using tools other than CFD-Post for post-processing, data needs to be exported to a results file in a supported
format. The CFX Export utility can also be run from the command line.

• File Export Utility (p. 131)

• Running cfx5export from the Command Line (p. 143)

There must be a results file to reference before exporting.

1. Select Tools > Export.

The Export dialog box is displayed.

2. Under Results File, click Browse  and select a results file for export.

3. If required, under Export File, click Browse  and modify the default output path and name.

4. Under Domain Name, select the domain to export.

Where multiple domains exist, select the domain(s) to export.

5. Under Export Type select CGNS, MSC.Patran, FIELDVIEW, EnSight or Custom User Export.

• CGNS (p. 133)

• MSC.Patran (p. 135)
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• FIELDVIEW (p. 138)

• EnSight (p. 140)

• Custom User Export (p. 142)

6. Under Export Options, configure options as required.

The options are dependent on the Export Type. For details, see File Export Utility (p. 131).

7. Click Export.

Once completed, a message is displayed. Click OK to close it.

Export to ANSYS MultiField Command
This option is used to produce files for use in Fluid Structure Interaction cases. For details, see Export to ANSYS
Multi-field solver Dialog (p. 131).

1. Select Tools > Export to ANSYS MultiField.

The Export to ANSYS MultiField Solver dialog box is displayed.

2. Under Results File, click Browse  and select a results file for export.

3. If required, under Export File, click Browse  and modify the default output path and name.

4. Under Domain Name, select the domain to export.

Where multiple domains exist, select the domain(s) to export.

5. If required, under Boundary, select the boundaries to export.

6. Under Export Options, configure options as required.

The options are dependent on the export type. For details, see Export to ANSYS Multi-field solver
Dialog (p. 131).

7. Click Export.

Once completed a message is displayed. Click OK to close it.

Interpolate Command
ANSYS CFX allows the values from one results file to be interpolated onto a CFX-Solver input file containing
another mesh.

The major benefit of interpolation is the ability to use the solution from a simple model to provide initial conditions
for another, perhaps more complex model (thus increasing the likelihood of converging the complex model simulation)
or to continue a run with a different mesh or other settings.

Interpolation can be used with modified geometry or boundary conditions. Interpolation can also be used to interpolate
the solutions from a model with different mesh topology. For example, the initial guess for a problem having one
domain can be interpolated from one or more results files having a solution that spans multiple domains. When the
shape of the model has changed and the initial values files do not fully overlap with the new mesh, the
CFX-Interpolator extrapolates values for the points in the new mesh that lie outside the Initial Values File(s), based
on the interpolated values on the mapped nodes. See Using the CFX-Interpolator (p. 86) in ANSYS CFX-Solver
Modeling Guide for more details on how the CFX-Interpolator works.

The CFX-Interpolator is most commonly invoked through settings on the Run Definition tab on the Configuration
or Execution Control details view in CFX-Pre, or, the Define Run dialog of the CFX-Solver Manager. For details,
see Run Definition Tab (p. 225) in ANSYS CFX-Pre User's Guide, Run Definition Tab (p. 216) in ANSYS CFX-Pre
User's Guide and Run Definition Tab (p. 8), respectively.

However, if you wish to manually use the interpolator to write variables into a specific Solver Input File (not invoked
from the Run Definition tab) then you can choose Tools > Interpolate Results from the CFX-Solver Manager. In
this case the specified Mesh File is used as the target file, and will be modified by the interpolation process. The
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text output is written into the CFX-Solver Manager's Interpolation dialog. You can then run the resulting target file
in the CFX-Solver, using the variables written into the target file by the CFX-Interpolator as the initial conditions
for the run.

To manually interpolate the results from a source file to a target file, you can use the Interpolate Results command
as follows:

1. Select Tools > Interpolate Results.

The Interpolation dialog box is displayed.

2. Select the Interpolate method.

3. Set Results File to the name of the source file. You can click Browse  to select the file using a browser.

4. Set Mesh File to the name of the target file. You can click Browse  to select the target file using a browser.

You can interpolate onto a CFX-Solver Input file.

5. Under Executable Settings, select or clear Double Precision.

For details, see Double-Precision Executables (p. 123).

6. If required, under Interpolator Memory, adjust the memory configuration. For details, see Configuring
Memory for the CFX-Solver (p. 13).

7. Click Interpolate.

The output window on the right displays details of the interpolation process.

Once completed, a message is displayed. Click OK to close it.

You can also run the interpolator from the command line. For details see Using the Command Line to Interpolate
Results (p. 104).

Note
• To save the results to a text file, right-click in the text output window and select Save As.

• Interpolating results from a source file to a target file which already contains solution data is not
recommended. See Interpolating Onto a Solver Input File with Results Fields (p. 94) in ANSYS
CFX-Solver Modeling Guide for details.

• Following the steps above, the interpolation is performed in Initial Guess mode. See Using the
CFX-Interpolator (p. 86) in ANSYS CFX-Solver Modeling Guide for details.

To generate a comparison of two files, you can use the Interpolate Results command. The comparison is stored
as new variables with the prefix Difference. These variables can be used in CFD-Post to determine regions
where the solution has changed significantly. A comparison of two files can be generated as follows:

1. Select Tools > Interpolate Results.

The Interpolation dialog box is displayed.

2. Select the Calculate Differences method.

3. Set Original Results to the name of the original results file. You can click Browse  to select the file using

a browser.

4. Set Modified Results to the name of the modified results file. You can click Browse  to select the file

using a browser.

5. Under Executable Settings, select or clear Double Precision.

For details, see Double-Precision Executables (p. 123).

6. If required, under Interpolator Memory, adjust the memory configuration. For details, see Configuring
Memory for the CFX-Solver (p. 13).

7. Click Calculate Differences.
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The output window on the right displays details of the differencing process.

Once completed, a message is displayed. Click OK to close it.

Note
CFD-Post now also supports comparison of two results files without the use of the CFX-Interpolator.
For details, see Case Comparison (p. 181) in ANSYS CFD-Post User's Guide.

Using the Command Line to Interpolate Results
In some instances, the cfx5interp script can be used from the command line to initiate an interpolation. This
section presents a brief introduction to this script. For more information about this script, type
<CFXROOT>/cfx5interp -help at the command prompt.

To use the cfx5interp script, enter a command line of the form:

cfx5interp -res <results file> -mesh <CFX-Solver input file> [<arguments>]

where:

• <results file> is the name of a results file that contains a solution.

• <CFX-Solver input file> is the name of a CFX-Solver input file that contains a mesh onto which the
solution should be interpolated.

• [<arguments>] is an optional list of additional arguments.

cfx5interp rewrites the CFX-Solver input file with the interpolated form of the solution that was read from the
results file. A command of this form would produce the same results as running invoking interpolation using Tools
> Interpolate Results within the CFX-Solver Manager.

You can use the -difference argument to cause the interpolator to produce difference datasets for differences
in results between two results files. The form of such a statement is:

cfx5interp -difference -from <res file 1> -dest <res file 2> [<arguments>]

where:

• <res file 1> is the name of a results file that contains the original (older) set of fields

• <res file 2> is the name of a results file that contains the newer set of fields

• [<arguments>] is an optional list of additional arguments

cfx5interp calculates the differences between an original set of fields and the newer set, and rewrites <res
file 2> with the differencing information included.

The cfx5interp script can run two versions of the interpolator. The newer version (a solver-based interpolator)
runs by default, and the older one (that was released with ANSYS CFX 10.0) can be invoked by using the
-interp-old argument.

When the older interpolator is used, the cfx5interp script is capable of producing a text file of results for specific
locations within the fluid domain. This is particularly useful if there is experimental data to validate.

To produce a results text file, first create a text file containing the particular vertex coordinates of interest, in the
following format:

x(1) y(1) z(1)
x(2) y(2) z(2)
. . . .
x(n) y(n) z(n)

Once the vertex file is created, run the old interpolator using a command line of the form:
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cfx5interp -vtx <vertex file> -res <results file> -interpolate-old

The old interpolator creates a file with a name of the form: <vertex file>.inn, where nn is chosen to make
a unique file name. This is a text file that contains the coordinates that are specified in the vertex file, plus the results
from the results file interpolated to the vertex locations.

If, in the vertex file, there are coordinates that lie outside of the solution grid, values of 0.0E0 will be assigned for
all variables at those coordinates. In other words, results are not extrapolated to a vertex file.

Note
Some of the values obtained using the cfx5interp script may differ slightly from the values obtained
using Data Export in CFD-Post. These minor discrepancies result from different methods of calculation.
Discrepancies are more likely to occur at points which lie very close to the edge of the mesh elements
or in regions of prism and hexahedral elements. Inconsistencies are likely to be more significant where
gradients are large, particularly in the boundary layer.

Edit Run In Progress Command
You can edit the CCL definition of a CFX-Solver input file while the solver is running. The changes you make take
effect when saved and the modified CCL is preprocessed for the flow solver. The modified CCL may take several
iterations to be updated depending on system load, hardware and problem size.

Theses changes apply only to the run in progress, and do not affect the CFX-Solver input file that was used to begin
the run (if one was used). Before the next outer-loop iteration begins, a backup file named
<iteration number>.bak is written to the working directory. The backup file can be used to restart the run
from the point at which the CCL definition was changed, if needed.

Only selected CCL parameters can be dynamically changed. A list of these parameters is in the RULES file. For
details, see RULES File (p. 81).

The Command File Editor can also be used to make changes to the CCL contained in a CFX-Solver input file.
Changes, when saved, affect the edited CFX-Solver input file only, not any run in progress. For details, see Editing
CFX-Solver Input Files (p. 75).

To access the command file editor, select Tools > Edit Run In Progress or click Edit Run In Progress .

Note
The Edit Run in Progress command is not enabled for simulations involving ANSYS Multi-field
couplings. This constraint exists because of difficulties involved with updating the MFX settings in the
ANSYS solver during the run.

CCL Propagation in Multi-Configuration Simulations
The Edit Run in Progress command is enabled for the configuration being run, rather than in the global (or
simulation) level workspace. In addition to applying CCL changes to the running configuration, some or all of the
changes are also automatically propagated to subsequent configuration runs. In particular:

• changes made to the LIBRARY section of the CCL (e.g. material properties, expressions, reactions, etc…) are
propagated to all subsequent configurations, and

• changes made to the FLOW section of the CCL (e.g. analysis type, boundary conditions, solver and output
controls, etc…) are propagated to all subsequent runs of the current configuration.

Edit Current Results File Command
Edit the results file in the current workspace (if available). This feature is available when a results file in the current
workspace that has finished. For details, see Editing CFX-Solver Input Files (p. 75).

• Select Tools > Edit Current Results File or click .

The Command File Editor is launched and the current results opened.
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Post-Process Results Command
Loads the CFD-Post post-processor. For details, see Overview of CFD-Post (p. 1) in the ANSYS CFD-Post User's
Guide.

1. Select Tools > Post-Process Results.

The Start CFD-Post dialog box is displayed.

2. Under Results File, click Browse  and select a results file to load into CFD-Post.

3. If you want to load two results files into CFD-Post together, check Specify Additional Results File, and select
another results file to load.

4. Select or clear Shut down Solver Manager.

If selected, ANSYS CFX-Solver Manager is shut down before CFD-Post is launched.

5. Click OK.

View Environment Command
Used to display a complete list of environment variables associated with the CFX-Solver Manager and their settings.

1. Select Tools > View Environment.

The Solver Manager Environment dialog box is displayed.

2. Click Save to export the content to a text file.
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Chapter 10. Monitors Menu
The Monitors menu sets the display options for plots of your simulation.

Each menu option has a submenu. This is used to specify display options for a given category. Selected options will
display the related plot.

Residuals are combined by default in the CFX-Solver Manager. Residuals for each domain can be displayed as
required by selecting the residuals by domain in the submenu for each residual type.
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Chapter 11. Starting the CFX-Solver from
the Command Line

The CFX-Solver is a separate module of CFX that has no graphical user interface. You can start CFX-Solver from
the command line by executing the following command:

cfx5solve [options]

where [options] denotes the options applicable during a command-line run. This chapter discusses how to run
CFX-Solver in a batch mode and describes the supported command-line options in the following sections:

• Command-Line Use (p. 109)

• Command-Line Options and Keywords for cfx5solve (p. 109)

• Command-Line Samples (p. 118)

You can also use CFX-Solver Manager to start CFX-Solver. The graphical user interface of the CFX-Solver Manager
enables you to set various options, allows easier control of the solution process, and provides some visual details
as the solution emerges. For details, see CFX-Solver Manager Basics (p. 1).

Command-Line Use
CFX-Solver Manager and CFX-Solver can be launched from a command line as follows:

• The basic command to start CFX-Solver Manager is cfx5solve.

The more general form of the command is:

cfx5solve [-interactive [-definition <file>]]
[-display <display>] [-help]
[-solver <executable>] [-verbose]

where [] denotes a discretionary option, | separates mutually exclusive options, and <> denotes that substitution
of a suitable value is required. All other options are keywords, some of which have a short form.

• The basic command to start the CFX-Solver using the CFX-Solver input file named <file> is:

cfx5solve -def <file> [-help] [-initial <file>]
[-double | -single]
[-nosave|-save] [-name <name>]  [-size <factor>]
[-solver <executable>] [-partition <number of partitions>]
[-parallel] [-parfile <file>] [-serial] [-verbose]

where [] denotes a discretionary option, | separates mutually exclusive options, and <> denotes that substitution
of a suitable value is required. All other options are keywords, some of which have a short form.

How you invoke a command line depends on your operating system:

• On UNIX, you can run CFX-Solver Manager from a UNIX shell.

• On Windows, start a CFX Command Line from the CFX Launcher: Tools > Command Line. Alternatively,
you can run CFX-Solver Manager from a DOS prompt. For details, see Command Line (p. 3) in the ANSYS
CFX Reference Guide.

The cfx5solve command-line options are described in the next section.

Command-Line Options and Keywords for cfx5solve
The command-line options for cfx5solve are described below. To see command-line help, run cfx5solve
-help.
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Note
When running the solver from the command line using a CFX-Solver input file or CFX-Solver results
file, any execution control CCL contained in the file takes precedence over the command-line options.

If an option is specified multiple times within the context of a specific configuration, then the last
specification of the option takes precedence.

UsageAlternative formCommand-Line Options

For an ANSYS Multi-field run, enables you to specify
any additional options when starting the Mechanical

-ansys-arguments
<arguments>

application solver. The specified options are passed
to the Mechanical application solver as command-line
arguments. For details, see MultiField Tab (p. 9).

For an ANSYS Multi-field run, specifies the
Mechanical application input file to use. For details,
see MultiField Tab (p. 9).

-ansys-input <file>

For an ANSYS Multi-field run, this turns off the
Processing Mechanical input file option. For details,
see MultiField Tab (p. 9).

-ansys-input-is-complete

For an ANSYS Multi-field run, sets the ANSYS
installation directory. This option is needed only if

-ansys-installation
<directory>

ANSYS is installed in a non-standard location. For
details, see MultiField Tab (p. 9).

For an ANSYS Multi-field run, sets the jobname for
the Mechanical application component of the

-ansys-jobname
<name>

simulation. The CFX-Solver Manager defaults this to
ANSYS. On a restart, the jobname must be the same
as for an initial run.

For an ANSYS Multi-field run, sets the license that
the Mechanical application solver should use. For
details, see MultiField Tab (p. 9).

-ansys-license
<licensekey>

For an ANSYS Multi-field run, tells CFX that the
Mechanical application component of the simulation

-ansys-restart
<file>

is a restart, and gives the database (*.db or *.rdb)
from the previous Mechanical application run to be
used for the restart. For details, see MultiField
Tab (p. 9).

Causes the flow solver to write a backup file every
<elapsed time frequency> hours, minutes,

-baket <elapsed time
frequency>

-bak-elapsed-time
<elapsed time
frequency> seconds, et cetera. Elapsed time must be in quotes and

have units in square brackets. For example: -baket
“10 [min]” or -baket “5 [hr]”.

Starts CFX-Solver in batch mode (that is, without
starting the CFX-Solver Manager interface).

-batch

Reads Command Language from the named file, and
uses it to provide defaults for the current run. If the

-bg-ccl <file>

file specifies a CFX-Solver input file for the run, the
command language contained in that CFX-Solver
input file will take precedence over that supplied. Also
see the -ccl option.
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UsageAlternative formCommand-Line Options

Reads additional Command Language from the named
file. Overrides any CFX Command Language specified

-ccl <file>

in the CFX-Solver input file. If <file> is the single
character '-', the Command Language is read from
the standard input (usually the terminal). If any
settings are made in the Command Language file
which also occur on the command line to the left of
the -ccl option, the settings in the file will take
precedence, as stated above. This option may be
repeated to include Command Language from more

than one file.a

Starts <executable> instead of the standard ANSYS
CFX ccl2flow.

-ccl2flow
<executable>

Starts <executable> instead of the standard ANSYS
CFX cclsetup.

-cclsetup
<executable>

Sets the working directory as specified.-chdir <directory>

When running in batch mode, this will cause
cfx5solve to verify its options, but exit before

-check-only

starting any processes, and is mostly for use by
CFX-Solver Manager.

Applies subsequent options to the specified
configuration.

-config
<configuration
name>

Uses initial values and continues the run from the
specified CFX-Solver results file. The mesh from the

-cont-from-file
<file>

-continue-from-file
<file>

CFX-Solver input file is used unless the
-use-mesh-from-iv option is also specified.
Only one -continue-from-file argument can be
supplied. See Continuing the History (p. 82) in
ANSYS CFX-Solver Modeling Guide for more details.

Uses initial values and continues the run from the most
recent results for the named configuration. The mesh

-cont-from-config
<configuration name>

-continue-from-configuration
<configuration
name> from the configuration (.cfg) file is used unless the

-use-mesh-from-iv option is also specified.
Only one -continue-from-configuration argument can
be supplied. See Continuing the History (p. 82) in
ANSYS CFX-Solver Modeling Guide for more details.

For an ANSYS Multi-field run, specifies CFX-Solver
which Port Number and Host Name to use to

-cplg-host
<port@host>

communicate with the Mechanical application solver.
For details, see MultiField Tab (p. 9).

Uses <file> as the solver input file for a single
configuration simulation. This may be a CFX-Solver

-def <file>-definition <file>

input file or a CFX-Solver results file for a restart.
The file specified is used in the same way as the input
file on the Define Run dialog box. For details, see
Define Run Command (p. 85). Also see the -mdef
option.
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UsageAlternative formCommand-Line Options

(UNIX only) Uses the X11 server <display>
instead of the X11 server defined by the DISPLAY
environment variable.

-display <display>

Starts the double-precision version of ANSYS CFX
Partitioner, Interpolator and Solver. Also see the
-single option.

-double

Starts the CFX-Solver using one of the example
CFX-Solver input files provided with the product. The
example StaticMixer is currently available.

-eg <file>-example <file>

Specifies the basename for the CFX-Solver output
file, CFX-Solver results file, and the temporary

-fullname <name>

directory based on <name> instead of the CFX-Solver
input file name. No numerical suffix (such as _001)
is added to the specified name.

Displays the help information for command-line
options.

-h-help

Uses the initial values in the CFX-Solver results file
<file>. The mesh from this results file is used unless

-ini <file>-initial <file>

the -interpolate-iv option is also specified.
This option has been deprecated and should be
replaced by -initial-file or
-continue-from-file as appropriate.

Uses initial values from the most recent results for the
named configuration as a basic initial guess for the

-ini-conf
<configuration name>

-initial-configuration
<configuration
name> run. The run history from this file is discarded. The

mesh from this results file is used unless the
-interpolate-iv option is also specified. See
Continuing the History (p. 82) in ANSYS CFX-Solver
Modeling Guide for more details.

Uses initial values from the specified CFX-Solver
Results file as a basic initial guess for the run. The run

-ini-file <file>-initial-file
<file>

history from this file is discarded. The mesh from the
configuration (.cfg) file or the CFX-Solver input
file is used unless the -use-mesh-from-iv option
is also specified. See Continuing the History (p. 82)
in ANSYS CFX-Solver Modeling Guide for more
details.

Starts CFX-Solver Manager in graphic user interface
(GUI) mode. The CFX-Solver Manager interface

-int

-manager

-interactive

allows an interactive control for starting a new run
and/or manage or monitor an existing run.

Interpolates the solution from the initial values file, if
one is supplied (using the -initial option), onto

-interp-iv-interpolate-iv

the mesh from the CFX-Solver input file, rather than
using the mesh from the initial values file. This option
has been deprecated and should be replaced by the
-initial-file or -continue-from-file
option, as appropriate.
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UsageAlternative formCommand-Line Options

When running with the solver-based interpolator
(-interp-iv option), this option will select the

-interp-double

double-precision version of the interpolator. It will
not override the -interpolator option if both are
used.

Uses the single precision ANSYS CFX Interpolator
executable.

-interp-single

When running with the interpolator (-interp-iv
option), this option will start <executable> instead
of the default interpolator.

-interpolator
<executable>

Keeps the .job file after an ANSYS CFX Solver run.
This file contains a brief summary of various solution
values, and is most useful for regression purposes.

-job

Keeps job file after an ANSYS CFX Partitioner run.
This file contains a brief summary of various solution
values, and is most useful for regression purposes.

-jobp-job-part

Sets the maximum elapsed time (wall clock time) that
CFX-Solver will run. Elapsed time must be in quotes

-maxet <elapsed
time>

-max-elapsed-time
<elapsed time>

and have correct units in square brackets. For example:
-maxet “10 [min]” or -maxet “5 [hr]”.

Uses <file> as the solver input file. This may be a
multi-configuration definition file or results file for a

-mdef <file>-mdefinition <file>

restart (that is, .mdef or .mres, respectively). The
file specified is used in the same way as the input file
on the Define Run dialog box. For details, see Define
Run Command (p. 85).

Use this option to specify one of the following MFX
run modes for an ANSYS Multi-field run:

-mfx-run-mode
<mode>

"Start ANSYS and CFX"

"Start ANSYS only"

"Start CFX only"

"Process Input File only"

For details, see MultiField Tab (p. 9).

When starting ANSYS CFX-Solver Manager, use this
option to monitor the run represented by <file>,

-monitor <file>

which may be a CFX-Solver results file or CFX-Solver
output file.

Treats the CFX-Solver input file as a
multi-configuration input file.

-multiconfig

Specifies the basename for exported files and the
temporary directory based on the problem name

-name <name>

<name> instead of the CFX-Solver input file name,
unless other names are explicitly defined.

This name cannot be set when using the CFX-Solver
Manager to start the CFX-Solver.
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UsageAlternative formCommand-Line Options

Use this option to preprocess the CFX-Solver input
file only, without running the solver executable. When

-norun

used with a multi-configuration CFX-Solver input
file, this option produces complete solver input files
for the individual configuration (.cfg) files. When
used with the "-config" option, only the specified
configuration is preprocessed.

Use this option to set the comma-separated
<host-list> in the same form as is used in the

-par-dist
<host-list>

Command Language definition. This option does not
require the -partition option, as one partition is
run on each host mentioned in the list. To run multiple
partitions on the same host, it may be listed multiple
times, or an asterisk may be used with the count, as
in "wallaby*3,kangaroo*4" for a 7-partition
run.

Host details are taken from the hostinfo.ccl file,
if they are there; otherwise, if possible, the required
information will be automatically detected. <host>
may be specified as
[<user>@]<hostname>[:<CFX_ROOT>], if
the user name or the ANSYS CFX installation root
directory differs from the local host.

When running in parallel, uses the specified host list.
See the -par-dist option for details of the host list.

-par-host-list
<host1> [,<host2>
[,...]] This option defaults to PVM Local Parallel on

UNIX/Linux platforms and HP MPI Local Parallel on
Windows.

When running in parallel, uses only the local host.
This will override the -par-dist or
-par-host-list options.

-par-local

Starts the solver in parallel mode. This option can be
combined with -partition for a partitioning run.

-par-parallel

If the -part option is not specified, then the
-parfile-read option must be used to specify a
valid partitioning information file.

Specifies the name of an input partition file used to
set up a partitioning or parallel run.

-parfile-read
<parfile>

Note
Only *.par files that are generated in
ANSYS CFX 12.0 (or later) are supported.
For details, see CFX Partition File (p. 63).

When used with a parallel run, saves the partitioning
information to a file with the same basename as the
results file, and the extension .par.

-parfile-save

Specifies the name of a partition file to which to write
the information from a partitioning run.

-parfile-write
<parfile>
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Starts the solver in partitioning mode. This option
should not be used if an existing partition file is also
specified.

-part <number of
partitions>

-partition <number
of partitions>

Starts <executable> instead of the standard
partitioner.

-partitioner
<executable>

Activates coupled partitioning mode for multidomain
problems. This is not activated by default.

-part-coupled

Activates independent partitioning mode for
multidomain problems. This is the default.

-part-independent

Starts the large problem partitioner which can partition
problems up to 2^31-1 elements. This partitioner uses

-part-large

64-bit integer and logical variables so it will allocate
more memory than the default partitioning executable.

Sets the partitioning mode to use when running the
partitioner. Valid options are metis-kway (MeTiS

-part-mode <mode>

k-way), metis-rec (MeTiS Recursive Bisection),
simple (Simple Assignment), drcb (Directional
Recursive Coordinate Bisection), orcb (Optimized
Recursive Coordinate Bisection), rcb (Recursive
Coordinate Bisection)

Finer control over the partitioning method is available
through the Command Language.

Starts the solver in partitioning mode only. This is
normally equivalent to -part, but may be necessary
if partitioning a results file from a previous run.

-part-only <number
of partitions>

Uses the single precision ANSYS CFX Partitioner.
This is the default, but is provided for overriding any

-part-single

information which might be stored in the CFX
Command Language dataset in a file from previous
runs. Also see the -double option.

Sets the first license used by solver, given the
availability of multiple usable licenses.

-P <license name>-preferred-license
<license name>

Enables the specification of a job priority to a solver
run; the allowed values are Idle (0), Low (1),

-pri <level>-priority <level>

Standard (2), and High (3). The default value on
UNIX platforms is High, which corresponds to nice
increment of 0. On Windows, the default is
Standard, corresponding to a priority level of
Normal.

Use this option to avoid deleting any temporary files
after the run. Normally the standard temporary files

-save

created by CFX-Solver are deleted automatically after
each run.

Use this option to explicitly specify that a serial run
is required. This is useful when restarting a run from

-serial

a results file produced by a parallel run, where this
option forces a serial run instead.
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Starts the single-precision version of the CFX-Solver,
Partitioner, and Interpolator. This is the default, but

-single

is provided for overriding any information which
might be stored in the CFX Command Language
dataset in a file from a previous run. Also see the
-double option.

Changes memory estimates used by the CFX-Solver
by a factor of <factor>. Memory estimates are

-S <factor>

-s <factor>

-size <factor>

sometimes inaccurate and this option needs to be used
to increase the memory allocated. For example, using
-size 1.05 increases memory allocated by 5%.
This option provides the same functionality as set in
Solver Memory. For details, see Solver Tab (p. 12).

Further options for controlling the CFX-Solver
memory allocation are available. Execute
cfx5solve -help for full details.

These flags are for advanced users to change the
memory allocation parameters for the solver. Usually,

-scat <size>

-nr <size>

-size-cat <size>

-size-nr <size>
you should use the -size option instead. <size>

-ni <size>-size-ni <size> is the desired memory allocation in words, and may
have K or M appended for kilo or mega. If the suffix
is 'x', then the number is treated as a multiplier.

-nd <size>

-nc <size>

-size-nd <size>

-size-nc <size>

-nl <size>-size-nl <size>

Changes the memory estimates used by the ANSYS
CFX cclsetup executable by a factor of <factor>.

-sizeccl <factor>-size-cclsetup
<factor>

These options are the same as the -size-* options
above, but provide sizes needed for the ANSYS CFX
CCL Setup executable.

-scatccl <size>

-nrccl <size>

-niccl <size>

-size-cclsetup-cat
<size>

-size-cclsetup-nr
<size>

-ndccl <size>
-size-cclsetup-ni
<size> -ncccl <size>

-nlccl <size>-size-cclsetup-nd
<size>

-size-cclsetup-nc
<size>

-size-cclsetup-nl
<size>

Changes the memory estimates used by the
solver-based interpolator by a factor of <factor>.
Also see the -size option.

-sizeint <factor>-size-interp
<factor>

These options are the same as the -size-* options
above, but provide sizes needed for the ANSYS CFX
Interpolator.

-scatint <size>

-nrint <size>

-niint <size>

-size-interp-cat
<size>

-size-interp-nr
<size>

-ndint <size>
-size-interp-ni
<size> -ncint <size>

-nlint <size>-size-interp-nd
<size>
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-size-interp-nc
<size>

-size-interp-nl
<size>

Changes the initial MMS catalogue size estimate used
by the CFX-Solver by a factor of <factor>. This

-smms <factor>-size-mms <factor>

option has been deprecated and should be replaced by
-size-cat.

Changes the initial MMS catalogue size estimate used
by the partitioner by a factor of <factor>. This

-smmspar <factor>-size-part-mms
<factor>

option has been deprecated and should be replaced by
-size-part-cat.

Changes the memory estimates used by the ANSYS
CFX Partitioner by a factor of <factor>. Also see

-sizepart <factor>

-sizepar <factor>

-size-part <factor>

-size-par <factor>
the -size option. Further options for controlling the
partitioner memory allocation are available. Execute
cfx5solve -help for full details.

These options are the same as the -size-* options,
but provide sizes needed for partitioner rather
than solver.

-scatpar <size>

-nrpar <size>

-nipar <size>

-size-part-cat
<size>

-size-part-nr
<size>

-ndpar <size>
-size-part-ni
<size> -ncpar <size>

-nlpar <size>-size-part-nd
<size>

-size-part-nc
<size>

-size-part-nl
<size>

Starts <executable> instead of the standard
ANSYS CFX solver on <os>, where <os> is the

-exec
[<os>=]<executable>

-solver
[<os>=]<executable>,
<os>=<executable>[...]] short architecture string for the desired operating

system. If <os> is omitted, then the current operating
system is assumed.

[,<os>=<executable>[,
...]]

For example: the command-line option -solver
"linux-amd64/mysolver.exe,linux=linux/mysolver.exe"
uses the executable "linux-amd64/mysolver.exe" for
the current operating system and the executable
"linux/mysolver.exe" for the "linux" operating system.
Full paths or paths relative to the working directory
may be used when specifying solver executables. In
this example, it is worth noting that the current
operating system is presumed to be "linux-amd64",
and that the "linux-amd64/mysolver.exe" and
"linux/mysolver.exe" will be used for all solvers
running on "linux-amd64" and "linux" operating
systems, respectively.

The string value for <os> can be determined by
running the following command:
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• On Unix-like systems, execute
<CFXROOT>/bin/cfx5info -os.

• On a Windows system, execute
<CFXROOT>\bin\cfx5info -os.

where <CFXROOT> is the path to your installation of
ANSYS CFX.

Uses the single precision ANSYS CFX Solver.-solver-single

Uses the double precision ANSYS CFX Solver.-solver-double

Uses the named start method to start the solver. This
option allows you to use different parallel methods,

-start-method
<name>

as listed in the CFX-Solver Manager GUI, instead of
the defaults. For parallel runs, you also need to provide
the -part or -par-dist options.

Uses the mesh from the source initial values (that is,
from a file or configuration) rather than from the

-use-mesh-from-iv

solver input file. This is only valid if a single
initial-values source is specified.

Specifying this option may result in additional output
being sent to the standard output file (normally the
screen).

-v-verbose

aLocators for applying physics cannot be modified using the -ccl option; they can, however, be changed in CFX-Pre.

Command-Line Samples
Here are some examples to help clarify the use of the command line:

Start CFX-Solver
To start CFX-Solver running from the CFX-Solver input file model.def, enter the command:

cfx5solve -def model.def

If the input file is for a multiple configuration (.mdef file), enter the command:

cfx5solve -mdef model.mdef

Start CFX-Solver Manager
To start CFX-Solver Manager, passing it the name of the CFX-Solver input file, enter the command:

cfx5solve -interactive -def model.def

Produce a Partition File
To produce a partition file with the MeTiS partitioning method and seven partitions, but not run CFX-Solver to
solve for the solution, enter the command:

cfx5solve -def model.def -partition 7

This command will produce a file named model_001.par in the local run directory.
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Note
If the file model.par exists in the working directory, then the partition type (MeTiS, RecCoordBis
or SpecDir) is read from this file, even if you have not specified the file model.par. Because this
could potentially be confusing, you are advised to use the CFX-Solver Manager to set up a partitioning
run, unless you are certain that either there is no file model.par or that the partitioning method specified
in the model.par file is what you require.

Start CFX-Solver in Local Parallel
To run CFX-Solver in parallel, starting from the CFX-Solver input file model.def and running only on the local
machine with two partitions, enter the command:

cfx5solve -def model.def -par-local -partition 2

If you have already created a file model.par (for instance, by using the command cfx5solve -def
model.def -partition 7), then you can run the parallel CFX-Solver by entering the command:

cfx5solve -def model.def -par-local -parfile-read model.par 

To run the CFX-Solver in parallel for the configuration named <config> and in serial for other configurations in
a multi-configuration simulation, enter the command:

cfx5solve -mdef model.mdef -config "<config>" -par-local -partition 2

Start CFX-Solver in Distributed Parallel
For this example to work, the hosts hosta, hostb and hostc must be defined in the central hostinfo.ccl
file.

To run CFX-Solver in distributed parallel, starting from the CFX-Solver input file model.def, and using 1 partition
on hosta, 2 partition on hostb and 4 partitions on hostc, for a total of 7 partitions, enter the command:

cfx5solve -def model.def -par-dist 'hosta,hostb*2,hostc*4'

Start CFX-Solver in Parallel
To start the CFX-Solver in parallel with four partitions on two hosts, enter the command:

cfx5solve -def file.def -par-dist 'hosta*2,hostb*2'

If you have already created a partitioning file, say model.par (for instance, by using the command cfx5solve
-def model.def -partition 7), then you can execute the distributed parallel run as follows:

cfx5solve -def model.def –parfile-read model.par -par-dist 'hosta,hostb*2,hostc*4'

The number of partitions specified using the –par-dist command-line flag must be the same as that in the
partitioning file, model.par, or the run will fail.

Start CFX-Solver in Parallel Using MPICH2
To start the CFX-Solver in parallel, with two partitions, using MPICH2 Local Parallel on a Windows machine (give
this command as a single line), enter the command:

cfx5solve -def file.def -start-method "MPICH2 Local Parallel for Windows" -part 2

Start an ANSYS Multi-field Run (FSI)
To start an ANSYS Multi-field Run, launching both the Mechanical application and CFX Solvers, starting from
the CFX-Solver input file model.def and using the Mechanical application input file model.inp:
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cfx5solve -def model.def -ansys-input model.inp

To start an ANSYS Multi-field run, launching the Mechanical application solver only, disabling the processing of
the Mechanical application input file and using the Mechanical application input file model.inp:

cfx5solve -def model.def -ansys-input model.inp -mfx-run-mode "Start ANSYS only" -ansys-

To start an ANSYS Multi-field run, launching CFX-Solver only and telling it to communicate with the already
running Mechanical application solver on a particular port number and host, enter the command:

cfx5solve -def model.def -mfx-run-mode "Start CFX only" -cplg-host 49800@machine1 -cplg-

Preprocess Incomplete Configuration Files
Configuration definition (.cfg) files that are created in conjunction with a multi-configuration simulation file
(.mdef) are incomplete; they do not contain global information like equation and material definitions.

To preprocess the configuration files so that they are complete and can be run independent of the multi-configuration
simulation, enter the command:

 cfx5solve -mdef model.mdef -norun 

To preprocess the configuration definition file corresponding to the configuration name <config>, enter the
command:

cfx5solve -mdef model.mdef -config "<config>" -norun

Stopping the CFX-Solver from the Command Line
After CFX-Solver is running, stop it by using cfx5stop from the command line.

Suppose a run is called mixer_001 in the current directory. There will be a temporary directory called
mixer_001.dir in the current directory while that run is actually running. To stop the run, enter the following
command line:

cfx5stop -directory mixer_001.dir
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Chapter 12. CFX-Solver Start Methods
CFX-Solver Start Methods define allowable parameters and command-line arguments used by CFX-Solver Manager
and CFX-Solver Script to launch the CFX-Solver executable and perform a run. The definition of the solver start
methods are modifiable by expert users to customize solver start-up for specific parallel or batch queuing
environments.

The standard start methods for a CFX installation are contained in the <CFXROOT>/etc/start-methods.ccl
file. These can be over-ridden by placing a custom version of this file in the same location as the site or user CFX
configuration files.

Direct Start Methods
Solver start methods that directly run the CFX-Solver executable are known as Direct start methods, and are
commonly used for defining solver execution in serial or parallel on local networks. Definition of solver start
methods for specific parallel environments can be made following the various available PVM (UNIX only) and
MPI methods in the file.

Indirect Start Methods
Solver start methods can also be used to launch a user-defined script or program that can perform system interaction
before re-executing a cfx5solve command under a different environment or system. These are known as indirect
start methods, and are commonly used for executing CFX-Solver runs on remote or batch queuing systems. Use of
Indirect start methods requires knowledge of a system scripting language (such as bash or Perl) to customize the
solve start-up process for your specific environment.

Example
An example of the use of Indirect Solver Start methods to run a cfx5solve command within a PBS-based batch
queuing system is provided in the CFX distribution. For details, please see the Submit to PBS Queue start method
in start-methods.ccl, and the qcfx5solve.pl script in the <CFXROOT>/extras/ directory.
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Chapter 13. CPU and Memory Requirements
This chapter provides information on typical increases in CPU (central processing unit) time and memory requirements
incurred by some simulations and physical models:

• Tetrahedral Mesh (p. 123)

• Special Partitioner, Solver and Interpolator Executables (p. 123)

• Turbulence (p. 124)

• Energy Models (p. 124)

• CHT Regions (p. 124)

• Multicomponent Flows (p. 124)

• Multiphase Flows (p. 124)

• Additional Variables, Wall Distance Variables, and Boundary Distance Variables (p. 125)

• Combustion Modeling (p. 125)

• Radiation Modeling (p. 126)

• GGI Interfaces (p. 126)

• Transient Runs (p. 126)

• Mesh Deformation (p. 126)

• Bi-Directional (Two-Way) Couplings with ANSYS Multi-field (p. 126)

Tetrahedral Mesh
The ratio of elements to nodes is approximately 5:1 for a tetrahedral mesh. For example, if 5 million tetrahedral
elements are in a mesh, then there are approximately 1 million nodes. This is in contrast to a hexahedral mesh where
the ratio of elements to nodes approaches 1:1 as the grid becomes large.

Memory required for a tetrahedral mesh is about 0.4 times the memory required for a hex mesh of the same number
of elements. Alternatively a tetrahedral mesh has about 2 times the required memory of a hexahedral mesh with the
same number of nodes.

Special Partitioner, Solver and Interpolator
Executables

On all systems there are default Partitioner, Solver and Interpolator executables. On some systems, there are additional
executables. There are currently two classes of special executables:

• Double-Precision Executables (p. 123)

• Large Problem Partitioner Executables (p. 123)

Double-Precision Executables
Double-precision executables store basic floating point numbers as 64 bit words. These executables are available
to permit more accurate numerical mathematical operations. Double precision accuracy might be needed if the
computational domain involves a huge variation in grid dimension, aspect ratio, pressure range, etc.

When double precision is used, the computer memory used for a given problem and grid size is double that of the
default (single precision) executable. Stated another way: the maximum problem size to run on a given computer
for the double precision executable is half that of the default single precision executable.

Large Problem Partitioner Executables
This special executable is only available on 64-bit platforms. The standard partitioner is currently limited to allocate
2^31-1 words of 4 byte integer stack space which limits the maximum problem size for partitioning to approximately
80 million elements (structured) and 200 million elements (unstructured).
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As a workaround, larger problems can be partitioned with the large problem partitioner. This executable internally
uses 8 byte integer data to perform the partitioning process. In theory, a maximum problem size of 2 billion elements
can be partitioned with this executable. However, practical considerations, such as available computer resources,
will still limit the maximum size.

Turbulence
The following topics will be discussed:

• Zero Equation Model (p. 124)

• Two-Equation Models (p. 124)

• Reynolds Stress Model (p. 124)

Zero Equation Model
The use of this model incurs a small increase in CPU time and memory requirements compared to laminar flow.

Two-Equation Models
Two additional scalar equations are solved when using two-equation turbulence models. The SST model has a slight
additional cost over other two equation models since a wall scale equation is also solved.

Consider the case of single phase, single component laminar flow in which the U-Mom, V-Mom, W-Mom, and
P-Mass equations are solved. Expect a CPU cost increase on the order of 50% by the addition of a two-equation
turbulence model. Memory requirement increases are small.

Reynolds Stress Model
This model adds six scalar equations for each of the Reynolds Stresses as well as the Eddy Dissipation equation. It
is approximately 2.5 times more expensive than the two equation turbulence models.

Consider the case of single phase, single component laminar flow in which the U-Mom, V-Mom, W-Mom, and
P-Mass equations are solved. Expect a CPU cost increase on the order of 120% by the addition of a Reynolds Stress
turbulence model. Memory requirement increases are small.

Energy Models
Both the thermal and total energy models require the solution of an additional scalar equation. The solution of the
energy equation typically requires 1/3 of the CPU required for the U-Mom, V-Mom, W-Mom, and P-Mass equations.
Memory requirement increases are small.

CHT Regions
Only the energy equation is solved in CHT regions, so compared to the same number of nodes in a fluid region, the
CPU costs are much less (U-Mom, V-Mom, W-Mom and P-Mass are not solved).

Multicomponent Flows
Each additional component adds an extra scalar equation. Therefore, as the number of components increase, CPU
time required to solve the Mass Fraction equation increases linearly. Expect each component to add approximately
25% to the CPU required for the U-Mom, V-Mom, W-Mom and P-Mass equations.

Multiphase Flows
The following topics will be discussed:

• Homogeneous Model (p. 125)

• Inhomogeneous Model (p. 125)
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• N-Phase Flow (p. 125)

Homogeneous Model
For two-phase flow using the homogeneous model, expect memory requirements to increase by a factor of 1.5 and
CPU time to increase by a factor of 1.7 over the same single-phase simulation. Enabling free surface does not
significantly alter CPU or memory requirements.

Inhomogeneous Model
For two-phase flow using the particle or mixture models, expect memory requirements to increase by a factor of
2.15 and CPU time to increase by a factor of 2.25. Enabling free surface does not significantly alter CPU or memory
requirements.

N-Phase Flow
As the number of fluids increase, expect memory and CPU requirements to increase approximately linearly for
small N. Tetrahedral meshes have more of a linear increase than hexahedral meshes. The table below gives
approximate memory increase factors for up to 5 phases when compared to the same single-phase simulation on a
hexahedral mesh.

Memory Increases# of Phases

(Tet Mesh)(Hex Mesh)

1.8011

3.402.152

5.703.503

8.055.154

10.607.005

Expect the CPU factor to be slightly less than the corresponding memory factors, but the trend is the same.

Additional Variables, Wall Distance Variables, and
Boundary Distance Variables

A single scalar equation is added for each Additional Variable. A single scalar equation is also added whenever the
Wall Distance variables or Boundary Distance variables are referenced in a CFX Expression Language (CEL)
expression, or when these quantities are required for a built-in model (for example, two equation-turbulence or
boundary-distance-based mesh-stiffness models). Note that Wall Distance values and Boundary Distance values
are derived from the solutions of the Wall Scale equations and Boundary Scale equations, respectively. Detailed
information on the wall scale equation is available at Wall and Boundary Distance Formulation (p. 50) in ANSYS
CFX-Solver Theory Guide.

Expect a CPU cost increase of approximately 20% for each Additional Variable over the solution of the U-Mom,
V-Mom, W-Mom, and P-Mass equations for a single-phase single-component case. Increases in memory requirements
are small.

Combustion Modeling
Modeling combustion incurs a slight cost compared to multicomponent flow with the same number of components.
For multi-step reactions each component is solved using the coupled solve. This incurs additional CPU time which
does not increase linearly with the number of components.
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Radiation Modeling
This adds a single scalar equation. Cost increases are similar to those of the energy equation. For details, see Energy
Models (p. 124).

GGI Interfaces
An intersection algorithm which is performed at the start of a simulation to connect each side of a GGI connection
incurs a one-time cost.

Each GGI connection means approximately 5% more CPU time and memory is required. This number can vary
greatly, as it is a function of the number of nodes involved in a GGI connection, compared to the number of nodes
that are not involved in the GGI connection. There is also a dependence on the geometric complexity of the GGI
connection.

Transient Runs
Each coefficient loop requires approximately the same CPU time as the equivalent steady-state iteration.

Mesh Deformation
Mesh deformation using either of the Regions of Motion Specified or Junction Box Routine
options introduces several CPU intensive operations during each outer iteration or time step. When deformation is
performed using Regions of Motion Specified, a Mesh Displacement equation is assembled and solved
at the start of each outer iteration or time step for Steady State and Transient simulations, respectively, and the mesh
coordinates are updated. When deformation is performed using a Junction Box Routine, you define how
mesh coordinates are updated.

After updating the mesh coordinates, other mesh related quantities (such as volumes, areas, mesh quality measures,
mesh velocities, etc.) are updated, and GGIs are re-intersected before advancing to solve other equations or physical
models for the current outer iteration or time step. Mesh volume flows that are later used to augment mass flow
rates applied in advective transport are precalculated and stored during these updates.

Depending on the complexity of the deformation and physical model (for example, the use of GGIs), adding the
mesh deformation to a simulation will increase CPU usage by approximately 10% to 50% per outer iteration or
time step.

Adding the mesh deformation will increase memory requirements due to the storage of: the noted mesh volume
flows (one per control volume integration point), and multiple sets of mesh coordinates for transient simulations
(one triplet per mesh vertex per time step that must be kept for the selected transient discretization).

Bi-Directional (Two-Way) Couplings with ANSYS
Multi-field

Enabling an external solver coupling with ANSYS Multi-field introduces a coupling (or stagger) iteration layer in
addition to the time step and coefficient loop iteration structure used for simulations involving CFX only. As outlined
in Bidirectional (Two-Way) FSI (p. 76), time steps are executed using a sequence of coupling iterations, which
involve one or more coefficient loop iterations within either the CFX or ANSYS field solver.

Additional memory is not required when external solver couplings are used. However, additional CPU time is
required because of the CFX solver coefficient loops performed per coupling iteration. In general, the CFX solver
CPU usage will increase by a factor that is slightly smaller than the number of coupling iterations required per time
step. A summary of expected CPU time increases is tabulated below, according to the degree of coupling between
the fluid and solid physical problems.

CPU IncreaseDegree of Coupling

2× to 5×Weak
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CPU IncreaseDegree of Coupling

5× to 10×Typical

> 10×Strong
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Chapter 14.The cfx5control Application
The cfx5control application can be used to dynamically control the CFX-Solver. The features available include:

• Stopping the solver running in the given directory at the end of the current timestep:

<CFXROOT>/bin/cfx5control <directory> -stop

• Instructing the solver running in the named directory to write a backup results file.

<CFXROOT>/bin/cfx5control <directory> -backup

• Editing the Command Language during a run:

<CFXROOT>/bin/cfx5control <directory> -edit-commands [-no-backup]

• Reading Command Language from a file and implementing it on the fly.

<CFXROOT>/bin/cfx5control <directory> -inject-commands <file> [-no-backup]

• Adjusting the priority of a CFX-Solver run by resetting the run priority on Windows or altering the nice increment
on non-Windows platforms. This applies to all solver processes in a parallel run.

<CFXROOT>/bin/cfx5control <directory> -reset-priority <level>

where <level> is one of Idle, Low, Standard or High, as given in the following table:

Windows PriorityUNIX nice inc.CFX Run Priority Level

Low190Idle

BelowNormal71Low

Normal02Standard

AboveNormal03High

If the current priority level is the same as <level> then there is no change. Administrative (or root) privileges
are usually required to increase the priority from a lower level to a higher level. When the change of priority is
attempted, then the CFX-Solver will write a diagnostic message into the CFX-Solver Output file of the form:

+--------------------------------------------------------------------+
|            ****** Updating Runtime Priority ******                 |
|                                                                    |
|      <outcome of the attempt to change the run priority>           |
|                                                                    |
+--------------------------------------------------------------------+

• Displaying help for this command:

<CFXROOT>/bin/cfx5control -help

In these examples:

• <CFXROOT> is the path to your installation of CFX

• <directory> specifies a directory in which the ANSYS CFX solver is currently running, such as
StaticMixer_004.dir.

• -no-backup prevents the solver from writing a backup file before reading the new Command Language file.
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Chapter 15. File Export Utility
The ANSYS CFX results file generated by a CFX-Solver run contains the details of the mesh used to perform the
calculation as well as details of the results variables that have been calculated. For details on which variables an
ANSYS CFX results file contains, see List of Field Variables (p. 162).

To postprocess an ANSYS CFX results file using software other than CFD-Post, the mesh and variables can be
extracted from the ANSYS CFX results file into a format compliant with the 3rd party software. ANSYS CFX
provides predefined translations to a number of different postprocessors and analysis packages, and CFX-Solver
Manager provides an interface to enable easy translation to these formats. A command line utility, cfx5export, can
be used to perform the same operations in batch mode.

The standard file formats that can be generated from ANSYS CFX are suitable for direct input into the following
software systems:

• ANSYS Multi-field

• All systems that support CGNS files

• MSC.Patran, from the MacNeal-Schwendler Corporation

• FIELDVIEW, from Intelligent Light

• EnSight, from Computational Engineering International, Inc.

It is also possible to write to other formats by creating a customized export program. See Creating a Customized
Export Program (p. 37).

When using CFX-Solver Manager, it is possible to export the results of a CFX-Solver run by selecting either Tools
> Export to ANSYS Multifield (see Export to ANSYS Multi-field solver Dialog (p. 131)) or Tools > Export (see
Export of Results to Other Formats (p. 132)).

This chapter describes:

• Export to ANSYS Multi-field solver Dialog (p. 131)

• Export of Results to Other Formats (p. 132)

• Generic Export Options (p. 132)

• Running cfx5export from the Command Line (p. 143)

• Exporting a Transient Results File (p. 147)

• Exporting Particle Tracking Data (p. 147)

• Using a Customized Export Program (p. 147)

Alternatively, it is possible to export the results directly from the command line. For details, see Running cfx5export
from the Command Line (p. 143).

Export to ANSYS Multi-field solver Dialog
The Export to ANSYS Multifield solver dialog is used to produce ANSYS .cdb files for use in Fluid Structure
Interaction cases. To display the dialog, select Tools > Export to ANSYS Multifield.

The sections that follow describe the Export Options fields on the dialog.

ANSYS Element Type
Selections correspond to the type of ANSYS element to export. The choices are 3D Thermal (element type 70),
2D Thermal (element type 152), and 2D Stress (element type 154). Refer to the Theory Reference for Mechanical
for a description of these element types.

Output Modifiers
The following scaling and offset factors can be used to change the units of the solution. The factors can be applied
when you need to convert the units that are written to the CFX file into those that you want to use in ANSYS.

The available modifiers are:
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• Offset Flow (p. 132)

• Offset Values (p. 132)

• Scale Flow (p. 132)

• Scale Values (p. 132)

Offset Flow
Default Value: 0

Requires a real number corresponding to the offset value applied to solution flows.

Offset Values
Default Value: 0

Requires a real number corresponding to the offset value applied to solution values.

Scale Flow
Default Value: 1

Requires a real number corresponding to the scaling factor applied to solution flows.

Scale Values
Default Value: 1

Requires a real number corresponding to the scaling factor applied to solution values.

Export of Results to Other Formats
To export CFX-Solver result to formats such as CGNS, EnSight, FIELDVIEW, MSC.Patran, or another customized
format, select Tools > Export from the menu bar of CFX-Solver Manager. The following section details the common
options that can be used when exporting results to the standard formats supported by ANSYS CFX.

Generic Export Options
To configure data for export, the Export dialog box must be displayed: select Tools > Export.

There are numerous export options when writing to the supported 3rd-party formats:

• Results File (p. ?)

• Domain Selection:Name (p. ?)

• Timestep Selection:Time (p. ?)

• Output Format (p. 133)

• Export File (p. 142)

• Output Only Boundary Geometry and Results (p. 142)

• Mesh Options: Use Initial Mesh for Rotating Domains (p. 142)

• Results Options: Output Level (p. 143)

• Results Options: Include Variables Only Found on Boundaries (p. 143)

• Results Options: Use Corrected Boundary Node Data (p. 143)

Results File
The name of the CFX-Solver results file to be exported.

Domain Selection:Name
The domain or domains in the CFX-Solver results file that are to be exported.
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Timestep Selection:Time
For transient CFX-Solver results files, the timestep to be exported.

Output Format
Default Value: CGNS

The output format selects which standard file format the output file will be written in. If a nonstandard format is
required, select Custom User Export.

The sections that follow describe the available output formats.

Note
For simulations with multiple configurations, *.mres files cannot be exported by the CFX-Solver
Manager.

CGNS
The CFD General Notation System (CGNS) is designed to facilitate the exchange of data between sites and
applications, and to help stabilize the archiving of data. The data is stored in a compact, binary format.

Note
To configure this option, select Tools > Export. The dialog box uses numerous common export options.
For details, see Generic Export Options (p. 132).

This section contains:

• Overview (p. 133)

• Available Options (p. 133)

• Exported Files (p. 134)

• Contents of CGNS Files Written by ANSYS CFX (p. 134)

• Reading Exported Files into a Program Supporting CGNS (p. 135)

Overview
CGNS consists of a collection of conventions for the storage and retrieval of CFD data. The system consists of two
parts:

• A standard format in which the data is recorded.

• Software that reads, writes, and modifies data in that format.

Available Options
The following options are available when writing a file in CGNS format:

• All options specified in Generic Export Options (p. 132)

• Geometry Output Only

• Default Value: Unselected.

• If selected, only mesh information and boundary condition information is written to the destination file—result
variables are not written.

• Output boundaries as

• Default Value: Nodes

• If Nodes are selected, all boundary conditions are written as collections of nodes; if Faces, then boundary
conditions are written as groups of 2D elements (faces). CFD-Post cannot read boundaries that are output
as Faces.
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• When Write Transient Data to One File is selected, all transient data (grid and results) are written to one
CGNS file using BaseIterativeData_t and ZoneIterativeData_t nodes within the file. When this
option is not selected, transient results are exported to a separate file for each timestep.

• When Use CGNS Variable Names is selected ANSYS CFX variable names are mapped to CGNS variable
names. For example Total Pressure becomes PressureStagnation.

Exported Files
The exported file set consists of either a single file for non-transient results, or multiple files for transient results.
Each contains a complete mesh and flow solution. By default all files are generated with a .cgns extension. Import
into a program that reads CGNS files should be done according to the importing program's instructions.

ANSYS CFX-Export is capable of writing CGNS Version 2.4 files. These CGNS files can be read by third parties
if they support the features CFX writes and are using CGNS Version 2.0 and above.

Note
A CGNS-valid file can be written in ADF or HDF5 format. CFX currently supports only ADF base files.
When HDF5 becomes standard practice, it is expected that both versions will be supported and identified
seamlessly.

Contents of CGNS Files Written by ANSYS CFX
The file produced contains grid and solution data. It does not contain problem setup (physics) information.

The amount of solution data and the type of grid written to the CGNS file is user controllable either on the command
line or via the GUI. What is seen in the CGNS file reflects what the user requests. There are files that when written
using some options may not be able to be reread into CFX-Pre. Caution must therefore be used if the original CFX
solution files are deleted, as it may not be possible to recover all information.

Names of variables, zones, and boundary conditions are always CGNS-compliant. The name seen within the CFX
application may have to be changed to achieve this.

The remainder of this sections describes the data records that are written when creating a CGNS file from ANSYS
CFX.

Base (Base_t)

A single base is written to each CGNS file.

• Its name is not significant.

• It is always written with a cell_dimension of 3 (that is, 3D).

If a transient file is being written, a simulation type (SimulationType_t) of TimeAccurate is specified
below the base node.

A state (ReferenceState_t) is also written below the base node with a description of where the file was
generated from and what it represents.

Zones (Zone_t)

A single zone is written under each Base_t node for each domain requested by the user and is always unstructured
in nature.

Coordinates of node data are always written in double precision. Due to the nature of the grid being unstructured,
there is no implicit ordering in how the grid is written.

Elements (Elements_t)

Element sections are written on a one per domain/subdomain basis as well as a one per boundary condition basis.
Due to the nature of CFX data, a single element cannot appear in more than one element section. Element numbering
is unique and consecutive.

You can control whether volume mesh (with surface mesh) or a surface mesh is written to the file.
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Boundary Conditions (BC_t)

Boundary Conditions are written. The location of each boundary condition is specified as set of 2D elements (faces)
or a set of nodes. The former is generally preferred as the latter can have some restrictions for the program that
reads the file.

No properties of the boundary condition are written other than its type.

Solution Data (FlowSolution_t)

Solution data is written where requested. Names are mapped to be CGNS compliant. No discrete data is currently
written. Where Wall Only data is present, “missing” solution data is written as 0.0.

Transient Data

Transient data is written to separate CGNS files by writing the Grid and Solution data for each CFX transient file
that is available to the cfx5export process.

ANSYS CFX Connectivity using CGNS for Aerodynamic Noise Analysis

Further information on exporting files is contained in Aerodynamic Noise Analysis (p. 311) in the ANSYS
CFX-Solver Modeling Guide.

Reading Exported Files into a Program Supporting CGNS
There is a wide range of products that can import CGNS files. Consult user documentation for the product being
used for further information.

Note
An issue was detected while reading a CGNS file in TecPlot 10 and earlier that prevented the files written
by ANSYS CFX being read by TecPlot. If a problem is encountered, try setting the environment variable
CFX5_EXPORT_CGNS_TECPLOT to a value of 1, restart ANSYS CFX, and export the CGNS file
again. If the problem persists, contact either ANSYS support or TecPlot support.

MSC.Patran
MSC.Patran is a general-purpose CAE simulation tool.

Note
To configure this option, select Tools > Export. The dialog box uses numerous common export options.
For details, see Generic Export Options (p. 132).

This section contains:

• Available Options (p. 135)

• Exported Files (p. 136)

• Reading Exported Files into MSC Patran (p. 136)

• Exporting Boundary Conditions to MSC.Patran (p. 136)

• Example Procedure (p. 137)

Available Options
The following options are available when writing a file in MASC.Patran format:

• All options specified in Generic Export Options (p. 132)

• Geometry Output Only (Neutral File)

• Default Value: Unselected.

If selected, the mesh from the ANSYS CFX results file is written to a Neutral file; solution variables are not
written to the Neutral file. For more details about MSC.Patran Neutral files, refer to your documentation
from MSC.Patran.
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Exported Files
The file set for this export option consists of three files:

File TypeFile Name

PATRAN Neutral File<basename>.out

PATRAN 2.5 Nodal Results File<basename>.nod

PATRAN Results Template File<basename>.results_tmpl

ANSYS CFX writes files in ASCII format using a subset of the record types to be found in the full definition of the
PATRAN file formats. The full definition of the PATRAN file formats can be found in the MSC.Patran
documentation.

Faces associated with the CFX boundaries and elements associated with subdomains are transferred into PATRAN
named components. The boundary/subdomain components are named using their CFX name.

Exported nodes are associated only with the PATRAN default_group, unless -nodes is used when cfx5export is
used from the command line.

Reading Exported Files into MSC Patran
The following procedure should be used for successfully import of results into MSC.Patran Version 2001r2. However,
this may need to be adapted depending on what MSC.Patran is used for. For more details about reading MSC Patran
Neutral files, see the MSC.Patran documentation.

Note
An MSC.Patran warning may appear when importing the Neutral file that reads No element type could
be found for element property set <P_SET.1>. No action needs to be taken.

1. Prepare the required PATRAN files.

Run cfx5export on the CFX results file, either using CFX-Solver Manager or directly from the command line.

2. Start PATRAN and create a new database.

Use File > New to create a new database. Click on Enable NFS access (on UNIX systems only). Enter a new
database name and click OK.

In New Model Preferences, choose the appropriate Analysis Code option for the analysis.

3. Import CFX-Mesh and results.

Use File > Import to access Import. Set Object/Source to Model/Neutral. Enter the name of the neutral
file produced by ANSYS CFX and click Apply. Acknowledge the first pop-up and answer Yes to the second
to continue.

Use Import again with Object/Source set to Results/PATRAN2.nod, to read the nodal results file produced
by cfx5export. Template for PATRAN 2.5 Import Results appears. Enter the name of the template file
produced by cfx5export, and click OK. Enter the nodal results file name in Import and click Apply.

4. Continue to use MSC.Patran as required.

Exporting Boundary Conditions to MSC.Patran
CFX can be used to provide data to be used as boundary conditions for other types of analysis in MSC.Patran.

MSC.Patran enables models to be prepared for several different kinds of analysis. It also has facilities for using
imported data to define data fields suitable for interpolating loads and boundary conditions onto the geometry or
the mesh of a new model.

A description of the relevant PATRAN facilities, in particular the Fields function and its applications, can be found
in the MSC.Patran documentation.
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Example Procedure
Here is an outline of some guidelines for one possible procedure for incorporating CFX results into a PATRAN
model. CFX temperature predictions will be used to define a temperature distribution on a geometry surface of a
new model. Details about any of the options can be found in the MSC.Patran documentation.

Points to note in this example are:

• Files generated by ANSYS CFX should be read into a new database first before any PATRAN model grid. This
ensures that the node numbers of the Neutral file correspond to the nodal result file. The nodes and elements in
the new model mesh will be numbered or renumbered to follow on from those in the CFX data.

• The CFX model should not be included in the new model analysis, but the CFX data must not be deleted until
the boundary values have been interpolated onto the new grid.

• The new model mesh can either be created or imported as part of step Step 6 (p. 137) or in a later step, without
affecting the procedure, because in this example the boundary condition is defined on geometry surfaces.

The example assumes exported results include the Temperature variable.

1. Prepare PATRAN Neutral and Nodal results files containing boundary data only.

Export the ANSYS CFX results file to MSC.Patran format, either using CFX-Solver Manager or directly from
the command line. Toggle Boundary Data Output Only on if using CFX-Solver Manager, or use the
-boundary option if using cfx5export from the command line.

2. Start PATRAN and create a new database.

Use File > New to create a new database. Click on Enable NFS access (on UNIX systems only). Enter a new
database name and click OK.

On New Model Preferences, choose the appropriate Analysis Code option, for example, PATRAN 2 NF.

3. Import CFX mesh and results.

Use File > Import. Set Object/Source to Model/Neutral. Enter the name of the Neutral file produced by
ANSYS CFX and click Apply. Acknowledge the pop-up to continue.

Use Import again with Object/Format set to Results/PATRAN2.nod, to read the nodal results file produced
by ANSYS CFX. Template for PATRAN 2.5 Import Results appears. Enter the name of the template file
produced by ANSYS CFX, and click OK. Enter the nodal results file name and click Apply.

4. Display temperature results as a fringe plot.

Select Group/Post to post just the group containing the boundary condition nodes to use. Select Results. On
Results, select the temperature results, and click Apply.

5. Create a continuous FEM field from the displayed variable.

Select the Fields option. Set Action/Object/Method to Create/Spatial/FEM. Enter a new name under
Field Name. Click the Continuous option. Select the relevant group under Mesh/Results Group Filter. Click
Apply.

6. Add the geometry for the new model.

Post the default_group and make it current using Group/Post. Use the toolbar icons to ensure the display will
be in wireframe mode rather than in hidden line mode. Then either create a geometry for the new PATRAN
model using the Geometry option to open the Geometry form or import the geometry from a previously
prepared database using File > Import with Object/Source set to Model/ MSC/PATRAN DB.

7. Define a temperature boundary condition on new geometry surfaces.

Select the Load/BCs option. Set Action/Object/Type to Create/Temperature/Nodal. Enter a name
under New Set Name. Click Input Data. Select the field in the Spatial Fields box and click OK. Under
Load/Boundary Conditions, click Select Application Region to display Select Application Region. Click
the Geometry option under Geometry Filter. In Select Geometric Entities, pick the surfaces to apply the
boundary condition to. Click Add and then OK. In Load/Boundary Conditions, click Apply. A temperature
distribution should now be visible on the relevant geometry surfaces, in the form of values shown at the
intersections of the surface display lines.
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8. Complete the PATRAN model.

FIELDVIEW
FIELDVIEW is a standalone CFD post processor supplied by Intelligent Light.

Note
To configure this option, select Tools > Export. The dialog box uses numerous common export options.
For details, see Generic Export Options (p. 132).

This section contains:

• Available Options (p. 138)

• Exported Files (p. 138)

• Reading Exported Files in FIELDVIEW (p. 139)

Available Options
The following options are available when writing a file for use in FIELDVIEW Unstructured format:

• All Options specified in Generic Export Options (p. 132).

• FV-UNS File Options: The options in this section detail the formatting of the separate grid and results files or
combined grid and results files that are written in FV-UNS (FIELDVIEW Unstructured) file format.

• Version:

• Default Value: 3.0

• The value selected details which version of the format should be used when writing the grid and results to
files for use within FIELDVIEW. It is recommended that you use the most recent version of the file format
supported by FIELDVIEW installed. Refer to the FIELDVIEW documentation for this information.

• Split Grid and Results Format:

• Default Value: Selected

• When selected, the grid from the ANSYS CFX results file is written to one file and the results to a second
or subsequent files. If not selected, a single combined file is written containing both the grid and the results.

Note
• This option is not available when the version is less than 2.7.

• If the number of variables that are to be written to the file exceeds 200, the results will be
written to more than one results file. Refer to FIELDVIEW 9 and later to learn how to load
multiple files into FIELDVIEW.

• Format:

• Default Value: Unstructured Binary

• This option enables a choice of whether the FV-UNS are written as in binary or ASCII format. The ASCII
format is human-readable but larger than the binary format. It is therefore recommended by ANSYS and
FIELDVIEW that binary format files be written in most cases.

• FV-REG Version:

• Default Value: 2.0

• The version specified here details the version of the format used when writing the region file for use in
FIELDVIEW. It is recommended that you specify the highest version that is supported by the version of
FIELDVIEW installed.

Exported Files
The file set for this export option consists of several files, depending on the format options selected.

If the output format is selected to be Split Grid and Results Format, more than one file will be generated with the
grid in one file and results in at least one other. Optionally, a region file will also be generated:
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File TypeFile Name

FIELDVIEW Grid File<basename>_grid.fv

FIELDVIEW Results File<basename>_results.fv

FIELDVIEW Region File<basename>_region.fv

If Split Grid and Results Format  (see Available Options (p. 138)) is not selected, then at least one combined grid
and results file will be generated:

File TypeFile Name

FIELDVIEW Combined Grid and Results File<basename>.fv

FIELDVIEW Region File<basename>_grid.fv.fvreg

Optionally, if particle tracks have been written in the ANSYS CFX results file, then these will be written to one or
more FIELDVIEW particle track files:

File TypeFile Name

FIELDVIEW Particle Track File<basename>_n.fv

ANSYS CFX writes a subset of record types that are available in the full FIELDVIEW file formats. The
documentation supplied with FIELDVIEW describes all the record types that can be read by different versions of
FIELDVIEW.

Reading Exported Files in FIELDVIEW
Files can be read into EnSight 5, 6, 7, and 8 as required:

• FIELDVIEW Versions 10.1 and Later (p. 139)

• FIELDVIEW Versions 9 and 10 (p. 140)

• FIELDVIEW Versions 6, 7, 8 (p. 140)

FIELDVIEW Versions 10.1 and Later

If the exported file is split into more than one file, it is necessary to follow a procedure similar to the following to
read each file in FIELDVIEW:

1. Select File > Data Input > ANSYS-CFX[FV-UNS Export]… .

2. On the ANSYS-CFX[FV-UNS Export]  form, ensure that the INPUT MODE is Replace.

3. If the file written is in Split Grid and Results format:

1. Click Read Grid or Combined Data.

2. Select the grid file from the file popup and click OK.

3. Click Read Results Data.

4. Select the first results file and click OK.

5. If further grid or results files are to be loaded, change the Input Mode to Append on the
ANSYS-CFX[FV-UNS Export] form and repeat from step “a” until all grid or results files have been
loaded.

4. If the file is a combined file:

1. Click Read Grid or Combined Data.

2. Select the combined file from the file popup and click OK.
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FIELDVIEW Versions 9 and 10

If the exported file is split into more than one file, it is necessary to follow a procedure similar to the following to
read each file in FIELDVIEW:

1. Select File > Data Input > Unstructured.

2. On the FV Unstructured form ensure that the INPUT MODE is Replace.

3. If the file written is in Split Grid and Results format:

1. Click Read Grid or Combined Data.

2. Select the grid file from the file popup and click OK.

3. Click Read Results Data.

4. Select the first results file and click OK.

5. If further grid or results files are to be loaded, change the input mode to Append on the FV Unstructured
form and repeat from step “a” until all grid or results files have been loaded.

4. If the file is a combined file:

1. Click Read Grid or Combined Data.

2. Select the combined file from the file popup and click OK.

FIELDVIEW Versions 6, 7, 8

The following procedure enables importing results into FIELDVIEW Version 6, 7 and 8.

Note
FIELDVIEW reads the version number from within the input file; however, some file formats that can
be generated by ANSYS CFX cannot be read by all version of FIELDVIEW. Refer to FIELDVIEW
documentation for exact details of which file formats can be processed by FIELDVIEW.

1. Select Data Files > Unstructured Data Input from the menu bar. In File Selection, select the file created
using cfx5export and then click OK. In Function Subset Selection, select All and click OK. Click Exit in
Unstructured Data Input.

2. The results can now be analyzed as required.

Note
The Region file written by ANSYS CFX to these versions of FIELDVIEW may have to be modified to
ensure correct axes of rotation and rotational velocities in FIELDVIEW.

If the ANSYS CFX file contains multiple rotation axes, it is not possible to write a single FIELDVIEW
file that can be correctly used in FIELDVIEW. In this case, you must write the file in “Split Grid and
Results Format”. For more details about reading FIELDVIEW Unstructured files, see the FIELDVIEW
documentation.

EnSight
EnSight is a suite of tools for engineering and scientific simulation.

Note
To configure this option, select Tools > Export. The dialog box uses numerous common export options.
For details, see Generic Export Options (p. 132).

This section contains:

• Available Options (p. 141)

• Export Files (p. 141)

• Reading Exported Files into EnSight (p. 141)
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Available Options
The following options are available when writing files for use in EnSight:

• All options specified in Generic Export Options (p. 132)

• EnSight Version:

• Default Value: Gold

• The selection specifies the EnSight file format version to which the output will adhere. It is recommended
that Gold be selected wherever possible. Refer to the EnSight documentation for differences between the
different formats.

• Format:

• Default Value: Unstructured Binary

• This option enables you to choose whether the EnSight data files are written as in binary or ASCII format.
The ASCII format is human-readable but larger than the binary format. It is therefore recommended by
ANSYS that binary format files are written in most cases.

Export Files
The file set for this export option consists of the following files:

File TypeFile Name

EnSight Geometry File<basename>.geom

EnSight Results File (version 5 only)<basename>.results

EnSight Variable Files for scalar variable<basename>.s01 (etc.)

EnSight Variable Files for vector variables<basename>.v01 (etc.)

EnSight case files (EnSight 6 and later).<basename>.case

Note
• Each subdomain and boundary condition is exported as one EnSight part.

• CFX variable aliases have to be modified (by removing spaces and special characters and by limiting
the name length) to create valid EnSight variable names. In some cases the names that result may
not be human recognizable; in all cases the mapping from the name used in ANSYS CFX to that
written to the EnSight file is displayed in the progress window of the Solver Manager.

ANSYS CFX uses a subset of record types that are available in the full EnSight file formats. The documentation
supplied with EnSight describes all the record types that can be used.

Reading Exported Files into EnSight
Files can be read into EnSight 5, 6, 7, and 8 as required.

• EnSight 8.2 and Later (p. 141)

• EnSight 6, 7, and 8.0 (p. 142)

• EnSight 5 (p. 142)

EnSight 8.2 and Later

The following procedure enables importing results into EnSight 8.2 and later. For more details about importing,
see the EnSight documentation.

1. Select File > Open.

2. Select the Format as Case.

3. Choose the case file that has been exported. All files produced by CFX-Solver Manager are automatically
loaded.
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EnSight 6, 7, and 8.0

The following procedure enables importing results into EnSight 6, 7, or 8.0. Results files may need modification,
depending on how they are to be used with EnSight. For more details about importing, see the EnSight documentation.

1. Select File > Data Reader.

2. Select the Format as Case.

3. Choose the case file that has been exported. All files produced by CFX-Solver Manager are automatically
loaded.

EnSight 5

The following procedure enables importing results into EnSight 5. Results files may need modification, depending
on how they are to be used with EnSight. For more details about importing, see the EnSight documentation.

1. Select File > Data (Reader). In File Selection, click the name of the geometry file created using cfx5export,
and then click on (Set) Geometry.

2. Click on the name of the EnSight results file. Click (Set) Result and then click Okay.

3. In Data Part Loader, click Load All, and then click Close.

4. The results can now be analyzed as required.

Custom User Export
Files can be exported to a custom format from CFX-Solver Manager. To do so, a custom export program must be
created. For information on all the ways of using a custom export program, see Using a Customized Export
Program (p. 147). For details on creating a custom export program, see Creating a Customized Export Program (p.
37).

Export File
This option specifies the destination file to which the grid and results will be written. This file name may be altered
in such a way that multiple files may be written with transient data or if the Output Format requires multiple files
to be written.

Output Only Boundary Geometry and Results
Availability: All Standard Formats (CGNS, MSC.Patran, FIELDVIEW and EnSight). Available only when Geometry
Output Only is not selected.

Default Value: Not selected.

If selected, only the data for nodes on the boundaries is output. This can be used, for example, to enable results
from CFD calculations to provide boundary conditions for other analysis in other packages.

Mesh Options: Use Initial Mesh for Rotating Domains
Availability: All Standard Formats (CGNS, MSC.Patran, FIELDVIEW and EnSight)

Default Value: Not selected.

By default, the mesh for any rotating domain is rotated into the correct position for the timestep when exporting,
as long as the angular velocity is specified as a single value (i.e. not using the CFX Expression Language). You can
choose to always write the mesh as it was positioned at the initial timestep by selecting the option Use Initial Mesh
for Rotating Domains.

If the angular velocity of the rotating domain is specified in terms of an expression, then the mesh is always exported
in its initial position and never rotated, and the Use Initial Mesh for Rotating Domains option is ignored.

The calculation of the correct rotated position assumes that the initial run was started from a time value of 0 [s],
and that the simulation time is continuous from 0 [s] through every run and restart (i.e. the Initial Time is not reset
by using the Value option). If this is not the case, then you should select Use Initial Mesh for Rotating Domains
option to write the mesh as it was positioned at the initial timestep, to avoid incorrectly rotated meshes.

Release 12.0 - © 2009 ANSYS, Inc. All rights reserved.

142 Contains proprietary and confidential information of ANSYS, Inc. and its subsidiaries and affiliates.

Export File



Results Options: Output Level
Availability: All Standard Formats (CGNS, MSC.Patran, FIELDVIEW and EnSight)

Default Value: 1.

The output level selects a predefined subset of variables to write to the destination results file. Each variable is given
a “user level” by CFX-Solver. For details, see List of Field Variables (p. 162).

An output level of:

• 1 writes a small subset of basic variables such as velocity and pressure, which have user level 1.

• 2 writes all variables that are of user levels 1 and 2.

• 3 writes all variables stored in the CFX results file.

Results Options: Include Variables Only Found on Boundaries
Availability: All Standard Formats (CGNS, MSC.Patran, FIELDVIEW and EnSight)

Default Value: Not selected.

If selected, the variables that exist only on boundaries (such as +y ) are written in addition to those variables which
have values in the interior of the domain(s).

Results Options: Use Corrected Boundary Node Data
Availability: All Standard Formats (CGNS, MSC.Patran, FIELDVIEW and EnSight)

Default Value: Selected

The values of some variables on the boundary nodes (that is, on the edges of the geometry) are not precisely equal
to the specified boundary conditions when CFX-Solver finishes calculations.

For instance, the value of velocity on a node on the wall will not be precisely zero, and the value of temperature on
an inlet may not be precisely the specified inlet temperature. For visualization purposes, it can be more helpful if
the nodes at the boundary contain the specified boundary conditions and so Use Corrected Data on Boundary
Nodes should be selected for these cases.

Corrected boundary node values are obtained by taking the results produced by CFX-Solver (called “conservative
values”) and overwriting the results on the boundary nodes with the values specified by the boundary conditions
set up in CFX-Pre. This ensures, for example, that velocity is displayed as zero on no-slip walls and is equal to the
specified inlet velocity on an inlet. Using corrected boundary node values is equivalent to selecting conservative
variables as described in Hybrid and Conservative Variable Values (p. 161) in the ANSYS CFX Reference Guide..

Running cfx5export from the Command Line
In the following code, [] denotes an optional argument, and <> and # denote that substitution of a suitable value
is required. All other arguments are keywords, some of which may have a short form.

Note
-cgns, -ensight, -fieldview, -patran, or -custom should be the first option on the command
line.

• -cgns creates files suitable for an application that supports the CGNS format.

• -ensight creates files suitable for input into the EnSight post-processor.

• -patran creates files suitable for input into the MSC/PATRAN post-processor.

• -fieldview creates files suitable for input into the FIELDVIEW post-processor.

• -custom should be used if there is a need for custom-defined export formats. For details, see Running a
Customized Export Program using cfx5export from the Command Line (p. 148).

For all standard options (-cgns, -patran, -fieldview, and -ensight), the source ANSYS CFX file <file>
is the same file as would be specified under Tools > Export > Results File in CFX-Solver Manager. The optional
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file entered as -name <file> is the filename used as the basename for the files generated as part of the export
process (this is equivalent to what is specified under Tools > Export > Export File).

Running cfx5export
To run cfx5export from the command line, type one of the following commands into a UNIX terminal or a suitable
Windows command line and press Return or Enter. For details, see Command Line (p. 3) in the ANSYS CFX
Reference Guide.

 cfx5export -ansysfsi [-domain <number>] [-help] [-name <file>] \
  [-offset-flow <number>] [-offset-val <number>] \
  [-scale-flow <number>] [-scale-val <number>] \
  [-summary] [-timestep <number>] [-verbose] \
  [-eltype <element type>] [-regions <region1><,region2>...] <file>

or

cfx5export -cgns [-boundary] [-corrected] [-C] \ 
 [-domain <number>] [-geometry] [-help] [-name <file>] \
 [-summary] [-timestep <number>] [-user <level>] [-norotate] \
 [-boundaries-as-nodes|-boundaries-as-faces] [-verbose] <file>

or

cfx5export -ensight [-5|-6|-7] [-absolute] [-ascii|-binary] \
 [-corrected] [-domain <number>] [-help] [-include] [-long] \
 [-name <file>] [-summary] [-timestep <number>] [-user <level>] \
 [-verbose] <file>

or

cfx5export -fieldview [-UNS[2.4|2.5|2.6|2.7|3.0]] [-REG[1.0|2.0]] \
 [-absolute] [-ascii] [-corrected] [-domain <number>] [-noparticles] \
 [-include] [-name <file>] [-summary] [-timestep <number>] \ 
 [-user <level>] [-norotate] [-verbose] <file>

or

cfx5export -patran [-absolute] [-boundary] [-corrected] [-domain <number>] \
 [-geometry] [-help] [-include] [-name <file>] [-nodes] [-summary] \
 [-timestep <number>] [-user <level>] [-norotate] [-verbose] <file>

or

cfx5export [-exec <executable>] -custom [<options>]

Keyword Descriptions
A basic description of the keywords is given below.

UsageAlternative formArgument

Write an EnSight Version 5 case file instead of an
EnSight Version 7 results file.

-5

Write an EnSight version 6 file instead of an EnSight
version 7 file.

-6

Write an EnSight version 7 file (default)-7
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UsageAlternative formArgument

Write the output file in ASCII format, rather than
unstructured binary format.

-s-ascii

Write the output file in unstructured binary format.-binary

Boundary data only. Using this argument corresponds
to selecting the option Boundary Data Output Only
when using cfx5export from CFX-Solver Manager.

-b-boundary

Write boundary conditions as collections of faces rather
than nodes.

-boundaries-as-faces

Write boundary conditions as collections of nodes rather
than faces (default).

-boundaries-as-nodes

Export data in the CGNS format-cgns

Map CFX variable names to CGNS variable names
(where possible).

-cgns-names

Use corrected boundary node values. This corresponds
to enabling Use Corrected Boundary Node Data when
using Tools > Export from CFX-Solver Manager.

-c-corrected

Save all timesteps into one CGNS file.-C-one-file-for-transient-cases

Use custom export program defined by the
CFX_EXPORT_EXEC variable. If this option is

-custom <options>

specified no further argument checking is done and all
remaining options on the command line are passed
straight to the export program. For details, see Generic
Export Options (p. 132).

Specifies the domain of interest. If <number> is
non-zero, cfx5export will export just the given domain.

-d <number>-domain <number>

If <number> is zero, the data is combined and exported
as a single domain. The default value is 0.

Export data for use with EnSight.-ensight

An alternative way of specifying the custom export
executable dynamically, without having to create a

-exec <executable>

cfx5rc file. Note that this parameter must appear before
the -custom switch.

Export data for use with FIELDVIEW.-fv-fieldview

Geometry data only (no results). Using this option
corresponds to choosing Geometry Output Only

-g-geometry

(Neutral File) when using cfx5export from CFX-Solver
Manager.

Print this information.-h-help

Include boundary node only data. If you specify this

option, then variables such as +y  (which have

-i-include

meaningful values only on the boundary nodes) will be
exported.

Use long variable names.-l-long
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UsageAlternative formArgument

Write all transient data to a single CGNS file using
BaseIterative_t and ZoneIterative_t nodes.

-one-file-for-transient-cases

Set the basename for the output files to <base> instead
of the name of the input file. If you do not use this

-output
<base> -out
<base>

-name <base>

option, the exported files will be written in the same
directory as the input file. You need to take care when
selecting this name to avoid your CFX results file being
overwritten.

Use nodes when exporting packet 21 data (groups).-n-nodes

Do not write particle track files.-noparticles

Do not rotate the grid to its true position. For details,
see Mesh Options: Use Initial Mesh for Rotating
Domains (p. 142).

-norotate

Export data for use with MSC/PATRAN.-patran

Specifies the version used when writing the
FIELDVIEW region file.

-REG <version>

Use the FIELDVIEW Split Grid and Results file format
when writing grid and results files.

-split-grid-and-results

Displays a summary of the domains and timesteps
contained in the CFX results file.

-f-summary

If the <number> is non-zero, data for the given timestep
in a transient run is exported. If <number> is -1, data

-time
<number>

-timestep <number>

from all timesteps is exported. If the -timestep switch
is not given, data from the last timestep will be exported.

-t <number>

Specifies the file format version when writing
FIELDVIEW Grid and Results files.

-UNS<version>

User level of interest: <level> should be a number
1, 2 or 3, and this corresponds to selecting Output Level

-u <level>-user <level>

1, 2 or 3 when using cfx5export from CFX-Solver
Manager.

Specifying this option may result in additional output
being sent to the standard output file (normally the
screen).

-v-verbose

Name of CFX results file from which data is to be
exported. The names of the file(s) created depends on
the format being written.

<file>

CGNS files will be written to <file>.cgns

EnSight geometry will be written to <file>geom, the
results file to <file>.res, and the variables to
<file>.s## or <file>.v## where ## is the
variable number and s indicates a scalar and v a vector
unless the -name option is used.

Patran geometry will be written to <file>.out as a
Neutral file, the results template to
<file>.res_tmpl, and the nodal results to
<basename>.nod unless the name option is used.
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UsageAlternative formArgument

Fieldview geometry will be written to <file>.fv
unless the -name option is used.

Note: The files will be created in the same directory as
the original files, not necessarily in the current working
directory.

Exporting a Transient Results File
If you have completed a transient run, you have several options for exporting the results. You can elect to:

• Export the results file, which contains the solution to the final timestep.

• Export one or more of the preliminary timestep solutions.

• Export all of the timesteps.

You can use either CFX-Solver Manager or the cfx5export script to export a transient file.

• Generic Export Options (p. 132)

• Running cfx5export from the Command Line (p. 143)

File Format
If you elect to export the results file, which contains the solution to the final timestep, the format will be:

filename.ext

where .ext is based on the format being written.

However, if you elect to export a different timestep, then the export file will have the following format:

filename_t#.ext

where # is the value of the timestep exported.

Note
EnSight transient files will be sequentially numbered, regardless of the timestep value. For example, if
timesteps of 1s, 5s, and 7s are exported, they will have the filenames filename_t1.ext,
filename_t2.ext and filename_t3.ext.

Exporting Particle Tracking Data
Export of particle tracking data is currently supported only to FIELDVIEW. Export of particle tracking data to any
other format is not supported in the current release of ANSYS CFX.

Using a Customized Export Program
There are multiple ways in which an export program can be used once it has been compiled.

• Using a Customized Export Program from CFX-Solver Manager (p. 147)

• Using a Customized Export Program from the Command Line (p. 148)

Using a Customized Export Program from CFX-Solver Manager
Open the Export dialog box by selecting Export from the Tools menu of CFX-Solver Manager.

1. Set Output Format to Custom User Export.

2. Supply the path to the compiled program in Export Executable.
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3. Enter any associated options required to run the customized program (such as would be entered at the command
line) in Custom Export Setting.

4. The specified custom export program runs with the associated arguments when you click Export.

Using a Customized Export Program from the Command Line
You may run your program directly from the command line started from the launcher (Tools > Command Line).
Such a command line will have the environment variables and path set appropriately.

Important
It is important to run the command line in the CFX environment. For details, see Command Line (p. 3)
in the ANSYS CFX Reference Guide.

Running a Customized Export Program Directly from the Command Line
For the purposes of describing what you can do, assume that the executable file is called myexport and is contained
in the directory /home/smith/export/ (UNIX) or c:\smith\export (Windows). You want to specify
the results file called file.res in the same directory and make the basename example.

UNIX
To run the program directly on a UNIX system, open a command line started from the launcher (Tools > Command
Line) and call your program using:

./myexport file.res example

assuming that the current directory is /home/smith/export/.

Windows
On a Windows machine, run the program by opening a command line started from the launcher (Tools > Command
Line), changing directory to c:\smith\export, and typing:

myexport file.res example

Note
Just double-clicking on the name of the program in the Windows Explorer, or using the Execute
myexport.exe option in Microsoft Developer Studio does not readily give you the option to enter
command-line arguments.

Running a Customized Export Program using cfx5export from the Command
Line

Your executable can be run directly from the command line by using the cfx5export command. This enables you
to issue an export command without specifying the location of the executable each time; an environment variable
remembers the location of the custom export executable.

For the purposes of describing the procedure, assume the executable file is called myexport and is contained in the
directory /home/smith/export/ (UNIX) or c:\smith\export (Windows). Specify the results file called
file.res in the same directory and make the basename example.

To run the program using the cfx5export -custom command, add the following line to the .cfx5rc file:

CFX_EXPORT_EXEC="<executable_path>"

where <executable_path> is the full path and name of the executable (for example,
/home/smith/export/myexport or c:\smith\export\myexport as appropriate). For details, see
Resources Set in cfx5rc Files (p. 38) in the ANSYS CFX Introduction.

The cfx5export command can be used with the custom argument for the given example. Type:
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cfx5export -custom file.res example

into a UNIX terminal or a suitable Windows command prompt and press Return or Enter. For details, see Command
Line (p. 3) in the ANSYS CFX Reference Guide.
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